aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-01-04 19:20:42 +0800
committermat <mat@FreeBSD.org>2016-01-04 19:20:42 +0800
commit9e8a46eb4de1c9ffdd3e1d3c8d8e9687dc8cf71c (patch)
treec66da8302c9e4961f7199d0afdaac10e06c87784 /lang
parent96371a9ae5b48fe4dc4d4139f5ca21a53ddc5819 (diff)
downloadfreebsd-ports-graphics-9e8a46eb4de1c9ffdd3e1d3c8d8e9687dc8cf71c.tar.gz
freebsd-ports-graphics-9e8a46eb4de1c9ffdd3e1d3c8d8e9687dc8cf71c.tar.zst
freebsd-ports-graphics-9e8a46eb4de1c9ffdd3e1d3c8d8e9687dc8cf71c.zip
Update to v5.23.6-46-g476d3d3.
Changes: https://github.com/Perl/perl5/compare/v5.23.6-31-g7c69ad4...v5.23.6-46-g476d3d3 Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/perl5-devel/Makefile2
-rw-r--r--lang/perl5-devel/distinfo4
-rw-r--r--lang/perl5-devel/files/patch-cpan_podlators_lib_Pod_Man.pm107
-rw-r--r--lang/perl5-devel/files/patch-cpan_podlators_t_devise-date.t39
4 files changed, 3 insertions, 149 deletions
diff --git a/lang/perl5-devel/Makefile b/lang/perl5-devel/Makefile
index ede5e28919e..1262464330e 100644
--- a/lang/perl5-devel/Makefile
+++ b/lang/perl5-devel/Makefile
@@ -29,7 +29,7 @@ TEST_ENV= ${MAKE_ENV} TEST_JOBS=${MAKE_JOBS_NUMBER}
USE_GITHUB= yes
GH_ACCOUNT= Perl
GH_PROJECT= perl5
-GH_TAGNAME= v5.23.6-31-g7c69ad4
+GH_TAGNAME= v5.23.6-46-g476d3d3
OPTIONS_DEFINE= DEBUG GDBM PERL_64BITINT PTHREAD \
MULTIPLICITY SITECUSTOMIZE
diff --git a/lang/perl5-devel/distinfo b/lang/perl5-devel/distinfo
index 977f16975f1..77c1076ef83 100644
--- a/lang/perl5-devel/distinfo
+++ b/lang/perl5-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (perl/perl-5.23.6-31_GH0.tar.gz) = 858b3efcb104f905653afe0e7c7090b060d61b0df535cf93cff463e91d046328
-SIZE (perl/perl-5.23.6-31_GH0.tar.gz) = 17654412
+SHA256 (perl/perl-5.23.6-46_GH0.tar.gz) = 7ca7e04ac7e239afb791e1d92167ad52ea6af0b670ef729d6b3180453a57137e
+SIZE (perl/perl-5.23.6-46_GH0.tar.gz) = 17690370
diff --git a/lang/perl5-devel/files/patch-cpan_podlators_lib_Pod_Man.pm b/lang/perl5-devel/files/patch-cpan_podlators_lib_Pod_Man.pm
deleted file mode 100644
index 438678c83c5..00000000000
--- a/lang/perl5-devel/files/patch-cpan_podlators_lib_Pod_Man.pm
+++ /dev/null
@@ -1,107 +0,0 @@
---- cpan/podlators/lib/Pod/Man.pm.orig 2015-04-15 07:47:18 UTC
-+++ cpan/podlators/lib/Pod/Man.pm
-@@ -876,25 +876,42 @@ sub devise_title {
- }
-
- # Determine the modification date and return that, properly formatted in ISO
--# format. If we can't get the modification date of the input, instead use the
--# current time. Pod::Simple returns a completely unuseful stringified file
--# handle as the source_filename for input from a file handle, so we have to
--# deal with that as well.
-+# format.
-+#
-+# If POD_MAN_DATE is set, that overrides anything else. This can be used for
-+# reproducible generation of the same file even if the input file timestamps
-+# are unpredictable or the POD coms from standard input.
-+#
-+# Otherwise, use the modification date of the input if we can stat it. Be
-+# aware that Pod::Simple returns the stringification of the file handle as
-+# source_filename for input from a file handle, so we'll stat some random ref
-+# string in that case. If that fails, instead use the current time.
-+#
-+# $self - Pod::Man object, used to get the source file
-+#
-+# Returns: YYYY-MM-DD date suitable for the left-hand footer
- sub devise_date {
- my ($self) = @_;
-+
-+ # If POD_MAN_DATE is set, always use it.
-+ if ($ENV{POD_MAN_DATE}) {
-+ return $ENV{POD_MAN_DATE};
-+ }
-+
-+ # Otherwise, get the input filename and try to stat it. If that fails,
-+ # use the current time.
- my $input = $self->source_filename;
- my $time;
- if ($input) {
-- $time = (stat $input)[9] || time;
-+ $time = (stat($input))[9] || time();
- } else {
-- $time = time;
-+ $time = time();
- }
-
-- # Can't use POSIX::strftime(), which uses Fcntl, because MakeMaker
-- # uses this and it has to work in the core which can't load dynamic
-- # libraries.
-- my ($year, $month, $day) = (localtime $time)[5,4,3];
-- return sprintf ("%04d-%02d-%02d", $year + 1900, $month + 1, $day);
-+ # Can't use POSIX::strftime(), which uses Fcntl, because MakeMaker uses
-+ # this and it has to work in the core which can't load dynamic libraries.
-+ my ($year, $month, $day) = (localtime($time))[5,4,3];
-+ return sprintf("%04d-%02d-%02d", $year + 1900, $month + 1, $day);
- }
-
- # Print out the preamble and the title. The meaning of the arguments to .TH
-@@ -1632,6 +1649,15 @@ argument.
- Sets the centered page header to use instead of "User Contributed Perl
- Documentation".
-
-+=item date
-+
-+Sets the left-hand footer. If this option is not set, the contents of the
-+environment variable POD_MAN_DATE, if set, will be used. Failing that,
-+the modification date of the input file will be used, or the current time
-+if stat() can't find that file (which will be the case if the input is
-+from C<STDIN>). If obtained from the file modification date or the
-+current time, he date will be formatted as C<YYYY-MM-DD>.
-+
- =item errors
-
- How to report errors. C<die> says to throw an exception on any POD
-@@ -1642,13 +1668,6 @@ POD errors entirely, as much as possible
-
- The default is C<pod>.
-
--=item date
--
--Sets the left-hand footer. By default, the modification date of the input
--file will be used, or the current date if stat() can't find that file (the
--case if the input is from C<STDIN>), and the date will be formatted as
--C<YYYY-MM-DD>.
--
- =item fixed
-
- The fixed-width font to use for verbatim text and code. Defaults to
-@@ -1810,6 +1829,20 @@ option was set to C<die>.
-
- =back
-
-+=head1 ENVIRONMENT
-+
-+=over 4
-+
-+=item POD_MAN_DATE
-+
-+If set, this will be used as the value of the left-hand footer unless the
-+C<date> option is explicitly set, overriding the timestamp of the input
-+file or the current time. This is primarily useful to ensure reproducible
-+builds of the same output file given the same souce and Pod::Man version,
-+even when file timestamps may not be consistent.
-+
-+=back
-+
- =head1 BUGS
-
- Encoding handling assumes that PerlIO is available and does not work
diff --git a/lang/perl5-devel/files/patch-cpan_podlators_t_devise-date.t b/lang/perl5-devel/files/patch-cpan_podlators_t_devise-date.t
deleted file mode 100644
index 3023a2a5b49..00000000000
--- a/lang/perl5-devel/files/patch-cpan_podlators_t_devise-date.t
+++ /dev/null
@@ -1,39 +0,0 @@
---- cpan/podlators/t/devise-date.t.orig 2015-04-15 07:47:18 UTC
-+++ cpan/podlators/t/devise-date.t
-@@ -1,15 +1,28 @@
--#!/usr/bin/perl -w
--
--# In order for MakeMaker to build in the core, nothing can use
--# Fcntl which includes POSIX. devise_date()'s use of strftime()
--# was replaced. This tests that it's identical.
-+#!/usr/bin/perl
-+#
-+# In order for MakeMaker to build in the core, nothing can use Fcntl which
-+# includes POSIX. devise_date()'s use of strftime() was replaced. This tests
-+# that it's identical. It also tests special handling of the POD_MAN_DATE
-+# environment variable.
-
-+use 5.006;
- use strict;
--
--use Test::More tests => 1;
-+use warnings;
-
- use Pod::Man;
- use POSIX qw(strftime);
-
-+use Test::More tests => 2;
-+
-+# Check that the results of device_date matches strftime. There is no input
-+# file name, so this will use the current time.
- my $parser = Pod::Man->new;
--is $parser->devise_date, strftime("%Y-%m-%d", localtime);
-+is(
-+ $parser->devise_date,
-+ strftime('%Y-%m-%d', localtime()),
-+ 'devise_date matches strftime'
-+);
-+
-+# Set the override environment variable and ensure that it's honored.
-+local $ENV{POD_MAN_DATE} = '2014-01-01';
-+is($parser->devise_date, '2014-01-01', 'devise_date honors POD_MAN_DATE');