aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-11-20 08:03:20 +0800
committergerald <gerald@FreeBSD.org>2009-11-20 08:03:20 +0800
commitb33f7a191e36ece7c0cf69838d5a55d17e884493 (patch)
treecd534631a9ee9191bcbdda3869b27a75fd642cc3 /lang
parentf4d927a198be679522726152e26f0933a0771717 (diff)
downloadfreebsd-ports-graphics-b33f7a191e36ece7c0cf69838d5a55d17e884493.tar.gz
freebsd-ports-graphics-b33f7a191e36ece7c0cf69838d5a55d17e884493.tar.zst
freebsd-ports-graphics-b33f7a191e36ece7c0cf69838d5a55d17e884493.zip
No longer download Objective-C related files which we don't actually use.
Minor style changes. Adjust the ports description to the new style I am using for the various gcc ports and remove an obsolete note on memory consumption when building libgcj (the Java library).
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc/Makefile7
-rw-r--r--lang/gcc/distinfo3
-rw-r--r--lang/gcc/pkg-descr11
-rw-r--r--lang/gcc45/Makefile7
-rw-r--r--lang/gcc45/distinfo3
-rw-r--r--lang/gcc45/pkg-descr11
-rw-r--r--lang/gcc46/Makefile7
-rw-r--r--lang/gcc46/distinfo3
-rw-r--r--lang/gcc46/pkg-descr11
-rw-r--r--lang/gcc47/Makefile7
-rw-r--r--lang/gcc47/distinfo3
-rw-r--r--lang/gcc47/pkg-descr11
-rw-r--r--lang/gcc48/Makefile7
-rw-r--r--lang/gcc48/distinfo3
-rw-r--r--lang/gcc48/pkg-descr11
15 files changed, 30 insertions, 75 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 05ac9e889ad..ba557f6bcbc 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
+ gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
@@ -37,8 +36,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
+MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -61,7 +60,7 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --disable-nls \
+CONFIGURE_ARGS+=--disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--with-gmp=${LOCALBASE} \
diff --git a/lang/gcc/distinfo b/lang/gcc/distinfo
index 10d8d78399f..ae5068d6a8a 100644
--- a/lang/gcc/distinfo
+++ b/lang/gcc/distinfo
@@ -7,9 +7,6 @@ SIZE (gcc-fortran-4.5-20091112.tar.bz2) = 1398510
MD5 (gcc-g++-4.5-20091112.tar.bz2) = d170a2b484213197a090b78b89478d61
SHA256 (gcc-g++-4.5-20091112.tar.bz2) = 820a66a18db85141e61140fa4e7201d5bb593063ee2f0fba612f185e43020e5e
SIZE (gcc-g++-4.5-20091112.tar.bz2) = 6296128
-MD5 (gcc-objc-4.5-20091112.tar.bz2) = 8c4e9dcd562bc5a574a7565d3e56b439
-SHA256 (gcc-objc-4.5-20091112.tar.bz2) = c35ac2d22088f14ce7f0fa600bd4a53b842cab9e348ae14bb6a08e41b1438c7e
-SIZE (gcc-objc-4.5-20091112.tar.bz2) = 246813
MD5 (gcc-testsuite-4.5-20091112.tar.bz2) = c4ba0cbc7e01a43482f0aa227b308ba0
SHA256 (gcc-testsuite-4.5-20091112.tar.bz2) = a2e79c827b8434ed6262827435f1b63ef5c823be009681b74d790c2078052fad
SIZE (gcc-testsuite-4.5-20091112.tar.bz2) = 5407113
diff --git a/lang/gcc/pkg-descr b/lang/gcc/pkg-descr
index eb55b684219..b9940115e27 100644
--- a/lang/gcc/pkg-descr
+++ b/lang/gcc/pkg-descr
@@ -1,11 +1,6 @@
-GCC, the GNU Compiler Collection includes C, C++, Java and Fortran.
-
-This port installs the various front ends as gcc45, g++45, gcj45,
-gfortran45 and so forth into the ${PREFIX}/bin directory.
-
-(Building the Java frontend and the associated libgcj library will
-consume more than 512MB of main memory. Set WITHOUT_JAVA=yes in
-the environment when building this port to avoid that.)
+GCC, the GNU Compiler Collection, supports a number of languages. This
+port installs the C, C++, Fortran and Java front ends as gcc45, g++45,
+gfortran45, and gcj45, respectively.
WWW: http://gcc.gnu.org/
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 05ac9e889ad..ba557f6bcbc 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
+ gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
@@ -37,8 +36,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
+MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -61,7 +60,7 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --disable-nls \
+CONFIGURE_ARGS+=--disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--with-gmp=${LOCALBASE} \
diff --git a/lang/gcc45/distinfo b/lang/gcc45/distinfo
index 10d8d78399f..ae5068d6a8a 100644
--- a/lang/gcc45/distinfo
+++ b/lang/gcc45/distinfo
@@ -7,9 +7,6 @@ SIZE (gcc-fortran-4.5-20091112.tar.bz2) = 1398510
MD5 (gcc-g++-4.5-20091112.tar.bz2) = d170a2b484213197a090b78b89478d61
SHA256 (gcc-g++-4.5-20091112.tar.bz2) = 820a66a18db85141e61140fa4e7201d5bb593063ee2f0fba612f185e43020e5e
SIZE (gcc-g++-4.5-20091112.tar.bz2) = 6296128
-MD5 (gcc-objc-4.5-20091112.tar.bz2) = 8c4e9dcd562bc5a574a7565d3e56b439
-SHA256 (gcc-objc-4.5-20091112.tar.bz2) = c35ac2d22088f14ce7f0fa600bd4a53b842cab9e348ae14bb6a08e41b1438c7e
-SIZE (gcc-objc-4.5-20091112.tar.bz2) = 246813
MD5 (gcc-testsuite-4.5-20091112.tar.bz2) = c4ba0cbc7e01a43482f0aa227b308ba0
SHA256 (gcc-testsuite-4.5-20091112.tar.bz2) = a2e79c827b8434ed6262827435f1b63ef5c823be009681b74d790c2078052fad
SIZE (gcc-testsuite-4.5-20091112.tar.bz2) = 5407113
diff --git a/lang/gcc45/pkg-descr b/lang/gcc45/pkg-descr
index eb55b684219..b9940115e27 100644
--- a/lang/gcc45/pkg-descr
+++ b/lang/gcc45/pkg-descr
@@ -1,11 +1,6 @@
-GCC, the GNU Compiler Collection includes C, C++, Java and Fortran.
-
-This port installs the various front ends as gcc45, g++45, gcj45,
-gfortran45 and so forth into the ${PREFIX}/bin directory.
-
-(Building the Java frontend and the associated libgcj library will
-consume more than 512MB of main memory. Set WITHOUT_JAVA=yes in
-the environment when building this port to avoid that.)
+GCC, the GNU Compiler Collection, supports a number of languages. This
+port installs the C, C++, Fortran and Java front ends as gcc45, g++45,
+gfortran45, and gcj45, respectively.
WWW: http://gcc.gnu.org/
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 05ac9e889ad..ba557f6bcbc 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
+ gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
@@ -37,8 +36,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
+MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -61,7 +60,7 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --disable-nls \
+CONFIGURE_ARGS+=--disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--with-gmp=${LOCALBASE} \
diff --git a/lang/gcc46/distinfo b/lang/gcc46/distinfo
index 10d8d78399f..ae5068d6a8a 100644
--- a/lang/gcc46/distinfo
+++ b/lang/gcc46/distinfo
@@ -7,9 +7,6 @@ SIZE (gcc-fortran-4.5-20091112.tar.bz2) = 1398510
MD5 (gcc-g++-4.5-20091112.tar.bz2) = d170a2b484213197a090b78b89478d61
SHA256 (gcc-g++-4.5-20091112.tar.bz2) = 820a66a18db85141e61140fa4e7201d5bb593063ee2f0fba612f185e43020e5e
SIZE (gcc-g++-4.5-20091112.tar.bz2) = 6296128
-MD5 (gcc-objc-4.5-20091112.tar.bz2) = 8c4e9dcd562bc5a574a7565d3e56b439
-SHA256 (gcc-objc-4.5-20091112.tar.bz2) = c35ac2d22088f14ce7f0fa600bd4a53b842cab9e348ae14bb6a08e41b1438c7e
-SIZE (gcc-objc-4.5-20091112.tar.bz2) = 246813
MD5 (gcc-testsuite-4.5-20091112.tar.bz2) = c4ba0cbc7e01a43482f0aa227b308ba0
SHA256 (gcc-testsuite-4.5-20091112.tar.bz2) = a2e79c827b8434ed6262827435f1b63ef5c823be009681b74d790c2078052fad
SIZE (gcc-testsuite-4.5-20091112.tar.bz2) = 5407113
diff --git a/lang/gcc46/pkg-descr b/lang/gcc46/pkg-descr
index eb55b684219..b9940115e27 100644
--- a/lang/gcc46/pkg-descr
+++ b/lang/gcc46/pkg-descr
@@ -1,11 +1,6 @@
-GCC, the GNU Compiler Collection includes C, C++, Java and Fortran.
-
-This port installs the various front ends as gcc45, g++45, gcj45,
-gfortran45 and so forth into the ${PREFIX}/bin directory.
-
-(Building the Java frontend and the associated libgcj library will
-consume more than 512MB of main memory. Set WITHOUT_JAVA=yes in
-the environment when building this port to avoid that.)
+GCC, the GNU Compiler Collection, supports a number of languages. This
+port installs the C, C++, Fortran and Java front ends as gcc45, g++45,
+gfortran45, and gcj45, respectively.
WWW: http://gcc.gnu.org/
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 05ac9e889ad..ba557f6bcbc 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
+ gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
@@ -37,8 +36,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
+MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -61,7 +60,7 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --disable-nls \
+CONFIGURE_ARGS+=--disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--with-gmp=${LOCALBASE} \
diff --git a/lang/gcc47/distinfo b/lang/gcc47/distinfo
index 10d8d78399f..ae5068d6a8a 100644
--- a/lang/gcc47/distinfo
+++ b/lang/gcc47/distinfo
@@ -7,9 +7,6 @@ SIZE (gcc-fortran-4.5-20091112.tar.bz2) = 1398510
MD5 (gcc-g++-4.5-20091112.tar.bz2) = d170a2b484213197a090b78b89478d61
SHA256 (gcc-g++-4.5-20091112.tar.bz2) = 820a66a18db85141e61140fa4e7201d5bb593063ee2f0fba612f185e43020e5e
SIZE (gcc-g++-4.5-20091112.tar.bz2) = 6296128
-MD5 (gcc-objc-4.5-20091112.tar.bz2) = 8c4e9dcd562bc5a574a7565d3e56b439
-SHA256 (gcc-objc-4.5-20091112.tar.bz2) = c35ac2d22088f14ce7f0fa600bd4a53b842cab9e348ae14bb6a08e41b1438c7e
-SIZE (gcc-objc-4.5-20091112.tar.bz2) = 246813
MD5 (gcc-testsuite-4.5-20091112.tar.bz2) = c4ba0cbc7e01a43482f0aa227b308ba0
SHA256 (gcc-testsuite-4.5-20091112.tar.bz2) = a2e79c827b8434ed6262827435f1b63ef5c823be009681b74d790c2078052fad
SIZE (gcc-testsuite-4.5-20091112.tar.bz2) = 5407113
diff --git a/lang/gcc47/pkg-descr b/lang/gcc47/pkg-descr
index eb55b684219..b9940115e27 100644
--- a/lang/gcc47/pkg-descr
+++ b/lang/gcc47/pkg-descr
@@ -1,11 +1,6 @@
-GCC, the GNU Compiler Collection includes C, C++, Java and Fortran.
-
-This port installs the various front ends as gcc45, g++45, gcj45,
-gfortran45 and so forth into the ${PREFIX}/bin directory.
-
-(Building the Java frontend and the associated libgcj library will
-consume more than 512MB of main memory. Set WITHOUT_JAVA=yes in
-the environment when building this port to avoid that.)
+GCC, the GNU Compiler Collection, supports a number of languages. This
+port installs the C, C++, Fortran and Java front ends as gcc45, g++45,
+gfortran45, and gcj45, respectively.
WWW: http://gcc.gnu.org/
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 05ac9e889ad..ba557f6bcbc 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
+ gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
@@ -37,8 +36,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
+MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -61,7 +60,7 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --disable-nls \
+CONFIGURE_ARGS+=--disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--with-gmp=${LOCALBASE} \
diff --git a/lang/gcc48/distinfo b/lang/gcc48/distinfo
index 10d8d78399f..ae5068d6a8a 100644
--- a/lang/gcc48/distinfo
+++ b/lang/gcc48/distinfo
@@ -7,9 +7,6 @@ SIZE (gcc-fortran-4.5-20091112.tar.bz2) = 1398510
MD5 (gcc-g++-4.5-20091112.tar.bz2) = d170a2b484213197a090b78b89478d61
SHA256 (gcc-g++-4.5-20091112.tar.bz2) = 820a66a18db85141e61140fa4e7201d5bb593063ee2f0fba612f185e43020e5e
SIZE (gcc-g++-4.5-20091112.tar.bz2) = 6296128
-MD5 (gcc-objc-4.5-20091112.tar.bz2) = 8c4e9dcd562bc5a574a7565d3e56b439
-SHA256 (gcc-objc-4.5-20091112.tar.bz2) = c35ac2d22088f14ce7f0fa600bd4a53b842cab9e348ae14bb6a08e41b1438c7e
-SIZE (gcc-objc-4.5-20091112.tar.bz2) = 246813
MD5 (gcc-testsuite-4.5-20091112.tar.bz2) = c4ba0cbc7e01a43482f0aa227b308ba0
SHA256 (gcc-testsuite-4.5-20091112.tar.bz2) = a2e79c827b8434ed6262827435f1b63ef5c823be009681b74d790c2078052fad
SIZE (gcc-testsuite-4.5-20091112.tar.bz2) = 5407113
diff --git a/lang/gcc48/pkg-descr b/lang/gcc48/pkg-descr
index eb55b684219..b9940115e27 100644
--- a/lang/gcc48/pkg-descr
+++ b/lang/gcc48/pkg-descr
@@ -1,11 +1,6 @@
-GCC, the GNU Compiler Collection includes C, C++, Java and Fortran.
-
-This port installs the various front ends as gcc45, g++45, gcj45,
-gfortran45 and so forth into the ${PREFIX}/bin directory.
-
-(Building the Java frontend and the associated libgcj library will
-consume more than 512MB of main memory. Set WITHOUT_JAVA=yes in
-the environment when building this port to avoid that.)
+GCC, the GNU Compiler Collection, supports a number of languages. This
+port installs the C, C++, Fortran and Java front ends as gcc45, g++45,
+gfortran45, and gcj45, respectively.
WWW: http://gcc.gnu.org/