aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2015-05-03 02:43:35 +0800
committersbruno <sbruno@FreeBSD.org>2015-05-03 02:43:35 +0800
commitbadb6ede3e1ecf0bb4c8d82b2a665e90e2400249 (patch)
tree77f8e8b7417e8c50f8af9322b78c5aafd9cf8a13 /lang
parent8db4e1c4a951d17f6db36847770de3b1d17c6445 (diff)
downloadfreebsd-ports-graphics-badb6ede3e1ecf0bb4c8d82b2a665e90e2400249.tar.gz
freebsd-ports-graphics-badb6ede3e1ecf0bb4c8d82b2a665e90e2400249.tar.zst
freebsd-ports-graphics-badb6ede3e1ecf0bb4c8d82b2a665e90e2400249.zip
This time, don't delete the requisite includes for the post-install bits.
Reimplement ONLY_FOR_ARCHS such that we know that this port requires newer compiler features (which aren't very clear from the port itself). Probably need to validate this on powerpc as we have clang available and gcc ports. PR: 197132
Diffstat (limited to 'lang')
-rw-r--r--lang/luajit/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index e902a368890..fe41e4ae55b 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -17,15 +17,14 @@ USE_LDCONFIG= yes
PLIST_SUB+= VERSION=${DISTVERSION}
+ONLY_FOR_ARCHS= i386 amd64 armv6
+ONLY_FOR_ARCHS_REASON= Requires newer gcc/clang to compile.
+
+.include <bsd.port.pre.mk>
+
post-install:
${LN} -sf ${PREFIX}/bin/${PORTNAME}-${DISTVERSION} \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@${INSTALL_MAN} ${WRKSRC}/etc/luajit.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
.include <bsd.port.post.mk>