aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
commitbdc7b8de9b4a00d6f78b8a20e6e92ad630e44558 (patch)
tree0af98c25fc0d67ccc871639ecd10e8476cfd8de7 /lang
parenta72ed0005b1dc840337c91df5cde89b1015c75f8 (diff)
downloadfreebsd-ports-graphics-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.gz
freebsd-ports-graphics-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.zst
freebsd-ports-graphics-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.zip
- Remove ports that only work with < perl 5.12 (devel/p5-B-Size, devel/p5-Devel-Arena)
- Remove conditionals for PERL_LEVEL < 501200 - Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk - Other minor cleanups RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS} PR: ports/165605 Submitted by: pgollucci (myself) Approved by: portmgr (linimon) Exp Run by: linimon Tested by: make index
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-Marpa-PP/Makefile22
-rw-r--r--lang/p5-Marpa-XS/Makefile2
-rw-r--r--lang/p5-Marpa/Makefile10
-rw-r--r--lang/p5-Parse-Perl/Makefile9
-rw-r--r--lang/p5-TryCatch/Makefile8
5 files changed, 8 insertions, 43 deletions
diff --git a/lang/p5-Marpa-PP/Makefile b/lang/p5-Marpa-PP/Makefile
index 34073c5254a..765826bc201 100644
--- a/lang/p5-Marpa-PP/Makefile
+++ b/lang/p5-Marpa-PP/Makefile
@@ -17,13 +17,12 @@ COMMENT= Pure Perl version of Marpa
BUILD_DEPENDS= p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
-BUILD_DEPENDS= p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI \
- p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Weaken>=3.004000:${PORTSDIR}/devel/p5-Test-Weaken
# PERL_CONFIGURE failed on Perl 5.12.4
-PERL_MODBUILD= 5.10.0+
+PERL_MODBUILD= yes
MAN3= Marpa::PP.3 \
Marpa::PP::Advanced::Bibliography.3 \
@@ -40,19 +39,4 @@ MAN3= Marpa::PP.3 \
Marpa::PP::Tracing.3 \
Marpa::PP::Vocabulary.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.21:${PORTSDIR}/lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.21:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-
-.if ${PERL_LEVEL} < 501200
-BUILD_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper \
- p5-Storable>=2.21:${PORTSDIR}/devel/p5-Storable
-RUN_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper \
- p5-Storable>=2.21:${PORTSDIR}/devel/p5-Storable
-TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-Marpa-XS/Makefile b/lang/p5-Marpa-XS/Makefile
index d1cb0ac06db..2282b9e4fa9 100644
--- a/lang/p5-Marpa-XS/Makefile
+++ b/lang/p5-Marpa-XS/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= p5-ExtUtils-PkgConfig>=0:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
TEST_DEPENDS= p5-Test-Weaken>=3.004000:${PORTSDIR}/devel/p5-Test-Weaken
-PERL_CONFIGURE= 5.10.0+
+PERL_CONFIGURE= yes
MAN3= Marpa::XS.3 \
Marpa::XS::Advanced::Bibliography.3 \
diff --git a/lang/p5-Marpa/Makefile b/lang/p5-Marpa/Makefile
index baba0626ce2..1e48ad8ee40 100644
--- a/lang/p5-Marpa/Makefile
+++ b/lang/p5-Marpa/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
RUN_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI
-PERL_CONFIGURE= 5.10.0+
+PERL_CONFIGURE= yes
MAN3= Marpa::Advanced::Algorithm.3 \
Marpa::Advanced::Bibliography.3 \
@@ -38,10 +38,4 @@ MAN3= Marpa::Advanced::Algorithm.3 \
Marpa::Support.3 \
Marpa::Tracing.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501200
-TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-Parse-Perl/Makefile b/lang/p5-Parse-Perl/Makefile
index 5374692d206..a78e45ca631 100644
--- a/lang/p5-Parse-Perl/Makefile
+++ b/lang/p5-Parse-Perl/Makefile
@@ -27,11 +27,4 @@ MAN3= Parse::Perl.3 \
Parse::Perl::CopHintsHash.3 \
Parse::Perl::Environment.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-TryCatch/Makefile b/lang/p5-TryCatch/Makefile
index 6ede8e89ac3..dcd36236408 100644
--- a/lang/p5-TryCatch/Makefile
+++ b/lang/p5-TryCatch/Makefile
@@ -46,10 +46,4 @@ BUILD_DEPENDS+= p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check
p5-B-Hooks-OP-PPAddr>=0.03:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>