aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-10-10 10:32:50 +0800
committerstas <stas@FreeBSD.org>2010-10-10 10:32:50 +0800
commitc2f274330c93551f13b5d9ae790f9e659689b393 (patch)
tree52f2f2ab2d73de7560cf7acb50611f6cce8405b7 /lang
parentd02c1ab79a3c26d58ee328c8af1c64ec1d849a38 (diff)
downloadfreebsd-ports-graphics-c2f274330c93551f13b5d9ae790f9e659689b393.tar.gz
freebsd-ports-graphics-c2f274330c93551f13b5d9ae790f9e659689b393.tar.zst
freebsd-ports-graphics-c2f274330c93551f13b5d9ae790f9e659689b393.zip
- Fix build on powerpc.
PR: ports/151348 Submitted by: Andreas Tobler <andreast@FreeBSD.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/gforth/Makefile4
-rw-r--r--lang/gforth/files/patch-configure17
2 files changed, 15 insertions, 6 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index dacbfed03c7..0c146a3a1c8 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -59,13 +59,13 @@ BROKEN= Does not compile
.endif
.endif
-.if ${ARCH} == i386
+.if ${ARCH} == i386 || ${ARCH} == "powerpc"
WORDSIZE=32
.else
WORDSIZE=64
.endif
-.if ${ARCH} == sparc64
+.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BYTEORDER=b
.else
BYTEORDER=l
diff --git a/lang/gforth/files/patch-configure b/lang/gforth/files/patch-configure
index 0bad3706086..dfe8191ccbb 100644
--- a/lang/gforth/files/patch-configure
+++ b/lang/gforth/files/patch-configure
@@ -1,6 +1,16 @@
---- configure.orig Sat Oct 21 02:49:22 2006
-+++ configure Sat Oct 21 02:49:27 2006
-@@ -8079,8 +8079,8 @@
+--- configure.orig 2003-08-25 10:03:42.000000000 +0200
++++ configure 2010-10-09 20:40:43.000000000 +0200
+@@ -3584,9 +3584,6 @@
+ else
+ LIBOBJS="$LIBOBJS ../arch/power/_sync_cache_range.$ac_objext"
+ fi
+-
+- #long long is broken on (at least) gcc-2.95.* for PPC
+- test x$ac_cv_sizeof_long_long = x && ac_cv_sizeof_long_long=0
+ ;;
+ *)
+ { echo "$as_me:$LINENO: WARNING: Using a generic machine description" >&5
+@@ -8079,8 +8076,8 @@
if (x) {
label1:
asm("$i");
@@ -9,4 +19,3 @@
+ label2:
return (&&label2)-(&&label1);
}
-