aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-06-01 00:33:18 +0800
committerijliao <ijliao@FreeBSD.org>2001-06-01 00:33:18 +0800
commitd2a5334e10c831a1e95c2cac0ff8b6a4a963bd8b (patch)
tree45304928bb4ce60bc586684c2ddcefdf64feb001 /lang
parentf61e5f9c04bfc013344ac7390d90f0366100e107 (diff)
downloadfreebsd-ports-graphics-d2a5334e10c831a1e95c2cac0ff8b6a4a963bd8b.tar.gz
freebsd-ports-graphics-d2a5334e10c831a1e95c2cac0ff8b6a4a963bd8b.tar.zst
freebsd-ports-graphics-d2a5334e10c831a1e95c2cac0ff8b6a4a963bd8b.zip
add awka
Converts the AWK script to C, then compiles it
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/awka/Makefile26
-rw-r--r--lang/awka/distinfo1
-rw-r--r--lang/awka/pkg-comment1
-rw-r--r--lang/awka/pkg-descr8
-rw-r--r--lang/awka/pkg-plist6
6 files changed, 43 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 49109b04cad..2b053d94955 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -8,6 +8,7 @@
SUBDIR += TenDRA
SUBDIR += aleph
SUBDIR += atlast
+ SUBDIR += awka
SUBDIR += bc-gcc
SUBDIR += bwbasic
SUBDIR += caml-light
diff --git a/lang/awka/Makefile b/lang/awka/Makefile
new file mode 100644
index 00000000000..96b297b9421
--- /dev/null
+++ b/lang/awka/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: awka
+# Date created: May 31, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+
+PORTNAME= awka
+PORTVERSION= 0.7.3
+CATEGORIES= lang
+MASTER_SITES= http://awka.sourceforge.net/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+INSTALLS_SHLIB= yes
+
+MANCOMPRESSED= no
+MAN1= awka.1
+MAN5= awka-elm.5 awka-elmref.5
+
+post-install:
+ @strip ${PREFIX}/bin/awka
+
+.include <bsd.port.mk>
diff --git a/lang/awka/distinfo b/lang/awka/distinfo
new file mode 100644
index 00000000000..d0530c62ce7
--- /dev/null
+++ b/lang/awka/distinfo
@@ -0,0 +1 @@
+MD5 (awka-0.7.3.tar.gz) = a1c17a23162f22cb7e3f92bd7bddc294
diff --git a/lang/awka/pkg-comment b/lang/awka/pkg-comment
new file mode 100644
index 00000000000..1da068d8122
--- /dev/null
+++ b/lang/awka/pkg-comment
@@ -0,0 +1 @@
+Converts the AWK script to C, then compiles it
diff --git a/lang/awka/pkg-descr b/lang/awka/pkg-descr
new file mode 100644
index 00000000000..a01d8bafd27
--- /dev/null
+++ b/lang/awka/pkg-descr
@@ -0,0 +1,8 @@
+Awka is an open-source implementation of the AWK programming language.
+
+Awka is not an interpreter like Gawk, Mawk or Nawk, but instead it converts
+the program to ANSI-C, then compiles this using gcc or a native C compiled
+to create a binary executable. This means you must have an ANSI C compiler
+present on your system for Awka to work.
+
+WWW: http://awka.sourceforge.net/
diff --git a/lang/awka/pkg-plist b/lang/awka/pkg-plist
new file mode 100644
index 00000000000..40f861b3f30
--- /dev/null
+++ b/lang/awka/pkg-plist
@@ -0,0 +1,6 @@
+bin/awka
+lib/libawka.a
+lib/libdfa.a
+lib/libawka.so
+include/libawka.h
+include/dfa.h