aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-11 07:19:37 +0800
committermiwi <miwi@FreeBSD.org>2008-01-11 07:19:37 +0800
commitdad02217bd10f45eb0b4f0fe04bc2dc63f57aaa3 (patch)
treef62bfbf82a8e3647b5e4455d585463c3fd7c1bcb /lang
parent6f6b9a5b3e8a5a2de857de7758cf703e114f9815 (diff)
downloadfreebsd-ports-graphics-dad02217bd10f45eb0b4f0fe04bc2dc63f57aaa3.tar.gz
freebsd-ports-graphics-dad02217bd10f45eb0b4f0fe04bc2dc63f57aaa3.tar.zst
freebsd-ports-graphics-dad02217bd10f45eb0b4f0fe04bc2dc63f57aaa3.zip
- Update to 1.0
PR: 119501 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/open-cobol-devel/Makefile24
-rw-r--r--lang/open-cobol-devel/distinfo6
-rw-r--r--lang/open-cobol-devel/files/patch-cobc::cobc.c11
-rw-r--r--lang/open-cobol-devel/files/patch-libcob::screenio.c10
-rw-r--r--lang/open-cobol-devel/files/patch-tests_atlocal.in11
-rw-r--r--lang/open-cobol-devel/pkg-plist5
-rw-r--r--lang/open-cobol/Makefile24
-rw-r--r--lang/open-cobol/distinfo6
-rw-r--r--lang/open-cobol/files/patch-cobc::cobc.c11
-rw-r--r--lang/open-cobol/files/patch-libcob::screenio.c10
-rw-r--r--lang/open-cobol/files/patch-tests_atlocal.in11
-rw-r--r--lang/open-cobol/pkg-plist5
12 files changed, 32 insertions, 102 deletions
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
index 67376c02646..f61e0eb29e2 100644
--- a/lang/open-cobol-devel/Makefile
+++ b/lang/open-cobol-devel/Makefile
@@ -7,27 +7,25 @@
#
PORTNAME= open-cobol
-PORTVERSION= 0.32
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An open-source COBOL compiler
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
-USE_GETOPT_LONG=yes
-USE_AUTOTOOLS= libltdl:15 libtool:15
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnometarget
+USE_BDB= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
INFO= open-cobol
-CPPFLAGS= -I${LOCALBASE}/include
+CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
.if defined(WITHOUT_NLS)
@@ -39,12 +37,8 @@ PLIST_SUB+= NLS=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|__gmp_rand|__gmpz_init|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|^SUBDIRS = lib |SUBDIRS = |g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
- ${WRKSRC}/cobc/Makefile.in
+ @${REINPLACE_CMD} -e 's|__gmp_randinit|__gmpz_init|g ; \
+ s|db-4.[0-9]|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
.if defined(MAINTAINER_MODE)
test: build
diff --git a/lang/open-cobol-devel/distinfo b/lang/open-cobol-devel/distinfo
index a3324c6b520..b9f1c9698da 100644
--- a/lang/open-cobol-devel/distinfo
+++ b/lang/open-cobol-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (open-cobol-0.32.tar.gz) = 9ffc3b75eca988e40206b3e310bba635
-SHA256 (open-cobol-0.32.tar.gz) = ede55ad33a5d8776c994a668b77716f0fddba23011263a07073ffff0c0c38fc9
-SIZE (open-cobol-0.32.tar.gz) = 768635
+MD5 (open-cobol-1.0.tar.gz) = 947e0d9c4ee7fa8f077ea4bca2f894e5
+SHA256 (open-cobol-1.0.tar.gz) = 15a36e4823b09938b25e947dcd0fad1b7b1ba2978591bb220a18c2bed32daf06
+SIZE (open-cobol-1.0.tar.gz) = 934641
diff --git a/lang/open-cobol-devel/files/patch-cobc::cobc.c b/lang/open-cobol-devel/files/patch-cobc::cobc.c
deleted file mode 100644
index d1809c28086..00000000000
--- a/lang/open-cobol-devel/files/patch-cobc::cobc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- cobc/cobc.c.orig Thu Jun 5 09:02:15 2003
-+++ cobc/cobc.c Sun Apr 4 00:32:21 2004
-@@ -36,7 +36,7 @@
-
- #include "cobc.h"
- #include "tree.h"
--#include "lib/getopt.h"
-+#include <getopt.h>
-
-
- /*
diff --git a/lang/open-cobol-devel/files/patch-libcob::screenio.c b/lang/open-cobol-devel/files/patch-libcob::screenio.c
deleted file mode 100644
index 727acf12811..00000000000
--- a/lang/open-cobol-devel/files/patch-libcob::screenio.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libcob/screenio.c.orig Fri Mar 12 13:41:58 2004
-+++ libcob/screenio.c Wed Nov 24 02:43:30 2004
-@@ -19,6 +19,7 @@
-
- #include "config.h"
-
-+#include <stdio.h>
- #include <string.h>
-
- #if HAVE_NCURSES_H
diff --git a/lang/open-cobol-devel/files/patch-tests_atlocal.in b/lang/open-cobol-devel/files/patch-tests_atlocal.in
deleted file mode 100644
index e902d53ba8b..00000000000
--- a/lang/open-cobol-devel/files/patch-tests_atlocal.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/atlocal.in.orig Tue May 3 11:31:14 2005
-+++ tests/atlocal.in Sat May 14 18:24:52 2005
-@@ -10,7 +10,7 @@
- COMPILE_ONLY="${COBC} -fsyntax-only ${FLAGS}"
- COMPILE_MODULE="${COBC} -m ${FLAGS}"
-
--export COB_CFLAGS="-I${abs_top_srcdir}"
-+export COB_CFLAGS="-I${abs_top_srcdir} -I@prefix@/include"
- export COB_LIBS="-L${abs_top_builddir}/libcob/.libs -lcob @LIBCOB_LIBS@"
- export COB_CONFIG_DIR="${abs_top_srcdir}/config"
- export LD_LIBRARY_PATH="${abs_top_builddir}/libcob/.libs"
diff --git a/lang/open-cobol-devel/pkg-plist b/lang/open-cobol-devel/pkg-plist
index e080fce6494..14d162dbcf6 100644
--- a/lang/open-cobol-devel/pkg-plist
+++ b/lang/open-cobol-devel/pkg-plist
@@ -4,26 +4,29 @@ bin/cobcrun
include/libcob.h
include/libcob/byteswap.h
include/libcob/call.h
+include/libcob/codegen.h
include/libcob/common.h
include/libcob/exception.def
include/libcob/fileio.h
+include/libcob/intrinsic.h
include/libcob/move.h
include/libcob/numeric.h
include/libcob/screenio.h
include/libcob/strings.h
+include/libcob/system.def
include/libcob/termio.h
lib/libcob.a
lib/libcob.la
lib/libcob.so
lib/libcob.so.1
%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
+%%DATADIR%%/config/bs2000.conf
%%DATADIR%%/config/cobol2002.conf
%%DATADIR%%/config/cobol85.conf
%%DATADIR%%/config/default.conf
%%DATADIR%%/config/ibm.conf
%%DATADIR%%/config/mf.conf
%%DATADIR%%/config/mvs.conf
-%%DATADIR%%/config/v023.conf
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%
@dirrm include/libcob
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 67376c02646..f61e0eb29e2 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -7,27 +7,25 @@
#
PORTNAME= open-cobol
-PORTVERSION= 0.32
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An open-source COBOL compiler
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
-USE_GETOPT_LONG=yes
-USE_AUTOTOOLS= libltdl:15 libtool:15
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnometarget
+USE_BDB= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
INFO= open-cobol
-CPPFLAGS= -I${LOCALBASE}/include
+CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
.if defined(WITHOUT_NLS)
@@ -39,12 +37,8 @@ PLIST_SUB+= NLS=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|__gmp_rand|__gmpz_init|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|^SUBDIRS = lib |SUBDIRS = |g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
- ${WRKSRC}/cobc/Makefile.in
+ @${REINPLACE_CMD} -e 's|__gmp_randinit|__gmpz_init|g ; \
+ s|db-4.[0-9]|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
.if defined(MAINTAINER_MODE)
test: build
diff --git a/lang/open-cobol/distinfo b/lang/open-cobol/distinfo
index a3324c6b520..b9f1c9698da 100644
--- a/lang/open-cobol/distinfo
+++ b/lang/open-cobol/distinfo
@@ -1,3 +1,3 @@
-MD5 (open-cobol-0.32.tar.gz) = 9ffc3b75eca988e40206b3e310bba635
-SHA256 (open-cobol-0.32.tar.gz) = ede55ad33a5d8776c994a668b77716f0fddba23011263a07073ffff0c0c38fc9
-SIZE (open-cobol-0.32.tar.gz) = 768635
+MD5 (open-cobol-1.0.tar.gz) = 947e0d9c4ee7fa8f077ea4bca2f894e5
+SHA256 (open-cobol-1.0.tar.gz) = 15a36e4823b09938b25e947dcd0fad1b7b1ba2978591bb220a18c2bed32daf06
+SIZE (open-cobol-1.0.tar.gz) = 934641
diff --git a/lang/open-cobol/files/patch-cobc::cobc.c b/lang/open-cobol/files/patch-cobc::cobc.c
deleted file mode 100644
index d1809c28086..00000000000
--- a/lang/open-cobol/files/patch-cobc::cobc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- cobc/cobc.c.orig Thu Jun 5 09:02:15 2003
-+++ cobc/cobc.c Sun Apr 4 00:32:21 2004
-@@ -36,7 +36,7 @@
-
- #include "cobc.h"
- #include "tree.h"
--#include "lib/getopt.h"
-+#include <getopt.h>
-
-
- /*
diff --git a/lang/open-cobol/files/patch-libcob::screenio.c b/lang/open-cobol/files/patch-libcob::screenio.c
deleted file mode 100644
index 727acf12811..00000000000
--- a/lang/open-cobol/files/patch-libcob::screenio.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libcob/screenio.c.orig Fri Mar 12 13:41:58 2004
-+++ libcob/screenio.c Wed Nov 24 02:43:30 2004
-@@ -19,6 +19,7 @@
-
- #include "config.h"
-
-+#include <stdio.h>
- #include <string.h>
-
- #if HAVE_NCURSES_H
diff --git a/lang/open-cobol/files/patch-tests_atlocal.in b/lang/open-cobol/files/patch-tests_atlocal.in
deleted file mode 100644
index e902d53ba8b..00000000000
--- a/lang/open-cobol/files/patch-tests_atlocal.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/atlocal.in.orig Tue May 3 11:31:14 2005
-+++ tests/atlocal.in Sat May 14 18:24:52 2005
-@@ -10,7 +10,7 @@
- COMPILE_ONLY="${COBC} -fsyntax-only ${FLAGS}"
- COMPILE_MODULE="${COBC} -m ${FLAGS}"
-
--export COB_CFLAGS="-I${abs_top_srcdir}"
-+export COB_CFLAGS="-I${abs_top_srcdir} -I@prefix@/include"
- export COB_LIBS="-L${abs_top_builddir}/libcob/.libs -lcob @LIBCOB_LIBS@"
- export COB_CONFIG_DIR="${abs_top_srcdir}/config"
- export LD_LIBRARY_PATH="${abs_top_builddir}/libcob/.libs"
diff --git a/lang/open-cobol/pkg-plist b/lang/open-cobol/pkg-plist
index e080fce6494..14d162dbcf6 100644
--- a/lang/open-cobol/pkg-plist
+++ b/lang/open-cobol/pkg-plist
@@ -4,26 +4,29 @@ bin/cobcrun
include/libcob.h
include/libcob/byteswap.h
include/libcob/call.h
+include/libcob/codegen.h
include/libcob/common.h
include/libcob/exception.def
include/libcob/fileio.h
+include/libcob/intrinsic.h
include/libcob/move.h
include/libcob/numeric.h
include/libcob/screenio.h
include/libcob/strings.h
+include/libcob/system.def
include/libcob/termio.h
lib/libcob.a
lib/libcob.la
lib/libcob.so
lib/libcob.so.1
%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
+%%DATADIR%%/config/bs2000.conf
%%DATADIR%%/config/cobol2002.conf
%%DATADIR%%/config/cobol85.conf
%%DATADIR%%/config/default.conf
%%DATADIR%%/config/ibm.conf
%%DATADIR%%/config/mf.conf
%%DATADIR%%/config/mvs.conf
-%%DATADIR%%/config/v023.conf
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%
@dirrm include/libcob