aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-04-13 05:58:15 +0800
committerthierry <thierry@FreeBSD.org>2004-04-13 05:58:15 +0800
commitdbeeea061b29b3d589b33dc45da41ac377f2b084 (patch)
treefb43621af850647a064c1db6ca9005392258c917 /lang
parent32362c922df03da84510ae6e465d316e5ad362d7 (diff)
downloadfreebsd-ports-graphics-dbeeea061b29b3d589b33dc45da41ac377f2b084.tar.gz
freebsd-ports-graphics-dbeeea061b29b3d589b33dc45da41ac377f2b084.tar.zst
freebsd-ports-graphics-dbeeea061b29b3d589b33dc45da41ac377f2b084.zip
Add fpc-base 1.0.10, meta package to install all of the
Free Pascal base. PR: 62623 Submitted by: John Merryweather Cooper <coop9211@uidaho.edu> Approved by: pav (mentor).
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/fpc-base/Makefile42
-rw-r--r--lang/fpc-base/pkg-descr9
-rw-r--r--lang/fpc-base/pkg-plist1
4 files changed, 53 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 0376013b206..fbf5c431abd 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -55,6 +55,7 @@
SUBDIR += ficl-devel
SUBDIR += forth
SUBDIR += fpc
+ SUBDIR += fpc-base
SUBDIR += fpc-demo
SUBDIR += fpc-devel
SUBDIR += fpc-docs
diff --git a/lang/fpc-base/Makefile b/lang/fpc-base/Makefile
new file mode 100644
index 00000000000..e3c3588ddbe
--- /dev/null
+++ b/lang/fpc-base/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: fpc-base
+# Date created: 10 February 2004
+# Whom: John Merryweather Cooper <coop9211@uidaho.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpc-base
+PORTVERSION= 1.0.10
+CATEGORIES= lang devel
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Meta package to install all of the Free Pascal base
+
+RUN_DEPENDS= fp:${PORTSDIR}/editors/fpc-ide \
+ ${PAKGDIR}/ibase/ibase60.ppu:${PORTSDIR}/databases/fpc-ibase \
+ ${PAKGDIR}/mysql/mysql.ppu:${PORTSDIR}/databases/fpc-mysql \
+ ${PAKGDIR}/odbc/odbcsql.ppu:${PORTSDIR}/databases/fpc-odbc \
+ ${PAKGDIR}/postgres/postgres.ppu:${PORTSDIR}/databases/fpc-postgres \
+ ${PAKGDIR}/oracle/oraoci.ppu:${PORTSDIR}/databases/fpc-oracle \
+ ${PAKGDIR}/regexpr/regexpr.ppu:${PORTSDIR}/devel/fpc-regexpr \
+ ${PAKGDIR}/inet/inet.ppu:${PORTSDIR}/net/fpc-inet \
+ ${PAKGDIR}/md5/md5.ppu:${PORTSDIR}/security/fpc-md5 \
+ ${PAKGDIR}/paszlib/paszlib.ppu:${PORTSDIR}/archivers/fpc-paszlib
+
+PAKGDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/freebsd
+DOCSDIR= ${LOCALBASE}/share/doc/fpc
+EXAMPLESDIR= ${LOCALBASE}/share/examples/fpc
+
+.if !defined(NOPORTDOCS)
+RUN_DEPENDS+= ${DOCSDIR}/user.pdf:${PORTSDIR}/lang/fpc-docs \
+ ${EXAMPLESDIR}/Makefile.fpc:${PORTSDIR}/lang/fpc-demo
+.endif
+
+NO_BUILD= yes
+
+do-install: # empty
+
+.include <bsd.port.mk>
diff --git a/lang/fpc-base/pkg-descr b/lang/fpc-base/pkg-descr
new file mode 100644
index 00000000000..85e8f52c6d2
--- /dev/null
+++ b/lang/fpc-base/pkg-descr
@@ -0,0 +1,9 @@
+FPC Base
+
+This collection constitutes the base packages and utilities for Free
+Pascal.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/lang/fpc-base/pkg-plist b/lang/fpc-base/pkg-plist
new file mode 100644
index 00000000000..549a621fec0
--- /dev/null
+++ b/lang/fpc-base/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty