aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2006-02-03 16:56:24 +0800
committerkris <kris@FreeBSD.org>2006-02-03 16:56:24 +0800
commitdfa638689f4c287a9acaeef4d16b6724cbca8f29 (patch)
treed8758fbdd4532e7e4d0373a8608a5b3df0ae99b0 /lang
parentc66ec515f5cfcd24224a8b6c129e38435811de45 (diff)
downloadfreebsd-ports-graphics-dfa638689f4c287a9acaeef4d16b6724cbca8f29.tar.gz
freebsd-ports-graphics-dfa638689f4c287a9acaeef4d16b6724cbca8f29.tar.zst
freebsd-ports-graphics-dfa638689f4c287a9acaeef4d16b6724cbca8f29.zip
Remove bogus DEPENDS. Instead, list pm3-base in BUILD_DEPENDS twice so
that it is installed, and we also run its configure script. Add missing USE_GMAKE needed to satisfy pm3-base port dependency check.
Diffstat (limited to 'lang')
-rw-r--r--lang/pm3-net/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/pm3-net/Makefile b/lang/pm3-net/Makefile
index de4bb2be20f..e75c7cec215 100644
--- a/lang/pm3-net/Makefile
+++ b/lang/pm3-net/Makefile
@@ -13,9 +13,11 @@ DISTFILES=
MAINTAINER= ports@FreeBSD.org
COMMENT= Low-level networking libraries for the PM3 Modula-3 distribution
-BUILD_DEPENDS= ${L1}libm3${L2}:${PORTSDIR}/lang/pm3-base
+# Yes, this port is listed twice; it needs to be installed,
+# and we also need to run the configure script in the port
+BUILD_DEPENDS= ${L1}libm3${L2}:${PORTSDIR}/lang/pm3-base \
+ /nonexistent:${PORTSDIR}/lang/pm3-base:configure
RUN_DEPENDS= ${L1}libm3${L2}:${PORTSDIR}/lang/pm3-base
-DEPENDS= ${PORTSDIR}/lang/pm3-base:configure
DIST_SUBDIR= pm3
INSTALL_TARGET= all
@@ -28,6 +30,7 @@ BUILDDIRS= network/tcplibs/tcp \
network/udp
L1= ${PREFIX}/lib/m3/${TARGET}/
SOVERSION= 7
+USE_GMAKE= yes
# hack to work around bsd.port.mk problem
USE_BZIP2= yes