aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2006-03-21 07:13:39 +0800
committerolgeni <olgeni@FreeBSD.org>2006-03-21 07:13:39 +0800
commite3332b46799b37fb66eaab68f3453bed137f2b91 (patch)
treebb707c516678fa43a706010f5467f6151487d71c /lang
parentfbdf0a01deeeb9c41fa0b206ab11c2fcd1292b2b (diff)
downloadfreebsd-ports-graphics-e3332b46799b37fb66eaab68f3453bed137f2b91.tar.gz
freebsd-ports-graphics-e3332b46799b37fb66eaab68f3453bed137f2b91.tar.zst
freebsd-ports-graphics-e3332b46799b37fb66eaab68f3453bed137f2b91.zip
Add support for amd64 (from ports/83001, modified).
PR: ports/83001 Submitted by: Rasmus Kaj <kaj(at)kth.se>
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile7
-rw-r--r--lang/erlang/files/patch-erts_configure24
-rw-r--r--lang/erlang14/Makefile7
-rw-r--r--lang/erlang14/files/patch-erts_configure24
4 files changed, 58 insertions, 4 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 980aca11e66..711c0850e3b 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -67,11 +67,14 @@ ERLANG_PLIST= ${WRKDIR}/pkg-plist
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
REINPLACE_ARGS= -i
CONFIGURE_TARGET= # Empty
-CONFIGURE_ARGS+= --enable-threads --enable-hipe --enable-kernel-poll
+CONFIGURE_ARGS+= --enable-threads --enable-kernel-poll
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --enable-hipe
+.endif
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
CFLAGS+= -I${LOCALBASE}/include
diff --git a/lang/erlang/files/patch-erts_configure b/lang/erlang/files/patch-erts_configure
new file mode 100644
index 00000000000..1b67a5a5032
--- /dev/null
+++ b/lang/erlang/files/patch-erts_configure
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- erts/configure.orig
++++ erts/configure
+@@ -1283,6 +1283,7 @@
+ i586) ARCH=x86;;
+ i686) ARCH=x86;;
+ x86_64) ARCH=amd64;;
++amd64) ARCH=amd64;;
+ ppc) ARCH=ppc;;
+ ppc64) ARCH=ppc64;;
+ "Power Macintosh") ARCH=ppc;;
+@@ -5804,7 +5805,9 @@
+
+ echo $ac_n "checking for unreliable floating point execptions""... $ac_c" 1>&6
+ echo "configure:5807: checking for unreliable floating point execptions" >&5
+-if test "$cross_compiling" = yes; then
++if test "${ARCH}" = amd64; then
++ erl_ok=reliable
++elif test "$cross_compiling" = yes; then
+ erl_ok=unreliable
+ else
+ cat > conftest.$ac_ext <<EOF
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 980aca11e66..711c0850e3b 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -67,11 +67,14 @@ ERLANG_PLIST= ${WRKDIR}/pkg-plist
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
REINPLACE_ARGS= -i
CONFIGURE_TARGET= # Empty
-CONFIGURE_ARGS+= --enable-threads --enable-hipe --enable-kernel-poll
+CONFIGURE_ARGS+= --enable-threads --enable-kernel-poll
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --enable-hipe
+.endif
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
CFLAGS+= -I${LOCALBASE}/include
diff --git a/lang/erlang14/files/patch-erts_configure b/lang/erlang14/files/patch-erts_configure
new file mode 100644
index 00000000000..1b67a5a5032
--- /dev/null
+++ b/lang/erlang14/files/patch-erts_configure
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- erts/configure.orig
++++ erts/configure
+@@ -1283,6 +1283,7 @@
+ i586) ARCH=x86;;
+ i686) ARCH=x86;;
+ x86_64) ARCH=amd64;;
++amd64) ARCH=amd64;;
+ ppc) ARCH=ppc;;
+ ppc64) ARCH=ppc64;;
+ "Power Macintosh") ARCH=ppc;;
+@@ -5804,7 +5805,9 @@
+
+ echo $ac_n "checking for unreliable floating point execptions""... $ac_c" 1>&6
+ echo "configure:5807: checking for unreliable floating point execptions" >&5
+-if test "$cross_compiling" = yes; then
++if test "${ARCH}" = amd64; then
++ erl_ok=reliable
++elif test "$cross_compiling" = yes; then
+ erl_ok=unreliable
+ else
+ cat > conftest.$ac_ext <<EOF