aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-02-25 23:25:49 +0800
committerswills <swills@FreeBSD.org>2012-02-25 23:25:49 +0800
commitebabec4cecd871be9aaca08eed6737e27920dbc2 (patch)
treeb729ba56c2e27aeef5ae606665bc9046e7b14c84 /lang
parent786d164e7516fb7d73918072cea84cc3156d0978 (diff)
downloadfreebsd-ports-graphics-ebabec4cecd871be9aaca08eed6737e27920dbc2.tar.gz
freebsd-ports-graphics-ebabec4cecd871be9aaca08eed6737e27920dbc2.tar.zst
freebsd-ports-graphics-ebabec4cecd871be9aaca08eed6737e27920dbc2.zip
- Update lang/ruby18 to p385
- Update lang/ruby19 to p125 Changes: http://www.ruby-forum.com/topic/3663807#1047121 http://www.ruby-lang.org/en/news/2012/02/16/ruby-1-9-3-p125-is-released/ PR: ports/165223 Submitted by: swills (myself) Reviewed by: pgollucci Approved by: portmgr
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/distinfo4
-rw-r--r--lang/ruby19/Makefile3
-rw-r--r--lang/ruby19/distinfo4
-rw-r--r--lang/ruby19/files/patch-configure.in22
-rw-r--r--lang/ruby19/files/patch-cont.c8
-rw-r--r--lang/ruby19/pkg-plist1
6 files changed, 21 insertions, 21 deletions
diff --git a/lang/ruby18/distinfo b/lang/ruby18/distinfo
index 856d7754312..58fdc8fa703 100644
--- a/lang/ruby18/distinfo
+++ b/lang/ruby18/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-1.8.7-p357.tar.bz2) = 5c64b63a597b4cb545887364e1fd1e0601a7aeb545e576e74a6d8e88a2765a37
-SIZE (ruby/ruby-1.8.7-p357.tar.bz2) = 4208157
+SHA256 (ruby/ruby-1.8.7-p358.tar.bz2) = 309ccd427e47ef41a70f96462bd3c2ef2e7911ce1b22432ab502f5bc6e949c1b
+SIZE (ruby/ruby-1.8.7-p358.tar.bz2) = 4209883
diff --git a/lang/ruby19/Makefile b/lang/ruby19/Makefile
index c60741013af..616813c2ff5 100644
--- a/lang/ruby19/Makefile
+++ b/lang/ruby19/Makefile
@@ -19,7 +19,8 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT?= An object-oriented interpreted scripting language
LIB_DEPENDS= ffi.5:${PORTSDIR}/devel/libffi \
- yaml-0.2:${PORTSDIR}/textproc/libyaml
+ yaml-0.2:${PORTSDIR}/textproc/libyaml \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
diff --git a/lang/ruby19/distinfo b/lang/ruby19/distinfo
index 4c545b91332..ea0d7b0ef7c 100644
--- a/lang/ruby19/distinfo
+++ b/lang/ruby19/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-1.9.3-p0.tar.bz2) = ca8ba4e564fc5f98b210a5784e43dfffef9471222849e46f8e848b37e9f38acf
-SIZE (ruby/ruby-1.9.3-p0.tar.bz2) = 9554576
+SHA256 (ruby/ruby-1.9.3-p125.tar.bz2) = c67a59443052b5a9219eb4cee3892bdfbc6f250f0c8e214e02256a4cc7ef5526
+SIZE (ruby/ruby-1.9.3-p125.tar.bz2) = 9733962
diff --git a/lang/ruby19/files/patch-configure.in b/lang/ruby19/files/patch-configure.in
index 5cfbc5cb5bd..e6aeb4a2cd1 100644
--- a/lang/ruby19/files/patch-configure.in
+++ b/lang/ruby19/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2011-10-09 06:17:20.000000000 -0700
-+++ configure.in 2011-11-04 00:52:17.000000000 -0700
-@@ -1112,11 +1112,11 @@
+--- configure.in.orig 2012-02-15 19:26:09.000000000 -0500
++++ configure.in 2012-02-16 22:28:27.617422641 -0500
+@@ -1118,11 +1118,11 @@
[superux*], [ ac_cv_func_setitimer=no
],
[ LIBS="-lm $LIBS"])
@@ -17,7 +17,7 @@
if test "${enable_win95}" = maybe; then
AC_HAVE_LIBRARY(unicows, [enable_win95=yes], [enable_win95=no])
fi
-@@ -1808,7 +1808,7 @@
+@@ -1815,7 +1815,7 @@
fi
if test x"$enable_pthread" = xyes; then
@@ -26,11 +26,11 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
-@@ -1822,6 +1822,7 @@
- [c], [],
- [root], [],
- [c_r], [MAINLIBS="-pthread $MAINLIBS"],
+@@ -1823,6 +1823,7 @@
+ if test x"$rb_with_pthread" = xyes; then
+ AC_DEFINE(_REENTRANT)
+ AC_DEFINE(_THREAD_SAFE)
+ [pthread], [MAINLIBS="-pthread $MAINLIBS"],
- [LIBS="-l$pthread_lib $LIBS"])
- else
- AC_MSG_WARN("Don't know how to find pthread library on your system -- thread support disabled")
+ AC_DEFINE(HAVE_LIBPTHREAD)
+ AC_CHECK_HEADERS(pthread_np.h, [], [], [@%:@include <pthread.h>])
+ AS_CASE([$pthread_lib],
diff --git a/lang/ruby19/files/patch-cont.c b/lang/ruby19/files/patch-cont.c
index 3a18d265e3a..e1323213601 100644
--- a/lang/ruby19/files/patch-cont.c
+++ b/lang/ruby19/files/patch-cont.c
@@ -1,11 +1,11 @@
---- cont.c.orig 2011-11-18 03:37:32.000000000 -0800
-+++ cont.c 2011-11-18 03:38:22.000000000 -0800
+--- cont.c.orig 2012-02-16 22:31:17.691397569 -0500
++++ cont.c 2012-02-16 22:31:31.507395417 -0500
@@ -15,7 +15,7 @@
#include "gc.h"
#include "eval_intern.h"
--#if ((defined(_WIN32) && _WIN32_WINNT >= 0x0400) || defined(HAVE_SETCONTEXT)) && !defined(__NetBSD__) && !defined(sun) && !defined(FIBER_USE_NATIVE)
-+#if ((defined(_WIN32) && _WIN32_WINNT >= 0x0400) || defined(HAVE_SETCONTEXT)) && !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(sun) && !defined(FIBER_USE_NATIVE)
+-#if ((defined(_WIN32) && _WIN32_WINNT >= 0x0400) || (defined(HAVE_GETCONTEXT) && defined(HAVE_SETCONTEXT))) && !defined(__NetBSD__) && !defined(sun) && !defined(FIBER_USE_NATIVE)
++#if ((defined(_WIN32) && _WIN32_WINNT >= 0x0400) || (defined(HAVE_GETCONTEXT) && defined(HAVE_SETCONTEXT))) && !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(sun) && !defined(FIBER_USE_NATIVE)
#define FIBER_USE_NATIVE 1
/* FIBER_USE_NATIVE enables Fiber performance improvement using system
diff --git a/lang/ruby19/pkg-plist b/lang/ruby19/pkg-plist
index f1c983c6355..42bf774bb49 100644
--- a/lang/ruby19/pkg-plist
+++ b/lang/ruby19/pkg-plist
@@ -258,7 +258,6 @@ include/ruby-1.9/ruby.h
%%RUBY_LIBDIR%%/%%RUBY_ARCH%%/coverage.so
%%RUBY_LIBDIR%%/%%RUBY_ARCH%%/curses.so
%%RUBY_LIBDIR%%/%%RUBY_ARCH%%/date_core.so
-%%RUBY_LIBDIR%%/%%RUBY_ARCH%%/dbm.so
%%RUBY_LIBDIR%%/%%RUBY_ARCH%%/digest/bubblebabble.so
%%RUBY_LIBDIR%%/%%RUBY_ARCH%%/digest/md5.so
%%RUBY_LIBDIR%%/%%RUBY_ARCH%%/digest/rmd160.so