aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-06-02 09:17:49 +0800
committergerald <gerald@FreeBSD.org>2013-06-02 09:17:49 +0800
commitf11d5c069c91accd6397cd157b99d36117a845b0 (patch)
tree59b9de3b2955feb3db12fd43c6a564ef8f18d2e2 /lang
parentaccd46c219fd952375272150d06a91e43ec82102 (diff)
downloadfreebsd-ports-graphics-f11d5c069c91accd6397cd157b99d36117a845b0.tar.gz
freebsd-ports-graphics-f11d5c069c91accd6397cd157b99d36117a845b0.tar.zst
freebsd-ports-graphics-f11d5c069c91accd6397cd157b99d36117a845b0.zip
Update to the 20130518 snapshot of GCC 4.7.4.
Introduce a new option BOOTSTRAP that allows switching between a full bootstrap of GCC and just running a simple build. Bootstrapping is the default upstream, and for very stable and old flavors of GCC we disable this by default since that is a huge win in terms of build time of the port. No change in default behavior for this port, for the time being we continue to bootstrap.
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc47/Makefile11
-rw-r--r--lang/gcc47/distinfo4
2 files changed, 11 insertions, 4 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 986de670836..2cfa82d4b89 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 4.7.4.20130413
+PORTVERSION= 4.7.4.20130518
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -38,10 +38,13 @@ MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
+OPTIONS_DEFINE= BOOTSTRAP
OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
+OPTIONS_DEFAULT= BOOTSTRAP
OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
+BOOTSTRAP_DESC= Build using a full bootstrap
.include <bsd.port.pre.mk>
@@ -62,6 +65,11 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
+.if empty(PORT_OPTIONS:MBOOTSTRAP)
+CONFIGURE_ARGS+=--disable-bootstrap
+.else
+ALL_TARGET= bootstrap-lean
+.endif
CONFIGURE_ARGS+=--disable-nls \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
@@ -74,7 +82,6 @@ CONFIGURE_ARGS+=--disable-nls \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
GNU_HOST=${CONFIGURE_TARGET} \
diff --git a/lang/gcc47/distinfo b/lang/gcc47/distinfo
index 8bca03b78fa..d55618dd773 100644
--- a/lang/gcc47/distinfo
+++ b/lang/gcc47/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.7-20130413.tar.bz2) = 9ed42490de334a01596cc1d399fe6a63801174142c23c3193b578e84a7158863
-SIZE (gcc-4.7-20130413.tar.bz2) = 78747169
+SHA256 (gcc-4.7-20130518.tar.bz2) = 540bf28ddac5e028b95cec8446e10a59130c5405e4837873727865c654851d09
+SIZE (gcc-4.7-20130518.tar.bz2) = 78790585