aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-05-19 06:32:17 +0800
committerriggs <riggs@FreeBSD.org>2015-05-19 06:32:17 +0800
commitfa24803c3976ab9ad3e0fb32a220d615fcf78589 (patch)
tree946c742a9043fc232d492fb23a9771af6ae7ee45 /lang
parent5e57943847038600d4c894156aac59dcb93af10b (diff)
downloadfreebsd-ports-graphics-fa24803c3976ab9ad3e0fb32a220d615fcf78589.tar.gz
freebsd-ports-graphics-fa24803c3976ab9ad3e0fb32a220d615fcf78589.tar.zst
freebsd-ports-graphics-fa24803c3976ab9ad3e0fb32a220d615fcf78589.zip
- Update to first stable upstream release 1.0.0
- Reflect stable release in pkg-descr - Pet portlint PR: 200284 Submitted by: maciej@pasternacki.net Reviewed by: riggs
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile16
-rw-r--r--lang/rust/distinfo8
-rw-r--r--lang/rust/files/patch-configure17
-rw-r--r--lang/rust/pkg-descr8
-rw-r--r--lang/rust/pkg-plist136
5 files changed, 88 insertions, 97 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index ab2923f75bf..a20bdfb9bee 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= rust
-PORTVERSION= 0.12.0
-PORTREVISION= 1
+PORTVERSION= 1.0.0
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
http://static.rust-lang.org/stage0-snapshots/:bootstrap
+DISTNAME= ${PORTNAME}c-${PORTVERSION}
DISTFILES= ${RUST_SOURCE}:src \
${RUST_BOOT}:bootstrap
EXTRACT_ONLY= ${RUST_SOURCE}
@@ -23,9 +23,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE-APACHE \
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= requires prebuilt bootstrap compiler
-RUST_SOURCE= ${DISTNAME}${EXTRACT_SUFX}
+RUST_SOURCE= ${DISTNAME}-src${EXTRACT_SUFX}
RUST_BOOT= rust-stage0-${RUST_BOOT_SIG}.tar.bz2
-RUST_BOOT_SIG= 2014-10-04-749ff5e-freebsd-x86_64-f39d94487d29b3d48217b1295ad2cda8c941e694
+RUST_BOOT_SIG= 2015-03-27-5520801-freebsd-x86_64-0910bbad35e213f679d0433884fd51398eb3bc8d
USES= gmake perl5 python:2
HAS_CONFIGURE= yes
@@ -59,8 +59,12 @@ post-extract:
${LN} -sf ${DISTDIR}/${RUST_BOOT} ${WRKSRC}/dl
post-install:
- @${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/manifest
+ @${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/manifest-rustc
+ @${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/install.log
+ @${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/uninstall.sh
@${STRIP_CMD} `${GREP} -v -e '^@dir' -e '^man' -e 'rlib$$' \
- -e '^.*\.a$$' ${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:'`
+ -e '^.*\.a$$' -e '^.*\.py$$' -e '^%' -e '^.*/rust-gdb$$' \
+ -e '^.*rustlib/components$$' -e '^.*/rust-installer-version$$' \
+ ${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:'`
.include <bsd.port.post.mk>
diff --git a/lang/rust/distinfo b/lang/rust/distinfo
index 2a3bd3c16e4..5efd215490a 100644
--- a/lang/rust/distinfo
+++ b/lang/rust/distinfo
@@ -1,4 +1,4 @@
-SHA256 (rust-0.12.0.tar.gz) = 883e66b24d90d9957c5c538469fcde6f0668e5fb6448beecfc60884060e769b7
-SIZE (rust-0.12.0.tar.gz) = 21223176
-SHA256 (rust-stage0-2014-10-04-749ff5e-freebsd-x86_64-f39d94487d29b3d48217b1295ad2cda8c941e694.tar.bz2) = 3f486b75a92c96b4bb63cb043037e6ff58bf5adde9d29e9e197959d6959de0b2
-SIZE (rust-stage0-2014-10-04-749ff5e-freebsd-x86_64-f39d94487d29b3d48217b1295ad2cda8c941e694.tar.bz2) = 12701560
+SHA256 (rustc-1.0.0-src.tar.gz) = c304cbd4f7b25d116b73c249f66bdb5c9da8645855ce195a41bda5077b995eba
+SIZE (rustc-1.0.0-src.tar.gz) = 22121878
+SHA256 (rust-stage0-2015-03-27-5520801-freebsd-x86_64-0910bbad35e213f679d0433884fd51398eb3bc8d.tar.bz2) = a422bd36bc81c9b0dbf0f3b6f5aae34cae6772b7bdffb6c46797cb2931b5e210
+SIZE (rust-stage0-2015-03-27-5520801-freebsd-x86_64-0910bbad35e213f679d0433884fd51398eb3bc8d.tar.bz2) = 15611104
diff --git a/lang/rust/files/patch-configure b/lang/rust/files/patch-configure
index 4c49b411d8e..2b90923d4cf 100644
--- a/lang/rust/files/patch-configure
+++ b/lang/rust/files/patch-configure
@@ -1,15 +1,15 @@
---- configure.orig 2014-01-20 12:44:20.637789551 +0800
-+++ configure 2014-01-20 12:45:23.726260411 +0800
-@@ -424,7 +424,6 @@
+--- configure.orig 2015-05-13 20:03:52 UTC
++++ configure
+@@ -678,7 +678,6 @@ putvar CFG_BOOTSTRAP_KEY
+
step_msg "looking for build programs"
- probe_need CFG_PERL perl
-probe_need CFG_CURLORWGET curl wget
probe_need CFG_PYTHON python2.7 python2.6 python2 python
python_version=$($CFG_PYTHON -V 2>&1)
-@@ -547,14 +546,6 @@
- fi
+@@ -805,13 +804,6 @@ then
+ putvar CFG_LOCAL_RUST_ROOT
fi
-# Force freebsd to build with clang; gcc doesn't like us there
@@ -17,9 +17,8 @@
-then
- step_msg "on FreeBSD, forcing use of clang"
- CFG_ENABLE_CLANG=1
-- putvar CFG_ENABLE_CLANG
-fi
-
- if [ -z "$CFG_ENABLE_CLANG" -a -z "$CFG_GCC" ]
+ # Force bitrig to build with clang; gcc doesn't like us there
+ if [ $CFG_OSTYPE = unknown-bitrig ]
then
- err "either clang or gcc is required"
diff --git a/lang/rust/pkg-descr b/lang/rust/pkg-descr
index c0852bd5d80..4b88f6d8609 100644
--- a/lang/rust/pkg-descr
+++ b/lang/rust/pkg-descr
@@ -1,5 +1,6 @@
-Rust is a systems programming language that runs blazingly fast, prevents
-almost all crashes, and eliminates data races. Some of its features:
+Rust is an open-source systems programming language that runs blazingly
+fast, prevents almost all crashes, and eliminates data races.
+Some of its features:
- Algebraic data types, type inference
- Pattern matching and closures
@@ -10,7 +11,4 @@ almost all crashes, and eliminates data races. Some of its features:
- Minimal runtime
- Efficient C bindings
-Rust is currently work-in-progress. Its development is driven by Mozilla
-with help of large open source community.
-
WWW: http://www.rust-lang.org/
diff --git a/lang/rust/pkg-plist b/lang/rust/pkg-plist
index 85ae3ab6433..98168983b9d 100644
--- a/lang/rust/pkg-plist
+++ b/lang/rust/pkg-plist
@@ -1,91 +1,81 @@
+bin/rust-gdb
bin/rustc
bin/rustdoc
+lib/libarena-4e7c5e5c.so
+lib/libflate-4e7c5e5c.so
+lib/libfmt_macros-4e7c5e5c.so
lib/libgetopts-4e7c5e5c.so
+lib/libgraphviz-4e7c5e5c.so
+lib/liblog-4e7c5e5c.so
+lib/librbml-4e7c5e5c.so
+lib/librustc-4e7c5e5c.so
+lib/librustc_back-4e7c5e5c.so
+lib/librustc_borrowck-4e7c5e5c.so
+lib/librustc_driver-4e7c5e5c.so
+lib/librustc_lint-4e7c5e5c.so
lib/librustc_llvm-4e7c5e5c.so
+lib/librustc_privacy-4e7c5e5c.so
+lib/librustc_resolve-4e7c5e5c.so
+lib/librustc_trans-4e7c5e5c.so
+lib/librustc_typeck-4e7c5e5c.so
lib/librustdoc-4e7c5e5c.so
-lib/libnative-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libstd-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libfourcc-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/liblog-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libcollections-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/librbml-4e7c5e5c.rlib
+lib/libserialize-4e7c5e5c.so
+lib/libstd-4e7c5e5c.so
+lib/libsyntax-4e7c5e5c.so
+lib/libterm-4e7c5e5c.so
+lib/libtest-4e7c5e5c.so
+lib/rustlib/components
+lib/rustlib/etc/gdb_load_rust_pretty_printers.py
+lib/rustlib/etc/gdb_rust_pretty_printing.py
+lib/rustlib/rust-installer-version
lib/rustlib/x86_64-unknown-freebsd/lib/liballoc-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libuuid-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libtime-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libarena-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libarena-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/libcollections-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libcompiler-rt.a
+lib/rustlib/x86_64-unknown-freebsd/lib/libcore-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libflate-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libflate-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/libfmt_macros-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/libgetopts-4e7c5e5c.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libgetopts-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/librustc_llvm-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/librustdoc-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/liblibc-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/liblog-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/liblog-4e7c5e5c.so
lib/rustlib/x86_64-unknown-freebsd/lib/libmorestack.a
-lib/rustlib/x86_64-unknown-freebsd/lib/libnative-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libcore-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libhexfloat-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librand-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/librbml-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/librbml-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc-4e7c5e5c.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_back-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/librustrt-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libunicode-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libgetopts-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libflate-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libsync-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/librlibc-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libflate-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_bitflags-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_borrowck-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_driver-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_lint-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_llvm-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_privacy-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_resolve-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_trans-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustc_typeck-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/librustdoc-4e7c5e5c.so
lib/rustlib/x86_64-unknown-freebsd/lib/libserialize-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libregex-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/liburl-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libregex_macros-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libgreen-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/libserialize-4e7c5e5c.so
+lib/rustlib/x86_64-unknown-freebsd/lib/libstd-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libstd-4e7c5e5c.so
lib/rustlib/x86_64-unknown-freebsd/lib/libsyntax-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libdebug-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libnum-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libnative-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/librand-4e7c5e5c.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libterm-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libtest-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libarena-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libcompiler-rt.a
-lib/rustlib/x86_64-unknown-freebsd/lib/libarena-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libtime-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/liblog-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libregex-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/librbml-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libglob-4e7c5e5c.so
lib/rustlib/x86_64-unknown-freebsd/lib/libterm-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libserialize-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libdebug-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libnum-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libsemver-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libglob-4e7c5e5c.rlib
+lib/rustlib/x86_64-unknown-freebsd/lib/libtest-4e7c5e5c.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libtest-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libgreen-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/librustrt-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libsemver-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libfmt_macros-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libuuid-4e7c5e5c.rlib
-lib/rustlib/x86_64-unknown-freebsd/lib/libsync-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/libstd-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/liburl-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/librustc-4e7c5e5c.so
-lib/rustlib/x86_64-unknown-freebsd/lib/liblibc-4e7c5e5c.rlib
-lib/librustc_back-4e7c5e5c.so
-lib/libflate-4e7c5e5c.so
-lib/libregex-4e7c5e5c.so
-lib/libgraphviz-4e7c5e5c.so
-lib/libsyntax-4e7c5e5c.so
-lib/libarena-4e7c5e5c.so
-lib/libtime-4e7c5e5c.so
-lib/liblog-4e7c5e5c.so
-lib/librbml-4e7c5e5c.so
-lib/libterm-4e7c5e5c.so
-lib/libserialize-4e7c5e5c.so
-lib/libdebug-4e7c5e5c.so
-lib/libtest-4e7c5e5c.so
-lib/librustrt-4e7c5e5c.so
-lib/libfmt_macros-4e7c5e5c.so
-lib/libsync-4e7c5e5c.so
-lib/libstd-4e7c5e5c.so
-lib/librustc-4e7c5e5c.so
-man/man1/rustdoc.1.gz
+lib/rustlib/x86_64-unknown-freebsd/lib/libunicode-4e7c5e5c.rlib
man/man1/rustc.1.gz
+man/man1/rustdoc.1.gz
@dir lib/rustlib/x86_64-unknown-freebsd/lib
@dir lib/rustlib/x86_64-unknown-freebsd
@dir lib/rustlib
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE-APACHE
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE-MIT
+%%PORTDOCS%%%%DOCSDIR%%/README.md