aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-11-23 22:24:17 +0800
committervs <vs@FreeBSD.org>2005-11-23 22:24:17 +0800
commitfb2ab82717932f30161a26dda60a74cade95b3f7 (patch)
treed949750aae7c6e8dff49935452ec6f0ef3fb4644 /lang
parenta3ce4f371e599506f179dccf5f40eb4c4aaeaeb0 (diff)
downloadfreebsd-ports-graphics-fb2ab82717932f30161a26dda60a74cade95b3f7.tar.gz
freebsd-ports-graphics-fb2ab82717932f30161a26dda60a74cade95b3f7.tar.zst
freebsd-ports-graphics-fb2ab82717932f30161a26dda60a74cade95b3f7.zip
Fix build on 4.x
Approved by: maintainer via barner@
Diffstat (limited to 'lang')
-rw-r--r--lang/kawa/Makefile4
-rw-r--r--lang/kawa/files/patch-bin_kawapath.c15
2 files changed, 15 insertions, 4 deletions
diff --git a/lang/kawa/Makefile b/lang/kawa/Makefile
index 31bb33db235..c25846be8d4 100644
--- a/lang/kawa/Makefile
+++ b/lang/kawa/Makefile
@@ -27,10 +27,6 @@ INFO= kawa kawa-tour
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on FreeBSD 4.x
-.endif
-
pre-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
-e 's|sed |gsed |g;' \
diff --git a/lang/kawa/files/patch-bin_kawapath.c b/lang/kawa/files/patch-bin_kawapath.c
new file mode 100644
index 00000000000..506240a8b06
--- /dev/null
+++ b/lang/kawa/files/patch-bin_kawapath.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- bin/kawapath.c.orig
++++ bin/kawapath.c
+@@ -15,8 +15,8 @@
+ const char *path = getenv("KAWALIB");
+ if (path == NULL)
+ {
+- path = kawalib;
+ const char *rp = progname == NULL ? NULL : strrchr(progname, '/');
++ path = kawalib;
+ if (rp != NULL)
+ {
+ /* If kawa is executed "in place" as $builddir/bin/kawa