aboutsummaryrefslogtreecommitdiffstats
path: root/mail/evolution-devel/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-06-30 03:33:26 +0800
committerade <ade@FreeBSD.org>2000-06-30 03:33:26 +0800
commit6f4188c874b99e95f6838f69cdda73c4b7a66575 (patch)
tree8257338f44dde9a8795a891ec413bd52540f1cac /mail/evolution-devel/Makefile
parent5043ab9c0a7a9f565375f9f232d143fc65168c21 (diff)
downloadfreebsd-ports-graphics-6f4188c874b99e95f6838f69cdda73c4b7a66575.tar.gz
freebsd-ports-graphics-6f4188c874b99e95f6838f69cdda73c4b7a66575.tar.zst
freebsd-ports-graphics-6f4188c874b99e95f6838f69cdda73c4b7a66575.zip
Evolution is the integrated mail, calendar and address book
distributed suite for GNOME from Helix Code, Inc.
Diffstat (limited to 'mail/evolution-devel/Makefile')
-rw-r--r--mail/evolution-devel/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/mail/evolution-devel/Makefile b/mail/evolution-devel/Makefile
new file mode 100644
index 00000000000..38cc6291224
--- /dev/null
+++ b/mail/evolution-devel/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: evolution
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= evolution
+PORTVERSION= 0.1
+CATEGORIES= mail gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/evolution
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ xml.5:${PORTSDIR}/textproc/libxml \
+ glade.3:${PORTSDIR}/devel/libglade \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
+ gnomeprint.9:${PORTSDIR}/print/gnomeprint \
+ oaf.0:${PORTSDIR}/devel/oaf \
+ bonobo.2:${PORTSDIR}/devel/bonobo \
+ gnomevfs.0:${PORTSDIR}/devel/gnomevfs \
+ unicode.0:${PORTSDIR}/devel/libunicode \
+ gtkhtml.2:${PORTSDIR}/www/gtkhtml \
+ ldap.1:${PORTSDIR}/net/openldap \
+ capplet.4:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure libical/configure
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+PLIST_SUB= VERSION=${PORTVERSION}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>