aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim-old/Makefile
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>1998-10-07 18:49:32 +0800
committermarkm <markm@FreeBSD.org>1998-10-07 18:49:32 +0800
commitd874cf5091e6c422ecb4a157cb200defccd28d10 (patch)
tree1959dbf0843d03e7a328582979edd4a0c0f2524d /mail/exim-old/Makefile
parent5212af2c903f84e1cc35ebbe95b975e69519399f (diff)
downloadfreebsd-ports-graphics-d874cf5091e6c422ecb4a157cb200defccd28d10.tar.gz
freebsd-ports-graphics-d874cf5091e6c422ecb4a157cb200defccd28d10.tar.zst
freebsd-ports-graphics-d874cf5091e6c422ecb4a157cb200defccd28d10.zip
Update to 2.02; set Sheldon Hearn as maintainer.
*NOTE* Configure file is not backward compatible!! The new configure file is installed as configure.sample.
Diffstat (limited to 'mail/exim-old/Makefile')
-rw-r--r--mail/exim-old/Makefile43
1 files changed, 31 insertions, 12 deletions
diff --git a/mail/exim-old/Makefile b/mail/exim-old/Makefile
index 2fbc2fd5cc9..af7f48ca572 100644
--- a/mail/exim-old/Makefile
+++ b/mail/exim-old/Makefile
@@ -1,27 +1,46 @@
# New ports collection makefile for: exim
-# Version required: 1.92
+# Version required: 2.02
# Date created: 23 June 1996
-# Whom: markm
+# Whom: axl@iafrica.com
#
-# $Id: Makefile,v 1.12 1998/02/09 14:32:28 markm Exp $
+# $Id$
#
-DISTNAME= exim-1.92
+DISTNAME= exim-2.02
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cus.cam.ac.uk/pub/software/programs/exim/
-DISTFILES= exim-1.92.tar.gz exim-texinfo-1.90.tar.gz
+DISTFILES= exim-2.02.tar.gz exim-texinfo-2.00.tar.gz
-MAINTAINER= markm@FreeBSD.ORG
+MAINTAINER= axl@iafrica.com
USE_PERL5= YES
do-configure:
- @${MKDIR} ${WRKSRC}/Local
- @${CP} ${FILESDIR}/Makefile ${WRKSRC}/Local
- @${CP} ${FILESDIR}/eximon.conf ${WRKSRC}/Local
- @(cd ${WRKSRC}/doc ; \
- for i in ../../exim-texinfo-1.90/doc/* ; do \
+ ${MKDIR} ${WRKSRC}/Local
+ if [ ! -d ${X11BASE} ] ; then \
+ ${SED} -e "s#XX_PREFIX_XX#${PREFIX}#" \
+ < ${FILESDIR}/Makefile.no_eximon \
+ > ${WRKSRC}/Local/Makefile ; \
+ else \
+ ${SED} -e "s#XX_PREFIX_XX#${PREFIX}#" \
+ < ${FILESDIR}/Makefile \
+ > ${WRKSRC}/Local/Makefile ; \
+ fi
+ ${CP} ${FILESDIR}/eximon.conf ${WRKSRC}/Local
+ ${CP} ${FILESDIR}/configure.default ${WRKSRC}/src
+ cd ${WRKSRC}/doc && \
+ for i in ../../exim-texinfo-2.00/doc/* ; do \
ln -sf $$i ; \
- done )
+ done
+
+post-build:
+ if [ ! -d ${X11BASE} ] ; then \
+ ${INSTALL_SCRIPT} ${FILESDIR}/eximon ${FILESDIR}/eximon.bin \
+ ${WRKSRC}/build-FreeBSD-i386 ; \
+ fi
+
+post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${PERL5} ${PKGDIR}/INSTALL \
+ exim-2.02 POST-INSTALL
.include <bsd.port.mk>