aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim/Makefile
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2003-03-07 17:39:52 +0800
committersheldonh <sheldonh@FreeBSD.org>2003-03-07 17:39:52 +0800
commit780af0c255ec2035082bf7f344f44288836c2f10 (patch)
tree10de38f32147f2de47022b2b9fb6a679c782eb1b /mail/exim/Makefile
parent42aa49470f83900b6d0697d68a9f642bfd4d0541 (diff)
downloadfreebsd-ports-graphics-780af0c255ec2035082bf7f344f44288836c2f10.tar.gz
freebsd-ports-graphics-780af0c255ec2035082bf7f344f44288836c2f10.tar.zst
freebsd-ports-graphics-780af0c255ec2035082bf7f344f44288836c2f10.zip
Fix the DB_LIB_VERSION=4 case.
Reported by: Andrew Filonov <aef@antar.bryansk.ru> Approved by: portmgr
Diffstat (limited to 'mail/exim/Makefile')
-rw-r--r--mail/exim/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index d74d951dd1b..b1961b25b05 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -169,13 +169,17 @@ SEDLIST+= -e 's,XX_LDAP_[^ ]*_XX,,' \
.if (${DB_LIB_VERSION} == 1)
DB_LIBS=
+DB_INCLUDES=
+SEDLIST+= -e 's,^DBMLIB=,\#DBMLIB=,'
.elif (${DB_LIB_VERSION} == 4)
-DB_LIBS= -ldb4
+DB_LIBS= -L${LOCALBASE}/lib -ldb4
+DB_INCLUDES= -I${LOCALBASE}/include/db4
LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
.else
.error DB_LIB_VERSION must be either 1 or 4
.endif
-SEDLIST+= -e 's,XX_DB_LIBS_XX,${DB_LIBS},'
+SEDLIST+= -e 's,XX_DB_LIBS_XX,${DB_LIBS},' \
+ -e 's,XX_DB_INCLUDES_XX,${DB_INCLUDES},'
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client