aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
authorrea <rea@FreeBSD.org>2011-01-10 18:53:13 +0800
committerrea <rea@FreeBSD.org>2011-01-10 18:53:13 +0800
commit0696b6e14d1a9d5ddb4b4de2a67b453849d59044 (patch)
tree06a6b33641ea40467798209fed83dceedc0dbb26 /mail/exim
parente7c23eb49ea71fc419a5160995fce31800e8a9ae (diff)
downloadfreebsd-ports-graphics-0696b6e14d1a9d5ddb4b4de2a67b453849d59044.tar.gz
freebsd-ports-graphics-0696b6e14d1a9d5ddb4b4de2a67b453849d59044.tar.zst
freebsd-ports-graphics-0696b6e14d1a9d5ddb4b4de2a67b453849d59044.zip
mail/exim: fix variable substitution
There was an extra '=' sign at the sed substitution pattern that affected users of make-only options TRUSTED_CONFIG_LIST and WHITELIST_D_MACROS: Exim binary won't build if any of these options is set. Spotted by: tdb Pointyhat to: rea Approved by: erwin (mentor)
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 95109ff76d3..da94ded3027 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -453,12 +453,12 @@ SEDLIST+= -e 's,^\# (HAVE_IPV6=),\1,'
SEDLIST+= -e 's,^\# (DISABLE_D_OPTION=),\1,'
.else
.if defined(WHITELIST_D_MACROS)
-SEDLIST+= -e 's,^\# (WHITELIST_D_MACROS=).*$$,\1=${WHITELIST_D_MACROS:S/,/\\,/g},'
+SEDLIST+= -e 's,^\# (WHITELIST_D_MACROS=).*$$,\1${WHITELIST_D_MACROS:S/,/\\,/g},'
.endif
.endif
.if defined(TRUSTED_CONFIG_LIST)
-SEDLIST+= -e 's,^\# (TRUSTED_CONFIG_LIST=).*$$,\1=${TRUSTED_CONFIG_LIST:S/,/\\,/g},'
+SEDLIST+= -e 's,^\# (TRUSTED_CONFIG_LIST=).*$$,\1${TRUSTED_CONFIG_LIST:S/,/\\,/g},'
.endif
DUMMY_LDFLAGS!= ${ECHO_CMD} ${LDFLAGS} | ${SED} -e 's|-Wl,-rpath|-Wl,-DUMMYrpath|g; s|-rpath|-Wl,-rpath|g; s|-DUMMYrpath|-rpath|g'