aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mahogany/files/patch-aa
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-11-18 04:43:34 +0800
committerade <ade@FreeBSD.org>2000-11-18 04:43:34 +0800
commit1dc449c8968b28bf109481199597c983ca4281ca (patch)
tree057e2794941b0f37411429b064838273d6a43808 /mail/mahogany/files/patch-aa
parentd3ca4e742df94d84386391a38e719189db25aadd (diff)
downloadfreebsd-ports-graphics-1dc449c8968b28bf109481199597c983ca4281ca.tar.gz
freebsd-ports-graphics-1dc449c8968b28bf109481199597c983ca4281ca.tar.zst
freebsd-ports-graphics-1dc449c8968b28bf109481199597c983ca4281ca.zip
Add mahogany, a threaded X11 mail and news client with an
embedded python interpreter. PR: 22882 Submitted by: S. Kiernan <sk-ports@vegamuse.org>
Diffstat (limited to 'mail/mahogany/files/patch-aa')
-rw-r--r--mail/mahogany/files/patch-aa91
1 files changed, 91 insertions, 0 deletions
diff --git a/mail/mahogany/files/patch-aa b/mail/mahogany/files/patch-aa
new file mode 100644
index 00000000000..08dae241fb9
--- /dev/null
+++ b/mail/mahogany/files/patch-aa
@@ -0,0 +1,91 @@
+--- configure.in.orig Wed Nov 8 10:21:36 2000
++++ configure.in Sun Nov 12 03:40:33 2000
+@@ -309,9 +309,19 @@
+ AC_SUBST(MAKE_USE_LEAKTRACER)
+
+ case "$USE_THREADS" in 1)
+- AC_CHECK_LIB(pthread,main,,AC_CHECK_LIB(pthreads,main))
++ AC_CHECK_LIB(pthread,main,threaded_lib=pthread,
++ AC_CHECK_LIB(pthreads,main,threaded_lib=pthreads,
++ AC_CHECK_LIB(c_r,pthread_self,threaded_lib=c_r,
++ threaded_lib=none)
++ )
++ )
+ AC_DEFINE(USE_THREADS)
+- LIBS="$LIBS -lpthread"
++ case "$threaded_lib" in
++ none) ;;
++ pthread*) LIBS="$LIBS -lpthread" ;;
++ c_r) CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE"
++ LIBS="-pthread $LIBS" ;;
++ esac
+ esac
+
+ dnl set debug/optimisation flags
+@@ -456,15 +466,16 @@
+
+ dnl libresolv or libbind (or simply libc under FreeBSD)
+ USE_RBL=1
+-AC_CHECK_LIB(resolv,res_query,,
+- AC_CHECK_LIB(bind,res_query,,
+- AC_CHECK_LIB(r,res_query,,
+- [
+- AC_MSG_WARN(cannot use RBL spam checker.)
+- USE_RBL=0
+- ]
+- )
+- )
++AC_CHECK_FUNC(res_query,,
++ [AC_CHECK_LIB(resolv,res_query,,
++ [AC_CHECK_LIB(bind,res_query,,
++ [AC_CHECK_LIB(r,res_query,,
++ [AC_MSG_WARN(cannot use RBL spam checker.)
++ USE_RBL=0
++ ]
++ ])
++ ])
++ ])
+ )
+
+ case "$USE_RBL" in 1) AC_DEFINE(USE_RBL) ;; esac
+--- Makefile.orig Mon Nov 6 14:58:02 2000
++++ Makefile Sun Nov 12 06:48:56 2000
+@@ -18,7 +18,7 @@
+ M := mahogany-$(M_VERSION_MAJOR).$(M_VERSION_MINOR)
+
+ doc:
+- set -e; for i in extra doc; do $(MAKE) -C $$i doc; done
++ set -e; for i in extra; do $(MAKE) -C $$i doc; done
+
+ classdoc:
+ set -e; for i in doc; do $(MAKE) -C $$i doc; done
+@@ -63,12 +63,6 @@
+ $(BINDIR) \
+ $(DATADIR) \
+ $(DOCDIR) \
+- $(DATADIR)/$(CANONICAL_HOST) \
+- $(DATADIR)/$(CANONICAL_HOST)/bin \
+- $(DATADIR)/$(CANONICAL_HOST)/lib \
+- $(DATADIR)/bin \
+- $(DATADIR)/lib \
+- $(DATADIR)/doc \
+ $(DOCDIR)/Tips \
+ ;do $(INSTALL) -d -m 755 $$i; \
+ done
+--- makeopts.in.orig Thu Oct 5 09:48:37 2000
++++ makeopts.in Sun Nov 12 17:22:51 2000
+@@ -95,11 +95,11 @@
+ # Directory in which to install library files.
+ DATADIR = $(DESTDIR)/share/Mahogany
+ # where to install docs
+-DOCDIR = $(DATADIR)/doc
++DOCDIR = $(DESTDIR)/share/doc/Mahogany
+
+ # for the dynamic linker, better than using -rpath
+-LD_RUN_PATH=$(DATADIR)/$(CANONICAL_HOST)/lib
+-MODULEDIR=$(DATADIR)/$(CANONICAL_HOST)/modules
++LD_RUN_PATH=$(DESTDIR)/lib
++MODULEDIR=$(DESTDIR)/libdata/Mahogany/modules
+
+ ifdef USE_LIBTOOL
+ LINK = $(LIBTOOL) --mode=link $(CXX) -Wl-r$(LD_RUN_PATH)