aboutsummaryrefslogtreecommitdiffstats
path: root/mail/maildrop
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2005-03-14 22:36:16 +0800
committersergei <sergei@FreeBSD.org>2005-03-14 22:36:16 +0800
commitd2c8a5f9202ada91ec49884348822db32be1d7da (patch)
treefb8cfc0b53cc148d796b06f67b689a262a7bc9cf /mail/maildrop
parent85783fe8f2799afb4b4fa617c5d3e819e2a0e4e3 (diff)
downloadfreebsd-ports-graphics-d2c8a5f9202ada91ec49884348822db32be1d7da.tar.gz
freebsd-ports-graphics-d2c8a5f9202ada91ec49884348822db32be1d7da.tar.zst
freebsd-ports-graphics-d2c8a5f9202ada91ec49884348822db32be1d7da.zip
- Fix MAILDROP_SUID/SGID - Maildrop was installed without suid/sgid bit
even if MAILDROP_SUID/MAILDROP_SGID option is set - fixed NOTE: this changes behavior of these options so that suid/sgid bit is set only if these options are explicitly specified. There is no default value for these options now. - Bump PORTREVISION PR: ports/78715 Submitted by: KIMURA Yasuhiro <yasu@utahime.org>
Diffstat (limited to 'mail/maildrop')
-rw-r--r--mail/maildrop/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index 3bdec79be86..e9bb820b88d 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -10,8 +10,6 @@
# MAILDROP_SUID=<uid>,
# MAILDROP_SGID=<gid> Maildrop will be installed with suid permissions for
# MAILDROP_SUID, and sgid permissions for MAILDROP_SGID.
-# If undefined, these values default to "root" and "mail"
-# respectively, which should be suitable for most systems.
# MAILDROP_TRUSTED_USERS=<user> Specify users allowed to use the -d option
# NO_MAILWRAPPER=yes If defined, let configure guess which sendmail binary
# to use
@@ -19,7 +17,7 @@
PORTNAME= maildrop
PORTVERSION= 1.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
@@ -34,8 +32,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-syslog=1 \
--enable-use-flock=1 \
--with-etcdir="${PREFIX}/etc" \
- --enable-maildrop-uid="${MAILDROP_SUID}" \
- --enable-maildrop-gid="${MAILDROP_SGID}" \
--enable-maildirquota
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CPPFLAGS+= -I${LOCALBASE}/include
@@ -54,6 +50,14 @@ CONFIGURE_ARGS+= --with-db=gdbm
CONFIGURE_ARGS+= --without-db
.endif
+.if defined(MAILDROP_SUID)
+CONFIGURE_ARGS+= --enable-maildrop-uid="${MAILDROP_SUID}"
+.endif
+
+.if defined(MAILDROP_SGID)
+CONFIGURE_ARGS+= --enable-maildrop-gid="${MAILDROP_SGID}"
+.endif
+
.if !defined(NO_MAILWRAPPER)
CONFIGURE_ARGS+= --enable-sendmail=/usr/sbin/sendmail
.endif
@@ -80,9 +84,6 @@ post-patch:
CONFIGURE_ARGS+= --disable-authlib
.endif
-MAILDROP_SUID?= root
-MAILDROP_SGID?= mail
-
.if defined(NOPORTDOCS)
# Just install the binary and man pages, no extra documentation
INSTALL_TARGET= install-maildrop install-deliverquota install-man
@@ -98,9 +99,15 @@ MAN8+= deliverquota.8
DOCS= AUTHORS INSTALL INSTALL.html README README.html README.postfix \
UPGRADE UPGRADE.html maildroptips.txt maildir/README.*
-.if !defined(NOPORTDOCS)
post-install:
+.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
+.if defined(MAILDROP_SUID)
+ ${CHMOD} u+s ${PREFIX}/bin/maildrop
+.endif
+.if defined(MAILDROP_SGID)
+ ${CHMOD} g+s ${PREFIX}/bin/maildrop
+.endif
.include <bsd.port.post.mk>