aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-17 09:16:02 +0800
committersteve <steve@FreeBSD.org>2000-07-17 09:16:02 +0800
commitbf471af82ec0eba4eb816de334c62c244148ef58 (patch)
tree5464584906d96ff4288c072167536384301c5358 /mail/mailman/Makefile
parent834149243d4b397cc6dbba1051224670899ceb99 (diff)
downloadfreebsd-ports-graphics-bf471af82ec0eba4eb816de334c62c244148ef58.tar.gz
freebsd-ports-graphics-bf471af82ec0eba4eb816de334c62c244148ef58.tar.zst
freebsd-ports-graphics-bf471af82ec0eba4eb816de334c62c244148ef58.zip
Adding mailman version 1.1.
Mailman is software to help manage email discussion lists, much like Majordomo and Smartmail. Unlike most similar products, Mailman gives each mailing list a web page, and allows users to subscribe, unsubscribe, etc. over the web. Even the list manager can administer his or her list entirely from the web. Mailman also integrates most things people want to do with mailing lists, including archiving, mail-to-news gateways, integrated bounce handling, spam prevention, email-based admin commands, direct SMTP delivery (with fast bulk mailing), support for virtual domains, and more. PR: 19400 Submitted by: Nick Hibma <n_hibma@calcaphon.com>
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
new file mode 100644
index 00000000000..50872d83375
--- /dev/null
+++ b/mail/mailman/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: mailman
+# Date created: 10 July 2000
+# Whom: n_hibma@qubesoft.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= mailman
+PORTVERSION= 1.1
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= mailman
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
+RUN_DEPENDS+= $(LOCALBASE)/sbin/httpd:${PORTSDIR}/www/apache13\
+ python:${PORTSDIR}/lang/python
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-mail-gid=daemon
+
+UNAME= mailman
+UID= 89
+
+MAILMANDIR= ${PREFIX}/mailman
+
+pre-configure:
+ # Add the username, uid, group amd gid
+ ${SH} ${FILESDIR}/configure.sh ${UNAME} ${UID}
+
+ # Create the dir and the correct permissions for it.
+ ${MKDIR} ${MAILMANDIR}
+ ${CHOWN} ${UNAME}:${UNAME} ${MAILMANDIR}
+ ${CHMOD} g+s ${MAILMANDIR}
+
+post-install:
+ @echo All related binaries have been installed in ${MAILMANDIR}/bin
+ @echo See ${WORKDIR}/INSTALL for installation instructions \($$prefix == ${MAILMANDIR}\).
+ @echo Sample entry for httpd.conf for Apache:
+ @echo " ScriptAlias /mailman/ ${MAILMANDIR}/cgi-bin/"
+ @echo ' <Directory ${MAILMANDIR}/cgi-bin/>'
+ @echo ' Options FollowSymLinks ExecCGI'
+ @echo ' ... other options ...'
+ @echo ' </Directory>'
+
+.include <bsd.port.mk>
+
+# Override the prefix (it is being abused in mailman)
+# XXX It might be a good idea to have a look again at where
+# the various files are put
+CONFIGURE_ARGS+= --prefix=${MAILMANDIR}