aboutsummaryrefslogtreecommitdiffstats
path: root/mail/openwebmail
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-08-13 00:56:40 +0800
committerleeym <leeym@FreeBSD.org>2004-08-13 00:56:40 +0800
commit985189ea0c97f8d8129aa5a4673ed298aff0e18d (patch)
treed6ec290bff374d5a4be5d06b7ff45ed30a1f37bd /mail/openwebmail
parent8b39f376595c60b44a94ce34d9a1e633341aeb48 (diff)
downloadfreebsd-ports-graphics-985189ea0c97f8d8129aa5a4673ed298aff0e18d.tar.gz
freebsd-ports-graphics-985189ea0c97f8d8129aa5a4673ed298aff0e18d.tar.zst
freebsd-ports-graphics-985189ea0c97f8d8129aa5a4673ed298aff0e18d.zip
minor fixes
- add --quiet argument for CPIO - remove the arguments of speedy_suidperl
Diffstat (limited to 'mail/openwebmail')
-rw-r--r--mail/openwebmail/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index e8d7c3eadfa..07ad5512c05 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -115,7 +115,7 @@ pre-fetch:
.endif
pre-patch:
- @${PERL} -pi.bak -e 's,${LOCALBASE}/bin/speedy_suid,${LOCALBASE}/bin/speedy_suidperl,g' ${PATCH_WRKSRC}/uty/*.diff
+ @${PERL} -pi.bak -e 's,${LOCALBASE}/bin/speedy_suid.*,${LOCALBASE}/bin/speedy_suidperl,g' ${PATCH_WRKSRC}/uty/*.diff
post-patch:
@${MV} ${PATCH_WRKSRC}/etc/openwebmail.conf ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
@@ -150,9 +150,9 @@ pre-install:
do-install:
@${MKDIR} ${OWCGIDIR} ${OWDATADIR}
@cd ${WRKSRC}/cgi-bin/openwebmail && ${FIND} . \
- | ${CPIO} -dpum -R ${BINOWN}:mail ${OWCGIDIR}
+ | ${CPIO} -dpum --quiet -R ${BINOWN}:mail ${OWCGIDIR}
@cd ${WRKSRC}/data/openwebmail && ${FIND} . \
- | ${CPIO} -dpum -R ${SHAREOWN}:${SHAREGRP} ${OWDATADIR}
+ | ${CPIO} -dpum --quiet -R ${SHAREOWN}:${SHAREGRP} ${OWDATADIR}
.if !exists(${OWCGIDIR}/etc/openwebmail.conf)
@${CP} ${OWCGIDIR}/etc/openwebmail.conf-dist ${OWCGIDIR}/etc/openwebmail.conf
.endif