aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Email-Stuffer
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-11-22 10:29:55 +0800
committerzi <zi@FreeBSD.org>2013-11-22 10:29:55 +0800
commitdd677d5794483a147a88a2523b5dc82dc1f0359a (patch)
tree39cf06bd6442d43d22b9bcb63e3aa51f6a92c96a /mail/p5-Email-Stuffer
parentfbfc0e4ff9133055fa59fb3bbba02f80b3ae7c14 (diff)
downloadfreebsd-ports-graphics-dd677d5794483a147a88a2523b5dc82dc1f0359a.tar.gz
freebsd-ports-graphics-dd677d5794483a147a88a2523b5dc82dc1f0359a.tar.zst
freebsd-ports-graphics-dd677d5794483a147a88a2523b5dc82dc1f0359a.zip
New port: mail/p5-Email-Stuffer:
Email::Stuffer, as its name suggests, is a fairly casual module used to stuff things into an email and send them. It is a high-level module designed for ease of use when doing a very specific common task, but implemented on top of the light and tolerable Email:: modules. Email::Stuffer is typically used to build emails and send them in a single statement, as seen in the synopsis. And it is certain only for use when creating and sending emails. As such, it contains no email parsing capability, and little to no modification support. WWW: http://search.cpan.org/dist/Email-Stuffer/
Diffstat (limited to 'mail/p5-Email-Stuffer')
-rw-r--r--mail/p5-Email-Stuffer/Makefile27
-rw-r--r--mail/p5-Email-Stuffer/distinfo2
-rw-r--r--mail/p5-Email-Stuffer/pkg-descr11
-rw-r--r--mail/p5-Email-Stuffer/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/mail/p5-Email-Stuffer/Makefile b/mail/p5-Email-Stuffer/Makefile
new file mode 100644
index 00000000000..a1b04351bc9
--- /dev/null
+++ b/mail/p5-Email-Stuffer/Makefile
@@ -0,0 +1,27 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Email-Stuffer
+PORTVERSION= 0.008
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= A more casual approach to creating and sending Email
+
+BUILD_DEPENDS= p5-prefork>=1.01:${PORTSDIR}/devel/p5-prefork \
+ p5-Params-Util>=0.23:${PORTSDIR}/devel/p5-Params-Util \
+ p5-File-Type>=0.22:${PORTSDIR}/devel/p5-File-Type \
+ p5-Email-MIME>=1.901:${PORTSDIR}/mail/p5-Email-MIME \
+ p5-Email-Send>=2.185:${PORTSDIR}/mail/p5-Email-Send
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+MAN3= Email::Stuffer.3
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Stuffer/distinfo b/mail/p5-Email-Stuffer/distinfo
new file mode 100644
index 00000000000..6fa3a503232
--- /dev/null
+++ b/mail/p5-Email-Stuffer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Email-Stuffer-0.008.tar.gz) = 43b83393899184acd16a84339a94ac4f3cecc9e7063c302eca1396e9c1034950
+SIZE (Email-Stuffer-0.008.tar.gz) = 31480
diff --git a/mail/p5-Email-Stuffer/pkg-descr b/mail/p5-Email-Stuffer/pkg-descr
new file mode 100644
index 00000000000..790c0acfe50
--- /dev/null
+++ b/mail/p5-Email-Stuffer/pkg-descr
@@ -0,0 +1,11 @@
+Email::Stuffer, as its name suggests, is a fairly casual module used to stuff
+things into an email and send them. It is a high-level module designed for
+ease of use when doing a very specific common task, but implemented on top of
+the light and tolerable Email:: modules.
+
+Email::Stuffer is typically used to build emails and send them in a single
+statement, as seen in the synopsis. And it is certain only for use when
+creating and sending emails. As such, it contains no email parsing
+capability, and little to no modification support.
+
+WWW: http://search.cpan.org/dist/Email-Stuffer/
diff --git a/mail/p5-Email-Stuffer/pkg-plist b/mail/p5-Email-Stuffer/pkg-plist
new file mode 100644
index 00000000000..dc9a10149f3
--- /dev/null
+++ b/mail/p5-Email-Stuffer/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Email/Stuffer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Stuffer/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Stuffer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email
+@dirrmtry %%SITE_PERL%%/Email