aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Mail-Graph
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
committeradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
commit3285716aaeafc0b799b7d0f09455fb838f7423eb (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /mail/p5-Mail-Graph
parent0e44743df6c6b7c3f4bc9ebe5b47c9868ff2ca6d (diff)
downloadfreebsd-ports-graphics-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.gz
freebsd-ports-graphics-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.zst
freebsd-ports-graphics-3285716aaeafc0b799b7d0f09455fb838f7423eb.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Diffstat (limited to 'mail/p5-Mail-Graph')
-rw-r--r--mail/p5-Mail-Graph/Makefile2
-rw-r--r--mail/p5-Mail-Graph/pkg-plist20
2 files changed, 10 insertions, 12 deletions
diff --git a/mail/p5-Mail-Graph/Makefile b/mail/p5-Mail-Graph/Makefile
index ddb8dadb668..5894befaed2 100644
--- a/mail/p5-Mail-Graph/Makefile
+++ b/mail/p5-Mail-Graph/Makefile
@@ -26,6 +26,8 @@ EXAMPLEARCHIVE= samples/archive/*.gz
SHEBANG_FILES= samples/*.pl
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/archive \
${STAGEDIR}${EXAMPLESDIR}/index ${STAGEDIR}${EXAMPLESDIR}/output
diff --git a/mail/p5-Mail-Graph/pkg-plist b/mail/p5-Mail-Graph/pkg-plist
index 9d3d36aaf0a..3c1dac0572c 100644
--- a/mail/p5-Mail-Graph/pkg-plist
+++ b/mail/p5-Mail-Graph/pkg-plist
@@ -1,14 +1,10 @@
%%SITE_PERL%%/Mail/Graph.pm
-%%EXAMPLESDIR%%/sample.pl
-%%EXAMPLESDIR%%/convert.pl
-%%EXAMPLESDIR%%/index/dummy.txt
-%%EXAMPLESDIR%%/index.tpl
-%%EXAMPLESDIR%%/output/w3c.png
-%%EXAMPLESDIR%%/output/spam.css
-%%EXAMPLESDIR%%/archive/sample.txt.gz
-%%EXAMPLESDIR%%/archive/sample2.txt.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/convert.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index/dummy.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index.tpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/output/w3c.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/output/spam.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/archive/sample.txt.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/archive/sample2.txt.gz
%%PERL5_MAN3%%/Mail::Graph.3.gz
-@dirrm %%EXAMPLESDIR%%/archive
-@dirrm %%EXAMPLESDIR%%/index
-@dirrm %%EXAMPLESDIR%%/output
-@dirrm %%EXAMPLESDIR%%