aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pine4
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-10-30 09:35:21 +0800
committerkris <kris@FreeBSD.org>2000-10-30 09:35:21 +0800
commit49a4dea9cedc7d2c464c634857dacbd4d1439398 (patch)
tree6b6cd0e94c8d67c913765d3455833f15712ea248 /mail/pine4
parent1d983fc22e81e0b40ef01f074884387251486b7c (diff)
downloadfreebsd-ports-graphics-49a4dea9cedc7d2c464c634857dacbd4d1439398.tar.gz
freebsd-ports-graphics-49a4dea9cedc7d2c464c634857dacbd4d1439398.tar.zst
freebsd-ports-graphics-49a4dea9cedc7d2c464c634857dacbd4d1439398.zip
Add a patch to address the known remote buffer overflow, from
Mike Silbersack <silby@silby.com>. Add a build- and install-time warning about the probable existence of further remote security problems, and remove FORBIDDEN. Submitted by: Mike Silbersack <silby@silby.com>
Diffstat (limited to 'mail/pine4')
-rw-r--r--mail/pine4/Makefile7
-rw-r--r--mail/pine4/files/patch-ba20
-rw-r--r--mail/pine4/pkg-install9
3 files changed, 34 insertions, 2 deletions
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index 14e696fc7db..3fc402276c5 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -16,8 +16,6 @@ DISTNAME?= ${PORTNAME}${PORTVERSION}
MAINTAINER?= pine@freebsd.ady.ro
-FORBIDDEN= "Remotely exploitable buffer overflows."
-
Y2K= http://www.washington.edu/pine/QandA/sysadmins.html#Millenium
MAN1= pine.1 pico.1 pilot.1
@@ -33,6 +31,11 @@ LDAP_PREFIX?= ${LOCALBASE}
BUILD_DEPENDS+= ${LDAP_PREFIX}/lib/libldap.a:${PORTSDIR}/net/ldap
.endif
+pre-fetch:
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+ ${SH} pkg-install
+.endif
+
post-patch:
for i in ${WRKSRC}/doc/pine.1 \
${WRKSRC}/pine/init.c \
diff --git a/mail/pine4/files/patch-ba b/mail/pine4/files/patch-ba
new file mode 100644
index 00000000000..84b34295397
--- /dev/null
+++ b/mail/pine4/files/patch-ba
@@ -0,0 +1,20 @@
+*** pine/newmail.c.orig Mon Sep 25 15:07:01 2000
+--- pine/newmail.c Tue Sep 26 15:34:24 2000
+***************
+*** 342,348 ****
+ e->from->personal, NULL),
+ ps_global->ttyo->screen_cols);
+ else
+! sprintf(from + ((number > 1L) ? 18 : 6), "%s%s%s",
+ e->from->mailbox,
+ e->from->host ? "@" : "",
+ e->from->host ? e->from->host : "");
+--- 342,349 ----
+ e->from->personal, NULL),
+ ps_global->ttyo->screen_cols);
+ else
+! snprintf(from + ((number > 1L) ? 18 : 6), sizeof(from) - strlen(from),
+! "%s%s%s",
+ e->from->mailbox,
+ e->from->host ? "@" : "",
+ e->from->host ? e->from->host : "");
diff --git a/mail/pine4/pkg-install b/mail/pine4/pkg-install
new file mode 100644
index 00000000000..b8e5db1ea6e
--- /dev/null
+++ b/mail/pine4/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" -o -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+/usr/bin/dialog --yesno "SECURITY NOTE: The pine software has had several remote vulnerabilities discovered in the past, which allowed remote attackers to execute arbitrary code as you on your local system, by the action of sending a specially-prepared email. All such KNOWN problems have been fixed, but the pine code is written in a very insecure style and the FreeBSD Security Officer believes there are likely to be other undiscovered vulnerabilities. Do you wish to proceed with the installation of pine anyway?" 12 70 || /usr/bin/false
+
+