aboutsummaryrefslogtreecommitdiffstats
path: root/mail/popular
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-14 23:42:21 +0800
committerpav <pav@FreeBSD.org>2006-06-14 23:42:21 +0800
commitc360555d8ed30c884efe6a6cd5691887b2742205 (patch)
tree4518db0c6e6691a834ca4b86b9a09769f012ebbf /mail/popular
parentc539aa43287943e99587f8532263586328cd6bf0 (diff)
downloadfreebsd-ports-graphics-c360555d8ed30c884efe6a6cd5691887b2742205.tar.gz
freebsd-ports-graphics-c360555d8ed30c884efe6a6cd5691887b2742205.tar.zst
freebsd-ports-graphics-c360555d8ed30c884efe6a6cd5691887b2742205.zip
- Fix time values parsing on FreeBSD 5.X and up
Reported by: Vlastimil Zeman <vlastimil.zeman@col.cz>
Diffstat (limited to 'mail/popular')
-rw-r--r--mail/popular/Makefile2
-rw-r--r--mail/popular/files/patch-src-util.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/popular/Makefile b/mail/popular/Makefile
index a0f4c6121a7..4b0d8b18596 100644
--- a/mail/popular/Makefile
+++ b/mail/popular/Makefile
@@ -7,7 +7,7 @@
PORTNAME= popular
PORTVERSION= 1.5.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.remote.org/jochen/mail/popular/download/
diff --git a/mail/popular/files/patch-src-util.c b/mail/popular/files/patch-src-util.c
new file mode 100644
index 00000000000..c1a9e983bd9
--- /dev/null
+++ b/mail/popular/files/patch-src-util.c
@@ -0,0 +1,11 @@
+--- src/util.c.orig Mon Apr 30 17:14:14 2001
++++ src/util.c Wed Jun 7 13:19:59 2006
+@@ -125,7 +125,7 @@
+ while (1) {
+ if (*tptr == '-') return -1;
+ value = strtol(tptr, &tptr, 10);
+- if (errno) return -1;
++ if (errno && errno != EINVAL) return -1;
+ switch (*tptr) {
+ case 'd':
+ sec += value*60*60*24;