aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix-current
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-12-01 08:37:41 +0800
committermnag <mnag@FreeBSD.org>2005-12-01 08:37:41 +0800
commit93f1311f7b22366bb7e6773041fc61d5940a20e5 (patch)
tree43c4d3be5247582643650f13b0a7a62748bb4fff /mail/postfix-current
parent88634aaee60ba2129e38ae28eb8420abafbbac48 (diff)
downloadfreebsd-ports-graphics-93f1311f7b22366bb7e6773041fc61d5940a20e5.tar.gz
freebsd-ports-graphics-93f1311f7b22366bb7e6773041fc61d5940a20e5.tar.zst
freebsd-ports-graphics-93f1311f7b22366bb7e6773041fc61d5940a20e5.zip
Backport from mail/postfix MIT Kerberos 5 option
Diffstat (limited to 'mail/postfix-current')
-rw-r--r--mail/postfix-current/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index b9503b3797b..a8c8c385319 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -35,6 +35,7 @@ OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" off \
SASLKRB "If your SASL requires Kerberos select this option" off \
SASLKRB5 "If your SASL requires Kerberos5 select this option" off \
+ SASLKRB5MIT "If your SASL requires MIT Kerberos5 select this option" off\
TLS "Enable SSL and TLS support" off \
DB3 "Berkeley DB3 (required if SASL built with DB3)" off \
DB40 "Berkeley DB4.0 (required if SASL built with DB4.0)" off \
@@ -110,19 +111,27 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_SASLKRB)
-.if defined(WITH_SASLKRB5)
+.if defined(WITH_SASLKRB5) || defined(WITH_SASLKRB5MIT)
BROKEN= "Select only one SASL Kerberos option"
.endif
POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.endif
.if defined(WITH_SASLKRB5)
-.if defined(WITH_SASLKRB)
+.if defined(WITH_SASLKRB) || defined(WITH_SASLKRB5MIT)
BROKEN= "Select only one SASL Kerberos option"
.endif
POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken
.endif
+.if defined(WITH_SASLKRB5MIT)
+.if defined(WITH_SASLKRB) || defined(WITH_SASLKRB5)
+BROKEN= "Select only one SASL Kerberos option"
+.endif
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
+POSTFIX_AUXLIBS+= -Wl,--rpath,$${KRB5_HOME:-${LOCALBASE}}/lib -lkrb5 -lcrypto -lcrypt -lcom_err
+.endif
+
.if defined(WITH_TLS)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
POSTFIX_CCARGS+= -DUSE_TLS -I${OPENSSLINC}