aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmailadmin
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2004-06-29 09:02:46 +0800
committerroam <roam@FreeBSD.org>2004-06-29 09:02:46 +0800
commit628254df4589d9330bc3ab13e298ef8e8fd37782 (patch)
treecd7ddc9ce21e0d428fec56dd8914834f41af4810 /mail/qmailadmin
parent8d2848531b6b81e4cb1c87fb7b3f3b308b59eecc (diff)
downloadfreebsd-ports-graphics-628254df4589d9330bc3ab13e298ef8e8fd37782.tar.gz
freebsd-ports-graphics-628254df4589d9330bc3ab13e298ef8e8fd37782.tar.zst
freebsd-ports-graphics-628254df4589d9330bc3ab13e298ef8e8fd37782.zip
Add the WITH_SPAM_DETECTION and SPAM_COMMAND knobs.
Submitted by: Rey Marin Jr. <rey.marin@gmail.com>
Diffstat (limited to 'mail/qmailadmin')
-rw-r--r--mail/qmailadmin/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index e5624340ad1..0127c386b48 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmailadmin
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -57,6 +57,11 @@ USE_GMAKE= YES
# WITHOUT_IDX_SQL - disable the SQL support for mailing lists
# WITH_HELP - display help links on login page
#
+# WITH_SPAM_DETECTION - allow users to enable/disable spam checking
+# SPAM_COMMAND - the command to use to check for spam;
+# default is "|preline /usr/local/bin/maildrop /etc/mailfilter"
+# do not forget the "|" at the start
+#
CGIBINDIR?= www/cgi-bin.default
CGIBINSUBDIR?= qmailadmin
@@ -118,4 +123,11 @@ CONFIGURE_ARGS+= --disable-ezmlm-mysql
CONFIGURE_ARGS+= --enable-help
.endif
+.if defined(WITH_SPAM_DETECTION)
+CONFIGURE_ARGS+= --enable-modify-spam=y
+.if defined(SPAM_COMMAND)
+CONFIGURE_ARGS+= --enable-spam-command="${SPAM_COMMAND}"
+.endif
+.endif
+
.include <bsd.port.post.mk>