aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qpopper/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-11-01 18:20:38 +0800
committersobomax <sobomax@FreeBSD.org>2000-11-01 18:20:38 +0800
commit3a5be9db7a990479cf1e59a904a3fd74ee5a2817 (patch)
treec2b8cc1a90a2c335e093cf5c5cf7e7a6d81422e1 /mail/qpopper/files
parentc2e5deeb010973a0137e6bc01d5e43d04e7335f9 (diff)
downloadfreebsd-ports-graphics-3a5be9db7a990479cf1e59a904a3fd74ee5a2817.tar.gz
freebsd-ports-graphics-3a5be9db7a990479cf1e59a904a3fd74ee5a2817.tar.zst
freebsd-ports-graphics-3a5be9db7a990479cf1e59a904a3fd74ee5a2817.zip
Merge popper3 and qpopper into single qpopper and remove popper3.
Reminded by: knu Hall of shame entry: alex
Diffstat (limited to 'mail/qpopper/files')
-rw-r--r--mail/qpopper/files/patch-aa45
-rw-r--r--mail/qpopper/files/patch-ac32
-rw-r--r--mail/qpopper/files/patch-ao17
-rw-r--r--mail/qpopper/files/patch-ap43
-rw-r--r--mail/qpopper/files/patch-aq14
-rw-r--r--mail/qpopper/files/patch-ar15
6 files changed, 160 insertions, 6 deletions
diff --git a/mail/qpopper/files/patch-aa b/mail/qpopper/files/patch-aa
new file mode 100644
index 00000000000..3f46923a351
--- /dev/null
+++ b/mail/qpopper/files/patch-aa
@@ -0,0 +1,45 @@
+--- popper/Makefile.in.orig Thu Aug 17 01:36:14 2000
++++ popper/Makefile.in Wed Nov 1 11:37:31 2000
+@@ -74,9 +74,9 @@
+ pop_msg.o pop_parse.o pop_pass.o pop_quit.o \
+ pop_rset.o pop_send.o pop_stat.o pop_updt.o \
+ pop_user.o pop_xtnd.o pop_xmit.o popper.o \
+- pop_bull.o xtnd_xlst.o pop_uidl.o mktemp.o \
+- pop_rpop.o pop_apop.o md5.o pop_auth.o pop_pope.o \
+- pop_extend.o scram.o hmac.o base64.o pop_util.o \
++ pop_bull.o xtnd_xlst.o pop_uidl.o \
++ pop_rpop.o pop_apop.o pop_auth.o pop_pope.o \
++ pop_extend.o scram.o hmac.o pop_util.o \
+ get_sub_opt.o msg_ptr.o drac.o pop_config.o main.o
+
+ SRCS = pop_dele.c pop_dropcopy.c \
+@@ -85,15 +85,15 @@
+ pop_msg.c pop_parse.c pop_pass.c pop_quit.c \
+ pop_rset.c pop_send.c pop_stat.c pop_updt.c \
+ pop_user.c pop_xtnd.c pop_xmit.c popper.c \
+- pop_bull.c xtnd_xlst.c pop_uidl.c mktemp.c \
+- pop_rpop.c pop_apop.c md5.c pop_auth.c pop_pope.c \
+- pop_extend.c scram.c hmac.c base64.c pop_util.c \
++ pop_bull.c xtnd_xlst.c pop_uidl.c \
++ pop_rpop.c pop_apop.c pop_auth.c pop_pope.c \
++ pop_extend.c scram.c hmac.c pop_util.c \
+ get_sub_opt.c msg_ptr.c drac.c pop_config.c main.c
+
+-POPAUTHOBJS = base64.o scram.o md5.o \
++POPAUTHOBJS = scram.o \
+ hmac.o popauth.o
+
+-POPAUTHSRCS = base64.c scram.c md5.c \
++POPAUTHSRCS = scram.c \
+ hmac.c popauth.c
+
+ INCLUDES = ${srcdir}/popper.h ${srcdir}/version.h \
+@@ -133,7 +133,7 @@
+ -I${common_srcdir} ${common_dir}/libcommon.a
+
+ popauth: ${POPAUTHOBJS}
+- ${CC} -o popauth ${POPAUTHOBJS} ${NETWORK_LIBS} ${DBM_LIBS} \
++ ${CC} -o popauth ${POPAUTHOBJS} ${LIBS} ${NETWORK_LIBS} ${DBM_LIBS} \
+ ${common_dir}/libcommon.a
+
+ .c.o:
diff --git a/mail/qpopper/files/patch-ac b/mail/qpopper/files/patch-ac
index 94ef0776838..e4b4db0e076 100644
--- a/mail/qpopper/files/patch-ac
+++ b/mail/qpopper/files/patch-ac
@@ -1,11 +1,37 @@
---- man/popper.8.orig Sun Sep 10 08:52:41 2000
-+++ man/popper.8 Fri Oct 6 02:49:25 2000
+--- man/popper.8.orig Wed Nov 1 11:33:06 2000
++++ man/popper.8 Wed Nov 1 11:38:58 2000
@@ -19,7 +19,7 @@
.SH NAME
qpopper \-\- pop 3 server (v3.1b7)
.SH SYNOPSIS
-.B /usr/local/lib/popper
-+.B !!PREFIX!!/libexec/qpopper
++.B %%PREFIX%%/libexec/qpopper
[
.I [ address ]
.I [ ":" ]
+@@ -628,7 +628,7 @@
+ systems with BSD 4.3 syslogging, the server logs (by default) to the
+ "local0" facility at priority "notice" for all messages except
+ debugging which is logged at priority "debug". The default log file is
+-/usr/spool/mqueue/POPlog. These can be changed, if desired. On
++/var/log/messages. These can be changed, if desired. On
+ systems with 4.2 syslogging all messages are logged to the local log
+ file, usually /usr/spool/mqueue/syslog.
+ .SH DEBUGGING
+@@ -663,7 +663,7 @@
+ .PP
+ The server implements several extended commands.
+ .PP
+-XTND XMIT: Sends a mail message using /usr/lib/sendmail.
++XTND XMIT: Sends a mail message using /usr/sbin/sendmail.
+ .PP
+ XTND XLIST header [num]: Extracts and returns the specified header line
+ for the specified message number. If the "num" parameter is missing,
+@@ -688,6 +688,7 @@
+ .SH FILES
+ .nf
+ /var/mail mail files
++/etc/ftpusers list of unwelcome/restricted users
+ /etc/inetd.conf pop program invocation
+ /etc/syslog.conf logging specifications
+ /var/spool/bulls bulletins
diff --git a/mail/qpopper/files/patch-ao b/mail/qpopper/files/patch-ao
new file mode 100644
index 00000000000..c1cf86d5002
--- /dev/null
+++ b/mail/qpopper/files/patch-ao
@@ -0,0 +1,17 @@
+--- popper/popauth.c.orig Wed Nov 1 11:42:03 2000
++++ popper/popauth.c Wed Nov 1 11:41:56 2000
+@@ -154,11 +154,11 @@
+ char *name;
+ } modes[] = {
+ #define SCRAM_AUTH 0
+- { "scramauth" },
++ { "qscramauth" },
+ #define APOP_AUTH 1
+- { "apopauth" },
++ { "qapopauth" },
+ #define POP_AUTH 2
+- { "popauth" },
++ { "qpopauth" },
+ #define OTHER 3
+ { NULL }
+ };
diff --git a/mail/qpopper/files/patch-ap b/mail/qpopper/files/patch-ap
index 97f4688c9e2..724eea5c1e7 100644
--- a/mail/qpopper/files/patch-ap
+++ b/mail/qpopper/files/patch-ap
@@ -1,11 +1,48 @@
---- man/popauth.8.orig Mon Aug 21 06:18:08 2000
-+++ man/popauth.8 Fri Oct 6 02:54:02 2000
+--- man/popauth.8.orig Mon Aug 21 00:18:08 2000
++++ man/popauth.8 Wed Nov 1 11:50:18 2000
+@@ -7,11 +7,11 @@
+ .\" See License.txt file for terms and conditions for modification and
+ .\" redistribution.
+ .\"
+-.TH POPAUTH 8
++.TH QPOPAUTH 8
+ .SH NAME
+-popauth \-\- manipulate POP authorization DB
++qpopauth \-\- manipulate POP authorization DB
+ .SH SYNOPSIS
+-.B popauth
++.B qpopauth
+ [
+ .BI \-trace " tracefile"
+ ] [
+@@ -43,18 +43,18 @@
+ ]
+
+ .SH DESCRIPTION
+-The \fIpopauth\fR program allows a POP-subscribers to add or change the secret
++The \fIqpopauth\fR program allows a POP-subscribers to add or change the secret
+ values used to generate their authentication credentials, or to verify the
+ existance of their records.
+
+ In addition,the super\-user or master POP user can add, delete, or reset
+ credential data for a user, or list which records exist. Only the
+-super\-user may initialize the database. \fIpopauth\fR is useful only when
++super\-user may initialize the database. \fIqpopauth\fR is useful only when
+ the APOP (or SCRAM) configuration option is defined. See the INSTALL file
+ in the Qpopper distribution for more information.
+
+ Under normal usage,
+-\fIpopauth\fR prompts for a new secret,
++\fIqpopauth\fR prompts for a new secret,
+ just like the \fIpasswd\fR program. It then updates the authorization DB.
+
+ With the `\-user' switch,
@@ -74,8 +74,8 @@
With the `\-delete' switch, the super-user or master POP user can remove
a user entry from the authorization DB.
.SH FILES
-/etc/pop.auth.* POP authorization DB
-+!!PREFIX!!/etc/qpopper/pop.auth.* POP authorization DB
++%%PREFIX%%/etc/qpopper/pop.auth.* POP authorization DB
.SH ACKNOWLEDGEMENTS
This program was derived from MH 6.8.3
.SH SEE ALSO
diff --git a/mail/qpopper/files/patch-aq b/mail/qpopper/files/patch-aq
new file mode 100644
index 00000000000..4fd927cb1bd
--- /dev/null
+++ b/mail/qpopper/files/patch-aq
@@ -0,0 +1,14 @@
+--- popper/scram.c.orig Tue Jul 25 04:07:21 2000
++++ popper/scram.c Wed Nov 1 11:46:31 2000
+@@ -17,7 +17,10 @@
+ #include <sys/types.h>
+ #include <netinet/in.h>
+
+-#include "md5.h"
++#include <md5.h>
++
++#define UINT4 u_int32_t
++
+ #include "hmac-md5.h"
+ #include "scram.h"
+
diff --git a/mail/qpopper/files/patch-ar b/mail/qpopper/files/patch-ar
new file mode 100644
index 00000000000..c6736220364
--- /dev/null
+++ b/mail/qpopper/files/patch-ar
@@ -0,0 +1,15 @@
+--- popper/hmac.c.orig Sat Jul 1 00:58:28 2000
++++ popper/hmac.c Wed Nov 1 11:46:36 2000
+@@ -12,7 +12,11 @@
+
+ #include <stdio.h>
+ #include <string.h>
+-#include "md5.h"
++#include <sys/types.h>
++#include <md5.h>
++
++#define UINT4 u_int32_t
++
+ #include "hmac-md5.h"
+
+