aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spruce/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>2000-05-22 05:45:02 +0800
committercpiazza <cpiazza@FreeBSD.org>2000-05-22 05:45:02 +0800
commitf1563a44592b5bdf0a9691b6edaedf9e8b1a8c43 (patch)
treeb7a3da565dab1f0ea538487272da733c576bea0f /mail/spruce/Makefile
parentb26b3187619442bc80c16b5f1a3858b58bdaa36e (diff)
downloadfreebsd-ports-graphics-f1563a44592b5bdf0a9691b6edaedf9e8b1a8c43.tar.gz
freebsd-ports-graphics-f1563a44592b5bdf0a9691b6edaedf9e8b1a8c43.tar.zst
freebsd-ports-graphics-f1563a44592b5bdf0a9691b6edaedf9e8b1a8c43.zip
Update to 0.6.5
Diffstat (limited to 'mail/spruce/Makefile')
-rw-r--r--mail/spruce/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/mail/spruce/Makefile b/mail/spruce/Makefile
index a6fe9350fd2..6d064a6e224 100644
--- a/mail/spruce/Makefile
+++ b/mail/spruce/Makefile
@@ -6,19 +6,25 @@
#
PORTNAME= spruce
-PORTVERSION= 0.4.9f
+PORTVERSION= 0.6.5
CATEGORIES= mail
-MASTER_SITES= http://www.xtorshun.org/spruce/ \
- http://fundy.linuxberg.com/files/x11/network/ \
- ftp://ftp.loxinfo.co.th/pub/unix/mail/
+MASTER_SITES= http://www.xtorshun.org/spruce/v0.6/ \
+ http://fundy.linuxberg.com/files/x11/network/
MAINTAINER= cpiazza@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+GTK_CONFIG= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG= ${LOCALBASE}/bin/glib12-config
+
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
+CONFIGURE_ENV= GTK_CONFIG=${GTK_CONFIG} GLIB_CONFIG=${GLIB_CONFIG} \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
USE_GMAKE= yes
+MAN1= spruce.1
+
.include <bsd.port.mk>