aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sylpheed2
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-02-21 19:49:57 +0800
committeroliver <oliver@FreeBSD.org>2005-02-21 19:49:57 +0800
commitb14240f37dd7ca0ce775f887040086bf9027769c (patch)
tree8e4d6b7406413bdbce9f4c518b3f5a6c48ef7cd6 /mail/sylpheed2
parent5d152857d0b2f823d741426f234b4378a58344cc (diff)
downloadfreebsd-ports-graphics-b14240f37dd7ca0ce775f887040086bf9027769c.tar.gz
freebsd-ports-graphics-b14240f37dd7ca0ce775f887040086bf9027769c.tar.zst
freebsd-ports-graphics-b14240f37dd7ca0ce775f887040086bf9027769c.zip
update to 1.9.3
add a patch which fixes non-7-bit-clean header handling
Diffstat (limited to 'mail/sylpheed2')
-rw-r--r--mail/sylpheed2/Makefile2
-rw-r--r--mail/sylpheed2/distinfo4
-rw-r--r--mail/sylpheed2/files/patch-src::codeconv.c24
3 files changed, 27 insertions, 3 deletions
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 582a153ce3c..b775faf6d3f 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sylpheed
-PORTVERSION= 1.9.1
+PORTVERSION= 1.9.3
PORTREVISION= 0
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
diff --git a/mail/sylpheed2/distinfo b/mail/sylpheed2/distinfo
index 754a8cadd84..85a95928124 100644
--- a/mail/sylpheed2/distinfo
+++ b/mail/sylpheed2/distinfo
@@ -1,4 +1,4 @@
-MD5 (sylpheed/sylpheed-1.9.1.tar.bz2) = 3164a9db5a7a50902083fb3b05c486ae
-SIZE(sylpheed/sylpheed-1.9.1.tar.bz2) = 2303268
+MD5 (sylpheed/sylpheed-1.9.3.tar.bz2) = 975a6282ddbd5fe8e2d0ec7081631808
+SIZE(sylpheed/sylpheed-1.9.3.tar.bz2) = 2221199
MD5 (sylpheed/mime.types) = 7c0563d85e2e830c0266d54517ad62e8
SIZE(sylpheed/mime.types) = 14979
diff --git a/mail/sylpheed2/files/patch-src::codeconv.c b/mail/sylpheed2/files/patch-src::codeconv.c
new file mode 100644
index 00000000000..5946301287b
--- /dev/null
+++ b/mail/sylpheed2/files/patch-src::codeconv.c
@@ -0,0 +1,24 @@
+--- src/codeconv.c.orig Mon Feb 21 12:46:21 2005
++++ src/codeconv.c Mon Feb 21 12:46:30 2005
+@@ -1577,8 +1577,20 @@
+ Xalloca(buf, buflen, return);
+ conv_anytodisp(buf, buflen, str);
+ unmime_header(outbuf, buf);
+- } else
++ } else {
++ gchar *tmp;
+ unmime_header(outbuf, str);
++ if (outbuf && !g_utf8_validate(outbuf, -1, NULL)) {
++ tmp = conv_codeset_strdup(outbuf,
++ conv_get_locale_charset_str(),
++ CS_UTF_8);
++ if (tmp) {
++ strncpy(outbuf, tmp, outlen-1);
++ g_free(tmp);
++ }
++ }
++ }
++
+ }
+
+ #define MAX_LINELEN 76