aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sylpheed2
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-01-21 13:03:38 +0800
committerpat <pat@FreeBSD.org>2002-01-21 13:03:38 +0800
commite391e2ddfb248f825a82c09e65265bad05bebf4f (patch)
tree5b8db257988c5a3cd258ce0ac8e52e65bff8f73d /mail/sylpheed2
parent9f35e4bf675b826c3c0118436c3c5a1c57e3243d (diff)
downloadfreebsd-ports-graphics-e391e2ddfb248f825a82c09e65265bad05bebf4f.tar.gz
freebsd-ports-graphics-e391e2ddfb248f825a82c09e65265bad05bebf4f.tar.zst
freebsd-ports-graphics-e391e2ddfb248f825a82c09e65265bad05bebf4f.zip
Add knob to enable LDAP support, no PORTREVISION bump required.
PR: 34090 Submitted by: maintainer
Diffstat (limited to 'mail/sylpheed2')
-rw-r--r--mail/sylpheed2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index b8f29d22979..e4fa03742d7 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -55,6 +55,12 @@ CONFIGURE_ARGS+=--enable-jpilot
.else
CONFIGURE_ARGS+= --disable-jpilot
.endif
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+CONFIGURE_ARGS+=--enable-ldap
+.else
+CONFIGURE_ARGS+=--disable-ldap
+.endif
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+=--enable-ssl
@@ -72,10 +78,15 @@ pre-everything::
@${ECHO} " WITH_JCONV=yes Enable Japanese charset conversion"
@${ECHO} " library libjconv."
@${ECHO} " WITH_JPILOT=yes Enable JPilot support."
+ @${ECHO} " WITH_LDAP=yes Enable LDAP support."
@${ECHO} ""
@${ECHO} " WITHOUT_SSL=yes Disable OpenSSL support."
@${ECHO} ""
+post-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
+ s|-lresolv||g' ${WRKSRC}/configure
+
pre-build:
${LN} -sf ${LOCALBASE}/bin/${LIBTOOL} ${WRKSRC}/libtool