aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird3/files
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-11-22 12:16:25 +0800
committermarcus <marcus@FreeBSD.org>2004-11-22 12:16:25 +0800
commit19945cac1dc8c098bdd851c2fb1b7605f03b6cba (patch)
treee5f888cc813c63c94ab51ea9dfdc9ce72fa370c5 /mail/thunderbird3/files
parent923d8a6ec2413e75522da7bf04d230180e560ab1 (diff)
downloadfreebsd-ports-graphics-19945cac1dc8c098bdd851c2fb1b7605f03b6cba.tar.gz
freebsd-ports-graphics-19945cac1dc8c098bdd851c2fb1b7605f03b6cba.tar.zst
freebsd-ports-graphics-19945cac1dc8c098bdd851c2fb1b7605f03b6cba.zip
* Instead of using Xvfb, and evil black magic to create the extensions
repository, use the hidden "-register" option instead. This has the advantage of not requiring an X DISPLAY and not modifying any preferences. * Add i18n support to the Thunderbird startup script [1] * Link nss with -Bsymbolic to avoid symbol conflicts with OpenSSL. This should help alleviate the CUPS printing problem PR: 73839 [1] Submitted by: Jose M Rodriguez <josemi@freebsd.jazztel.es> [1]
Diffstat (limited to 'mail/thunderbird3/files')
-rw-r--r--mail/thunderbird3/files/patch-mail_app_mozilla.in34
-rw-r--r--mail/thunderbird3/files/patch-security-coreconf-FreeBSD.mk22
2 files changed, 53 insertions, 3 deletions
diff --git a/mail/thunderbird3/files/patch-mail_app_mozilla.in b/mail/thunderbird3/files/patch-mail_app_mozilla.in
new file mode 100644
index 00000000000..12eed67ff3e
--- /dev/null
+++ b/mail/thunderbird3/files/patch-mail_app_mozilla.in
@@ -0,0 +1,34 @@
+--- mail/app/mozilla.in.orig Thu Nov 11 23:14:17 2004
++++ mail/app/mozilla.in Thu Nov 11 23:15:43 2004
+@@ -218,12 +218,31 @@
+ script_args="$script_args -d $2"
+ shift 2
+ ;;
++ -UILocale)
++ moreargs="$moreargs -UILocale $2"
++ _done_locale="YES"
++ shift 2
++ ;;
++ -UIRegion)
++ if [ -n "${_done_locale}" ]; then
++ moreargs="$moreargs -UIRegion $2"
++ fi
++ shift 2
++ ;;
+ *)
+ moreargs="$moreargs \"$1\""
+ shift 1
+ ;;
+ esac
+ done
++
++if [ ! -n "${_done_locale}" -a -n "${MOZILLA_UILOCALE}" ]; then
++ moreargs="$moreargs -UILocale ${MOZILLA_UILOCALE}"
++ if [ -n "${MOZILLA_UIREGION}" ]; then
++ moreargs="$moreargs -UIRegion ${MOZILLA_UIREGION}"
++ fi
++fi
++unset _done_locale
+
+ export MRE_HOME
+ eval "set -- $moreargs"
diff --git a/mail/thunderbird3/files/patch-security-coreconf-FreeBSD.mk b/mail/thunderbird3/files/patch-security-coreconf-FreeBSD.mk
index 4f6bccff7ce..3e0e14acaaf 100644
--- a/mail/thunderbird3/files/patch-security-coreconf-FreeBSD.mk
+++ b/mail/thunderbird3/files/patch-security-coreconf-FreeBSD.mk
@@ -1,12 +1,28 @@
---- security/coreconf/FreeBSD.mk Thu Oct 16 23:03:47 2003
-+++ security/coreconf/FreeBSD.mk Thu Oct 16 22:53:11 2003
-@@ -44,5 +44,9 @@
+--- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
++++ security/coreconf/FreeBSD.mk Sun Nov 21 22:59:49 2004
+@@ -43,8 +43,12 @@
+ ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
CPU_ARCH = x86
+ endif
+endif
+
+ OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
+
+@@ -71,7 +75,11 @@
+ DLL_SUFFIX = so.1.0
endif
+-MKSHLIB = $(CC) $(DSO_LDOPTS)
++ifneq (,$(filter alpha ia64,$(OS_TEST)))
++MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS) -o $@
++else
++MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
++endif
+ ifdef MAPFILE
+ # Add LD options to restrict exported symbols to those in the map file
+ endif