aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird3
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-10-31 12:33:21 +0800
committermezz <mezz@FreeBSD.org>2007-10-31 12:33:21 +0800
commit4cb169c73250a80fc8eb586bdd7dbb50a6a025ca (patch)
tree86d619024ce7aa9f084cdc6da504c66d5d90a543 /mail/thunderbird3
parentad723cf428bc963d059ed1c8a674900144cd6297 (diff)
downloadfreebsd-ports-graphics-4cb169c73250a80fc8eb586bdd7dbb50a6a025ca.tar.gz
freebsd-ports-graphics-4cb169c73250a80fc8eb586bdd7dbb50a6a025ca.tar.zst
freebsd-ports-graphics-4cb169c73250a80fc8eb586bdd7dbb50a6a025ca.zip
Fix the crash with GTK+ 2.12.x, depend on what theme user is using. Bump the
PORTREVISION. Reported by: several in freebsd-gnome@ Tested by: kan Obtained from: https://bugzilla.mozilla.org/show_bug.cgi?id=389801 Approved by: portmgr (marcus)
Diffstat (limited to 'mail/thunderbird3')
-rw-r--r--mail/thunderbird3/Makefile1
-rw-r--r--mail/thunderbird3/files/patch-gfx_src_gtk_gtk2drawing.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 2b0d361cd7e..9e145f8a3e7 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= thunderbird
DISTVERSION= 2.0.0.6
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird3/files/patch-gfx_src_gtk_gtk2drawing.c b/mail/thunderbird3/files/patch-gfx_src_gtk_gtk2drawing.c
new file mode 100644
index 00000000000..8af8a079e89
--- /dev/null
+++ b/mail/thunderbird3/files/patch-gfx_src_gtk_gtk2drawing.c
@@ -0,0 +1,13 @@
+--- gfx/src/gtk/gtk2drawing.c.fixgtk212 2005-09-13 05:30:53.000000000 +0200
++++ gfx/src/gtk/gtk2drawing.c 2007-09-06 09:42:34.000000000 +0200
+@@ -551,8 +551,8 @@ moz_gtk_option_menu_get_metrics(gboolean
+ else
+ *indicator_spacing = default_indicator_spacing;
+
+- g_free(tmp_indicator_size);
+- g_free(tmp_indicator_spacing);
++ gtk_requisition_free(tmp_indicator_size);
++ gtk_border_free(tmp_indicator_spacing);
+
+ return MOZ_GTK_SUCCESS;
+ }