aboutsummaryrefslogtreecommitdiffstats
path: root/mail/vpopmail-devel/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-07-04 23:34:50 +0800
committerroam <roam@FreeBSD.org>2001-07-04 23:34:50 +0800
commit01d456802b2cbff0deb171ef07d9ac5c2050088f (patch)
tree402093a77f74b03c9afec0ce1f816ae28d536b9e /mail/vpopmail-devel/Makefile
parentf1c9ffb281d5f3c39aaaff805c04b1772fce4a74 (diff)
downloadfreebsd-ports-graphics-01d456802b2cbff0deb171ef07d9ac5c2050088f.tar.gz
freebsd-ports-graphics-01d456802b2cbff0deb171ef07d9ac5c2050088f.tar.zst
freebsd-ports-graphics-01d456802b2cbff0deb171ef07d9ac5c2050088f.zip
Rip out the configure script parts that try to modify the destination dir.
Let the user override the MySQL username, password and db at build time. Let the user override the vchkpw gid and the vpopmail uid. Bump PORTREVISION. Approved by: nbm (maintainer)
Diffstat (limited to 'mail/vpopmail-devel/Makefile')
-rw-r--r--mail/vpopmail-devel/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index b73c64f273b..09f3db073de 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpopmail
PORTVERSION= 4.9.10
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.inter7.com/vpopmail/
@@ -45,6 +45,11 @@ CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
# APOPFILE - location of apop secrets file
# QMAIL_DIR - location of qmail directory
# PREFIX - installation area for vpopmail (see comment below)
+# WITH_MYSQL_USER - the username for connecting to the MySQL server (root)
+# WITH_MYSQL_PASSWD - the password for connecting to the MySQL server (gipgap)
+# WITH_MYSQL_DB - the name of the MySQL database to use (vpopmail)
+# VCHKPW_GID - the group ID of the new vchkpw group (89)
+# VPOPMAIL_UID - the user ID of the new vpopmail user (89)
#
HARDQUOTA?= 10000000
@@ -112,5 +117,16 @@ CONFIGURE_ARGS+= --enable-default-domain=${DEFAULT_DOMAIN}
pre-configure:
@PKG_PREFIX=${PREFIX}/vpopmail ${PERL5} ${PKGINSTALL}
+.if defined(WITH_MYSQL)
+.if defined(WITH_MYSQL_USER)
+ ${PERL} -pi -e "s/(#define MYSQL_USER.*)root(.*)/\$$1${WITH_MYSQL_USER}\$$2/" ${WRKSRC}/vmysql.h
+.endif
+.if defined(WITH_MYSQL_PASSWD)
+ ${PERL} -pi -e "s/(#define MYSQL_PASSWD.*)gipgap(.*)/\$$1${WITH_MYSQL_PASSWD}\$$2/" ${WRKSRC}/vmysql.h
+.endif
+.if defined(WITH_MYSQL_DB)
+ ${PERL} -pi -e "s/(#define MYSQL_DATABASE.*)vpopmail(.*)/\$$1${WITH_MYSQL_DB}\$$2/" ${WRKSRC}/vmysql.h
+.endif
+.endif
.include <bsd.port.mk>