aboutsummaryrefslogtreecommitdiffstats
path: root/mail/vpopmail-devel/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2002-09-21 03:55:07 +0800
committerroam <roam@FreeBSD.org>2002-09-21 03:55:07 +0800
commit6bdfade32fc2faa8145f4d4d74bef59ecda90c27 (patch)
tree3e3f6e02ddbb83abe937a2b1b55acaf3e6d344a7 /mail/vpopmail-devel/Makefile
parent1e5e027c2d04552e517b6e939fe83db813fc5c8a (diff)
downloadfreebsd-ports-graphics-6bdfade32fc2faa8145f4d4d74bef59ecda90c27.tar.gz
freebsd-ports-graphics-6bdfade32fc2faa8145f4d4d74bef59ecda90c27.tar.zst
freebsd-ports-graphics-6bdfade32fc2faa8145f4d4d74bef59ecda90c27.zip
Apply a blessed +3 magic wand of autotools protection; a rogue run of
autoconf or automake over our local patches can ruin your whole day. This rarely, if ever, affected the vpopmail ports, causing mysterious failures at install time, but inevitably killed the stunnel build if automake-1.5 happened to be installed. Reported by: Dan Langille <dan@langille.org> for stunnel, Sitchin Zech <mailsagan@yahoo.com> for vpopmail
Diffstat (limited to 'mail/vpopmail-devel/Makefile')
-rw-r--r--mail/vpopmail-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index 0d96bead0cf..b12f8363161 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
GNU_CONFIGURE= YES
USE_GMAKE= YES
+USE_REINPLACE= YES
VCFGDIR?= ${WRKDIR}/vcfg
VCFGFILES?= inc_deps lib_deps tcp.smtp
@@ -238,6 +239,11 @@ CONFIGURE_ARGS+= --enable-users-big-dir=n
CONFIGURE_ARGS+= --enable-make-seekable=n
.endif
+# autoconf and automake can remove our patches to the configure scripts.
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it