aboutsummaryrefslogtreecommitdiffstats
path: root/mail/vpopmail-devel/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-11-04 20:05:05 +0800
committerroam <roam@FreeBSD.org>2001-11-04 20:05:05 +0800
commitfa626ba55dbd2588398dc554bb02f33aa8110391 (patch)
tree616a9a5b2f057351218be2388a52379758d92dba /mail/vpopmail-devel/Makefile
parent65c91b6ad15ce67cd72223bd06829317530a1f2a (diff)
downloadfreebsd-ports-graphics-fa626ba55dbd2588398dc554bb02f33aa8110391.tar.gz
freebsd-ports-graphics-fa626ba55dbd2588398dc554bb02f33aa8110391.tar.zst
freebsd-ports-graphics-fa626ba55dbd2588398dc554bb02f33aa8110391.zip
Fix the build of several dependent ports by actually installing
the inc_deps and lib_deps files. This should fix qmailadmin, courier-imap and possibly others, after I broke them by my configure changes to not create and populate ${PREFIX}/vpopmail/etc/ at configure time. Add a couple of configuration knobs. Bump PORTREVISION for the inc_deps/lib_deps fix. Reported by: a multitude of innocents :( Pointy hat: roam (myself)
Diffstat (limited to 'mail/vpopmail-devel/Makefile')
-rw-r--r--mail/vpopmail-devel/Makefile30
1 files changed, 29 insertions, 1 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index 8c572c8d145..18b2e4a76ea 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpopmail
PORTVERSION= 4.9.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://www.inter7.com/vpopmail/
@@ -21,6 +21,10 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
GNU_CONFIGURE= YES
USE_GMAKE= YES
+VCFGDIR?= ${WRKDIR}/vcfg
+VCFGFILES?= inc_deps lib_deps tcp.smtp
+
+CONFIGURE_ENV+= VCFGDIR="${VCFGDIR}"
CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
--enable-tcprules-bin=${LOCALBASE}/bin/tcprules \
--enable-tcpserver-file=${PREFIX}/vpopmail/etc/tcp.smtp
@@ -32,8 +36,11 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
#
# WITH_PASSWD - allow authentication off /etc/passwd
# WITH_MYSQL - allow authentitation via mysql
+# WITH_MYSQL_LARGE_SITE - enables large site layout
# WITH_APOP - allow apop authentication
# WITHOUT_ROAMING - disallow roaming users
+# WITH_IP_ALIAS - enables IP aliasing
+# WITH_DELIVER_FILTER - enables the experimental vdelivermail filter
#
# Set these to the values you'd prefer
#
@@ -103,12 +110,23 @@ LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+= --enable-mysql=y \
--enable-sqlincdir=${LOCALBASE}/include/mysql \
--enable-sqllibdir=${LOCALBASE}/lib/mysql
+.if defined(WITH_MYSQL_LARGE_SITE)
+CONFIGURE_ARGS+= --enable-large-site=y
+.endif
.endif
.if defined(DEFAULT_DOMAIN)
CONFIGURE_ARGS+= --enable-default-domain=${DEFAULT_DOMAIN}
.endif
+.if defined(WITH_IP_ALIAS)
+CONFIGURE_ARGS+= --enable-ip-alias-domains=y
+.endif
+
+.if defined(WITH_DELIVER_FILTER)
+CONFIGURE_ARGS+= --enable-deliver-filter=y
+.endif
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it
@@ -128,8 +146,18 @@ pre-configure:
${PERL} -pi -e "s/(#define MYSQL_DATABASE.*)vpopmail(.*)/\$$1${WITH_MYSQL_DB}\$$2/" ${WRKSRC}/vmysql.h
.endif
.endif
+ ${MKDIR} ${VCFGDIR}
post-install:
${CHMOD} o-rwx ${PREFIX}/vpopmail/bin ${PREFIX}/vpopmail/lib
+ ${MKDIR} ${PREFIX}/vpopmail/etc
+ if [ ! -f "${PREFIX}/vpopmail/etc/tcp.smtp" ]; then \
+ if [ -f "${VCFGDIR}/tcp.smtp" ]; then \
+ ${INSTALL_DATA} ${VCFGDIR}/tcp.smtp ${PREFIX}/vpopmail/etc/; \
+ else \
+ ${TOUCH} ${PREFIX}/vpopmail/etc/tcp.smtp; \
+ fi; \
+ fi
+ ${INSTALL_DATA} ${VCFGDIR}/inc_deps ${VCFGDIR}/lib_deps ${PREFIX}/vpopmail/etc/
.include <bsd.port.mk>