aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-04-08 23:57:15 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-04-08 23:57:15 +0800
commit003d69c403f8b0e90fed9b19c3d956d0b1c4afa6 (patch)
treeb9834ca0f0b110aed7ae01c9d8ebd5ecd9437b2c /mail
parent44abb7731a20b402e61fa7c244c1ee610443b993 (diff)
downloadfreebsd-ports-graphics-003d69c403f8b0e90fed9b19c3d956d0b1c4afa6.tar.gz
freebsd-ports-graphics-003d69c403f8b0e90fed9b19c3d956d0b1c4afa6.tar.zst
freebsd-ports-graphics-003d69c403f8b0e90fed9b19c3d956d0b1c4afa6.zip
- Support staging
- Update to 2.01 [1] - Pass maintainership to submitter (previous maintainer has timed out since 2009) - Convert to new LIB_DEPENDS format - Use OPTIONS_SUB - Remove use of bsd.port.pre.mk PR: ports/185973 [1] Submitted by: Uffe Jakobsen <uffe@uffe.org> [1]
Diffstat (limited to 'mail')
-rw-r--r--mail/mailfront/Makefile26
-rw-r--r--mail/mailfront/distinfo4
-rw-r--r--mail/mailfront/pkg-plist4
3 files changed, 18 insertions, 16 deletions
diff --git a/mail/mailfront/Makefile b/mail/mailfront/Makefile
index b3519a44328..1657c732996 100644
--- a/mail/mailfront/Makefile
+++ b/mail/mailfront/Makefile
@@ -2,19 +2,20 @@
# $FreeBSD$
PORTNAME= mailfront
-PORTVERSION= 1.21
+PORTVERSION= 2.01
CATEGORIES= mail
MASTER_SITES= http://untroubled.org/${PORTNAME}/ \
http://untroubled.org/${PORTNAME}/archive/
-MAINTAINER= tarkhil@over.ru
+MAINTAINER= uffe@uffe.org
COMMENT= Mail server network protocol front-ends
-LIB_DEPENDS= cvm-v2client:${PORTSDIR}/security/cvm
+LIB_DEPENDS= libcvm-v2client.so:${PORTSDIR}/security/cvm
OPTIONS_DEFINE= LUA
-OPTIONS_DEFAULT= LUA
+OPTIONS_DEFAULT=LUA
+OPTIONS_SUB= yes
USES= qmail:vars
@@ -27,12 +28,12 @@ CVM_INC= ${LOCALBASE}/include
CVM_LIB= ${LOCALBASE}/lib
MODULES_DIR= ${PREFIX}/libexec/${PORTNAME}
-DOCS= NEWS README TODO *.html
+ALL_TARGET= all
+LATE_INSTALL_ARGS= install_prefix=${STAGEDIR}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+DOCS= NEWS README TODO *.html
-ALL_TARGET= all
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLUA}
ALL_TARGET+= lua
@@ -40,9 +41,6 @@ USE_LUA= yes
CFLAGS+= -I${LUA_INCDIR}
CFLAGS_SO+= -L${LUA_LIBDIR}
LDFLAGS+= -L${LUA_LIBDIR}
-PLIST_SUB+= LUA=""
-.else
-PLIST_SUB+= LUA="@comment "
.endif
LDFLAGS+= -rdynamic
@@ -60,8 +58,8 @@ do-configure:
.if ${PORT_OPTIONS:MDOCS}
post-install:
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/mailfront/distinfo b/mail/mailfront/distinfo
index 5ef5b0b3ae0..5cab462cd79 100644
--- a/mail/mailfront/distinfo
+++ b/mail/mailfront/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mailfront-1.21.tar.gz) = 219dcefafc1a458407ac0605168499f2e3e585cd14b89659809e5bcda2c82825
-SIZE (mailfront-1.21.tar.gz) = 113966
+SHA256 (mailfront-2.01.tar.gz) = 1fb069ef7c36dc8487e1ba102ac5548f35f7bdfdbfb583662387e9044bc72b63
+SIZE (mailfront-2.01.tar.gz) = 119144
diff --git a/mail/mailfront/pkg-plist b/mail/mailfront/pkg-plist
index 3028272a838..03dfd19ff1d 100644
--- a/mail/mailfront/pkg-plist
+++ b/mail/mailfront/pkg-plist
@@ -17,12 +17,14 @@ libexec/mailfront/plugin-add-received.so
libexec/mailfront/plugin-check-fqdn.so
libexec/mailfront/plugin-clamav.so
libexec/mailfront/plugin-counters.so
+libexec/mailfront/plugin-cvm-authenticate.so
libexec/mailfront/plugin-cvm-validate.so
%%LUA%%libexec/mailfront/plugin-lua.so
libexec/mailfront/plugin-mailrules.so
libexec/mailfront/plugin-patterns.so
libexec/mailfront/plugin-qmail-validate.so
libexec/mailfront/plugin-spamassassin.so
+libexec/mailfront/plugin-starttls-ucspi.so
libexec/mailfront/protocol-qmqp.so
libexec/mailfront/protocol-qmtp.so
libexec/mailfront/protocol-smtp.so
@@ -44,6 +46,7 @@ libexec/mailfront/protocol-smtp.so
%%PORTDOCS%%%%DOCSDIR%%/plugin-check-fqdn.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-clamav.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-counters.html
+%%PORTDOCS%%%%DOCSDIR%%/plugin-cvm-authenticate.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-cvm-validate.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-force-file.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-lua.html
@@ -54,6 +57,7 @@ libexec/mailfront/protocol-smtp.so
%%PORTDOCS%%%%DOCSDIR%%/plugin-relayclient.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-require-auth.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-spamassassin.html
+%%PORTDOCS%%%%DOCSDIR%%/plugin-starttls-ucspi.html
%%PORTDOCS%%%%DOCSDIR%%/plugin-template.html
%%PORTDOCS%%%%DOCSDIR%%/pop3front.html
%%PORTDOCS%%%%DOCSDIR%%/protocol-qmqp.html