aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-04-05 01:39:14 +0800
committergabor <gabor@FreeBSD.org>2007-04-05 01:39:14 +0800
commit04b03743c77497b454e1974936eb17e1065f6550 (patch)
tree2212285e76f65b9b53cdcf0f33e9ed09af0b102f /mail
parent59e617d81b84d0d55d93d904c629d12c369c6e25 (diff)
downloadfreebsd-ports-graphics-04b03743c77497b454e1974936eb17e1065f6550.tar.gz
freebsd-ports-graphics-04b03743c77497b454e1974936eb17e1065f6550.tar.zst
freebsd-ports-graphics-04b03743c77497b454e1974936eb17e1065f6550.zip
- Remove old Perl support from unmaintained ports in categories starting
with letter k-n
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-Alias/Makefile10
-rw-r--r--mail/p5-Mail-SRS/Makefile8
-rw-r--r--mail/sqlgrey/Makefile8
-rw-r--r--mail/sympa/Makefile15
-rw-r--r--mail/zmailer/Makefile4
5 files changed, 6 insertions, 39 deletions
diff --git a/mail/p5-Mail-Alias/Makefile b/mail/p5-Mail-Alias/Makefile
index fde4b78495a..9594e5e3be0 100644
--- a/mail/p5-Mail-Alias/Makefile
+++ b/mail/p5-Mail-Alias/Makefile
@@ -17,12 +17,6 @@ COMMENT= Mail::Alias
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+MAN3= Mail::Alias.3
-.if ${PERL_LEVEL} < 500100
-IGNORE= "This port requires perl 5.1 or newer. Install lang/perl5 or lang/perl5.8 and try again."
-.endif
-
-MAN3= Mail::Alias.3
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-SRS/Makefile b/mail/p5-Mail-SRS/Makefile
index 646cfedd898..af83d5cd84f 100644
--- a/mail/p5-Mail-SRS/Makefile
+++ b/mail/p5-Mail-SRS/Makefile
@@ -32,10 +32,4 @@ MAN1= srs.1 \
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600 #depends on DB_File >= 1.806
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index fbed1f82525..19dcd154211 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -77,10 +77,4 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-RUN_DEPENDS+= ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 62f5d3eb398..8d38c3999ce 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -26,7 +26,8 @@ BUILD_DEPENDS+= ${SITE_PERL}/Mail/Mailer.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${SITE_PERL}/${PERL_ARCH}/Locale/Msgcat.pm:${PORTSDIR}/misc/p5-Locale-Msgcat \
- ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
+ ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
CONFLICTS= sympa-5*
@@ -48,11 +49,7 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Oracle.pm:${PORTSDIR}/databases/p5-DBD-Oracle
.else
.if ${DB_TYPE} == "Pg"
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg-13
-.else
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
-.endif
.else
.if ${DB_TYPE} == "Sybase"
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Sybase.pm:${PORTSDIR}/databases/p5-DBD-Sybase
@@ -99,12 +96,4 @@ post-install:
post-deinstall:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} POST-DEINSTALL
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
.include <bsd.port.post.mk>
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index b2cc15c39e7..3cec7155474 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -26,10 +26,6 @@ CONFIGURE_ARGS= --without-openssl
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.006 or better
-.endif
-
.if ${OSVERSION} >= 500000
EXTRA_PATCHES= ${FILESDIR}/extra-patch-EAI_NODATA
.endif