aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-06 04:26:35 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-06 04:26:35 +0800
commit10b9c6f1cb8be053c964753d1634b1fd2d37e63e (patch)
treea529831c990911e3597403fbb49a60f2bd456b12 /mail
parent13dd35439c2e63db3c1a54cdfb7128e9cbb108ec (diff)
downloadfreebsd-ports-graphics-10b9c6f1cb8be053c964753d1634b1fd2d37e63e.tar.gz
freebsd-ports-graphics-10b9c6f1cb8be053c964753d1634b1fd2d37e63e.tar.zst
freebsd-ports-graphics-10b9c6f1cb8be053c964753d1634b1fd2d37e63e.zip
- Add LICENSE
- Remove unnecessary SHEBANG_LANG - Support STAGEDIR - Reformat pkg-descr
Diffstat (limited to 'mail')
-rw-r--r--mail/tumgreyspf/Makefile33
-rw-r--r--mail/tumgreyspf/pkg-descr20
2 files changed, 24 insertions, 29 deletions
diff --git a/mail/tumgreyspf/Makefile b/mail/tumgreyspf/Makefile
index 4c4f5110597..ca046bfca31 100644
--- a/mail/tumgreyspf/Makefile
+++ b/mail/tumgreyspf/Makefile
@@ -11,17 +11,15 @@ MASTER_SITES= ftp://ftp.tummy.com/pub/tummy/tumgreyspf/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= External policy checker for the postfix mail server
+LICENSE= GPLv2
+
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/spf.py:${PORTSDIR}/mail/py-spf
OPTIONS_DEFINE= DOCS
NO_BUILD= yes
-SHEBANG_LANG= perl python
-SHEBANG_FILES= *
USE_PYTHON= -2.7
USES= shebangfix
-python_OLD_CMD= ${SETENV} python
-python_CMD= ${PYTHON_CMD}
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
PKGINSTALL= ${WRKDIR}/pkg-install
@@ -33,11 +31,14 @@ SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
TUMGREYSPF_USER=${TUMGREYSPF_USER} \
TUMGREYSPF_GROUP=${TUMGREYSPF_GROUP}
+SHEBANG_FILES= *
+python_OLD_CMD= ${SETENV} python
+python_CMD= ${PYTHON_CMD}
+
TUMGREYSPF_DIR?= /var/db/${PORTNAME}
TUMGREYSPF_USER?= nobody
TUMGREYSPF_GROUP?= nobody
-NO_STAGE= yes
.include <bsd.port.options.mk>
pre-everything::
@@ -61,23 +62,21 @@ post-patch:
${WRKSRC}/tumgreyspf.conf ${WRKSRC}/tumgreyspfsupp.py
do-install:
+ ${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/
cd ${WRKSRC}/ && \
- ${INSTALL_SCRIPT} tumgreyspf tumgreyspf-clean tumgreyspf-configtest tumgreyspf-stat ${PREFIX}/bin/ && \
- ${INSTALL_SCRIPT} gentest ${PREFIX}/bin/tumgreyspf-gentest && \
- ${INSTALL_SCRIPT} tumgreyspfsupp.py ${PYTHONPREFIX_SITELIBDIR}/ && \
- ${INSTALL_DATA} tumgreyspf.conf ${PREFIX}/etc/tumgreyspf.conf.default
+ ${INSTALL_SCRIPT} tumgreyspf tumgreyspf-clean tumgreyspf-configtest tumgreyspf-stat ${STAGEDIR}${PREFIX}/bin/ && \
+ ${INSTALL_SCRIPT} gentest ${STAGEDIR}${PREFIX}/bin/tumgreyspf-gentest && \
+ ${INSTALL_SCRIPT} tumgreyspfsupp.py ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ && \
+ ${INSTALL_DATA} tumgreyspf.conf ${STAGEDIR}${PREFIX}/etc/tumgreyspf.conf.default
.if !exists(${PREFIX}/etc/tumgreyspf.conf)
- ${INSTALL_DATA} ${WRKSRC}/tumgreyspf.conf ${PREFIX}/etc/
+ ${INSTALL_DATA} ${WRKSRC}/tumgreyspf.conf ${STAGEDIR}${PREFIX}/etc/
.endif
post-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/__default__.dist ${DATADIR}/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README* ${DOCSDIR}/
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/__default__.dist ${STAGEDIR}${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README* ${STAGEDIR}${DOCSDIR}/
.if !defined(PACKAGE_BUILDING)
@${SETENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
diff --git a/mail/tumgreyspf/pkg-descr b/mail/tumgreyspf/pkg-descr
index 92e1407384c..b28db555868 100644
--- a/mail/tumgreyspf/pkg-descr
+++ b/mail/tumgreyspf/pkg-descr
@@ -1,17 +1,13 @@
-Tumgreyspf, an external policy checker for the postfix mail
-server. It can optionally greylist and/or use spfquery to
-check SPF records to determine if email should be accepted
-by your server.
+Tumgreyspf, an external policy checker for the postfix mail server. It can
+optionally greylist and/or use spfquery to check SPF records to determine if
+email should be accepted by your server.
-Because of it's design, legitimate e-mail is never trapped
-or rejected. Only spam and viruses are caught. Since adding
-it to our mail server (which also uses Spam Assassin, ClamAV,
-and an outsourced anti-spam system), our spam level has
+Because of it's design, legitimate e-mail is never trapped or rejected. Only
+spam and viruses are caught. Since adding it to our mail server (which also uses
+Spam Assassin, ClamAV, and an outsourced anti-spam system), our spam level has
dropped by an order of magnitude.
-It uses the file-system as it's database, no additional
-database is required to use it.
+It uses the file-system as it's database, no additional database is required to
+use it.
WWW: http://www.tummy.com/Community/software/tumgreyspf/
-
-Marcus Alves Grando <mnag@FreeBSD.org>