aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2003-08-05 19:58:12 +0800
committertobez <tobez@FreeBSD.org>2003-08-05 19:58:12 +0800
commit1379cc11eb603b0dca040bf8977a64baafb27584 (patch)
tree59075dd762cecbd11b661134a543fe7aa9256710 /mail
parentbf39c7ecfb4b67135befed9ecbfcbe2434c6a7d4 (diff)
downloadfreebsd-ports-graphics-1379cc11eb603b0dca040bf8977a64baafb27584.tar.gz
freebsd-ports-graphics-1379cc11eb603b0dca040bf8977a64baafb27584.tar.zst
freebsd-ports-graphics-1379cc11eb603b0dca040bf8977a64baafb27584.zip
Make it work with perls >= 5.6.
Submitted by: droso
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-Box1/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/mail/p5-Mail-Box1/Makefile b/mail/p5-Mail-Box1/Makefile
index f9d0626d7f3..89b1a5ca620 100644
--- a/mail/p5-Mail-Box1/Makefile
+++ b/mail/p5-Mail-Box1/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module implementing a modern mail-folder managerat
-BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
- ${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+BUILD_DEPENDS= ${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -44,4 +43,11 @@ post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@]\w+)/use vars qw($$1);$$1/' \
${WRKSRC}/Message.pm
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.include <bsd.port.post.mk>