aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2004-01-22 20:18:43 +0800
committertrevor <trevor@FreeBSD.org>2004-01-22 20:18:43 +0800
commit1a4fe1abef078142c88fe743751cab946f0e6d1a (patch)
treeb3f0484b3d24d10d7a0453f904fc5634ac0fd064 /mail
parentb986261853674afc9ed239fc66c9bd33bb7acb46 (diff)
downloadfreebsd-ports-graphics-1a4fe1abef078142c88fe743751cab946f0e6d1a.tar.gz
freebsd-ports-graphics-1a4fe1abef078142c88fe743751cab946f0e6d1a.tar.zst
freebsd-ports-graphics-1a4fe1abef078142c88fe743751cab946f0e6d1a.zip
Use the CPIO macro defined in bsd.port.mk.
Diffstat (limited to 'mail')
-rw-r--r--mail/claws-mail/Makefile2
-rw-r--r--mail/openwebmail/Makefile6
-rw-r--r--mail/sylpheed-claws/Makefile2
3 files changed, 4 insertions, 6 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index cfc3f93e862..857319c7feb 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -39,8 +39,6 @@ CONFIGURE_ARGS= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
--with-openssl-libs=${OPENSSLLIB}
.endif
-CPIO?= /usr/bin/cpio
-
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --program-suffix="-claws" --enable-ipv6
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index 8f5e6ae6a66..a91b825d808 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -143,8 +143,10 @@ pre-install:
do-install:
@${MKDIR} ${OWCGIDIR} ${OWDATADIR}
- @cd ${WRKSRC}/cgi-bin/openwebmail && ${FIND} . | cpio -dpum -R ${BINOWN}:mail ${OWCGIDIR}
- @cd ${WRKSRC}/data/openwebmail && ${FIND} . | cpio -dpum -R ${SHAREOWN}:${SHAREGRP} ${OWDATADIR}
+ @cd ${WRKSRC}/cgi-bin/openwebmail && ${FIND} . \
+ | ${CPIO} -dpum -R ${BINOWN}:mail ${OWCGIDIR}
+ @cd ${WRKSRC}/data/openwebmail && ${FIND} . \
+ | ${CPIO} -dpum -R ${SHAREOWN}:${SHAREGRP} ${OWDATADIR}
.if !exists(${OWCGIDIR}/etc/openwebmail.conf)
@${CP} ${OWCGIDIR}/etc/openwebmail.conf-dist ${OWCGIDIR}/etc/openwebmail.conf
.endif
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index cfc3f93e862..857319c7feb 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -39,8 +39,6 @@ CONFIGURE_ARGS= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
--with-openssl-libs=${OPENSSLLIB}
.endif
-CPIO?= /usr/bin/cpio
-
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --program-suffix="-claws" --enable-ipv6