aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-26 00:13:38 +0800
committermat <mat@FreeBSD.org>2016-04-26 00:13:38 +0800
commit249200c5ac5a6482e3f464dcbabf7f4879065734 (patch)
tree2cf1a158cf8540bcd6bed759d4e35240e31330bb /mail
parent4a29dd7050d143c963a767fa8b7671e3a0ddc09d (diff)
downloadfreebsd-ports-graphics-249200c5ac5a6482e3f464dcbabf7f4879065734.tar.gz
freebsd-ports-graphics-249200c5ac5a6482e3f464dcbabf7f4879065734.tar.zst
freebsd-ports-graphics-249200c5ac5a6482e3f464dcbabf7f4879065734.zip
Remove USE_SQLITE from bsd.databases.mk, replaced by USES=sqlite.
While there replace USE_SQLITE=x by USES=sqlite:x. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Diffstat (limited to 'mail')
-rw-r--r--mail/cyrus-imapd23/Makefile2
-rw-r--r--mail/cyrus-imapd24/Makefile2
-rw-r--r--mail/dbmail22/Makefile2
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot2/Makefile2
-rw-r--r--mail/dspam/Makefile10
-rw-r--r--mail/exim/Makefile3
7 files changed, 11 insertions, 12 deletions
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index 9307c0b1e73..b9043fd1a61 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -82,7 +82,7 @@ SNMP_5_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
SNMP_5_CONFIGURE_ON= --with-snmp=${LOCALBASE}
SNMP_5_CONFIGURE_OFF= --with-snmp=no
SQLITE_DESC= Enable SQLite backend (experimental)
-SQLITE_USE= SQLITE=yes
+SQLITE_USES= sqlite
SQLITE_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
# Autocreate Inbox and Autosieve patches from UoA
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 3d72a07a75b..9c311075d8f 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -77,7 +77,7 @@ REPLICATION_CONFIGURE_ENABLE=replication
SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
SNMP_CONFIGURE_ON= --with-snmp=${LOCALBASE}
SNMP_CONFIGURE_OFF= --with-snmp=no
-SQLITE_USE= SQLITE=yes
+SQLITE_USES= sqlite
SQLITE_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
OPTIONS_RADIO= GSSAPI
diff --git a/mail/dbmail22/Makefile b/mail/dbmail22/Makefile
index 2d35783c539..e214b0e012b 100644
--- a/mail/dbmail22/Makefile
+++ b/mail/dbmail22/Makefile
@@ -27,7 +27,7 @@ OPTIONS_SUB= yes
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
-SQLITE_USE= SQLITE=3
+SQLITE_USES= sqlite:3
SQLITE_CONFIGURE_WITH= sqlite
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index dc349fd9e49..9853e1fb65b 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -77,7 +77,7 @@ MYSQL_USE= MYSQL=yes
PGSQL_CONFIGURE_WITH= pgsql
PGSQL_USES= pgsql
SQLITE_CONFIGURE_WITH= sqlite
-SQLITE_USE= SQLITE=3
+SQLITE_USES= sqlite:3
SSL_CONFIGURE_OFF= --without-ssl
SSL_CONFIGURE_ON= --with-ssl=openssl
VPOPMAIL_BUILD_DEPENDS= ${LOCALBASE}/vpopmail/bin/vchkpw:mail/vpopmail
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 2072761df4a..f8856920bf4 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -109,7 +109,7 @@ SOLR_CONFIGURE_WITH= solr
SOLR_BUILD_DEPENDS= curl:ftp/curl
SOLR_LIB_DEPENDS= libexpat.so:textproc/expat2
-SQLITE_USE= SQLITE=3
+SQLITE_USES= sqlite:3
SQLITE_CONFIGURE_WITH= sqlite
SSL_CONFIGURE_WITH= ssl=openssl
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index e4c3801f15c..da98675d186 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -215,20 +215,20 @@ _DBDRV:= ${_DBDRV:S/pgsql_drv,//}
.endif
.if ${PORT_OPTIONS:MSQLITE3}
-USE_SQLITE= 3
+USES+= sqlite:3
_DBDRV_COUNT:= ${_DBDRV_COUNT}o
.else
_DBDRV:= ${_DBDRV:S/sqlite3_drv,//}
.endif
.if ${PORT_OPTIONS:MSQLITE2}
-USE_SQLITE= 2
+USES+= sqlite:2
_DBDRV_COUNT:= ${_DBDRV_COUNT}o
.else
_DBDRV:= ${_DBDRV:S/sqlite_drv,//}
.endif
-.if defined(USE_SQLITE)
+.if ${USES:Msqlite*}
CONFIGURE_ARGS+= --with-sqlite-includes=${LOCALBASE}/include \
--with-sqlite-libraries=${LOCALBASE}/lib
PLIST_SUB+= SQLITE=""
@@ -464,7 +464,7 @@ pre-configure:
@${FALSE}
.endif
.if ${PORT_OPTIONS:MEXTERNAL_LOOKUP} && !( defined(USE_MYSQL) || \
- ${PORT_OPTIONS:MPGSQL} || defined(USE_SQLITE) )
+ ${PORT_OPTIONS:MPGSQL} || ${PORT_OPTIONS:MSQLITE*} )
@${ECHO_CMD} "You need MySQL, Postgres or SQLITE for EXTERNAL_LOOKUP."
@${FALSE}
.endif
@@ -505,7 +505,7 @@ post-install:
@cd ${WRKSRC}/src/tools.pgsql_drv && \
${INSTALL_DATA} *.sql ${STAGEDIR}${EXAMPLESDIR}/pgsql
.endif
-.ifdef(USE_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE*}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sqlite
cd ${WRKSRC}/src/tools.sqlite_drv && \
${INSTALL_DATA} *.sql ${STAGEDIR}${EXAMPLESDIR}/sqlite
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index eae67e3a7d7..791f04a5b3b 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -55,8 +55,7 @@ REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
SASLAUTHD_RUN_DEPENDS= ${LOCALBASE}/sbin/saslauthd:security/cyrus-sasl2-saslauthd
SA_EXIM_RUN_DEPENDS= ${LOCALBASE}/bin/spamc:mail/spamassassin
SPF_LIB_DEPENDS= libspf2.so:mail/libspf2
-SQLITE_USE= sqlite=yes
-SQLITE_USES= pkgconfig
+SQLITE_USES= pkgconfig sqlite
.include <bsd.port.options.mk>