aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-12-25 21:38:41 +0800
committererwin <erwin@FreeBSD.org>2006-12-25 21:38:41 +0800
commit27382e21600682c6d01b844ff214dbbd79dab6df (patch)
treee7fedae2d7774a344f109a37a78f1525922de09d /mail
parent2867a42c5fd07dcc6ba335ad522a7c127004c991 (diff)
downloadfreebsd-ports-graphics-27382e21600682c6d01b844ff214dbbd79dab6df.tar.gz
freebsd-ports-graphics-27382e21600682c6d01b844ff214dbbd79dab6df.tar.zst
freebsd-ports-graphics-27382e21600682c6d01b844ff214dbbd79dab6df.zip
Make GnuPG support for sa-update optional.
PR: 105692 Submitted by: shaun
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index c54c46abb7b..f6aadc35370 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -22,8 +22,7 @@ BUILD_DEPENDS= p5-Net-DNS>=0.53:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
RUN_DEPENDS= ${BUILD_DEPENDS} \
${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
- gpgv:${PORTSDIR}/security/gnupg1
+ ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
PERL_CONFIGURE= yes
CONFIGURE_ARGS= SYSCONFDIR="${PREFIX}/etc" \
@@ -36,6 +35,7 @@ CONTACT_ADDRESS?= The administrator of that system
OPTIONS= AS_ROOT "Run spamd as root (recommended)" on \
DOMAINKEYS "DomainKeys support" off \
SSL "Build with SSL support for spamd/spamc" on \
+ GNUPG "Install GnuPG (for sa-update)" on \
MYSQL "Add MySQL support" off \
PGSQL "Add PostreSQL support" off \
RAZOR "Add Vipul's Razor support" on \
@@ -60,6 +60,10 @@ CONFIGURE_ARGS+= ENABLE_SSL=yes
CONFIGURE_ARGS+= ENABLE_SSL=no
.endif
+.if !defined(WITHOUT_GNUPG)
+RUN_DEPENDS+= gpgv:${PORTSDIR}/security/gnupg1
+.endif
+
.if defined(WITH_MYSQL)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.endif