aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>2006-05-08 14:47:04 +0800
committermax <max@FreeBSD.org>2006-05-08 14:47:04 +0800
commit4278c54db78aa12592d567cb78fffb2501fa6499 (patch)
tree2337cff4d2bda5bcfd1a2cb319ed3bd755e8d0f6 /mail
parent4f44842a467d1e8d2205f6d4e596a9a3713ba632 (diff)
downloadfreebsd-ports-graphics-4278c54db78aa12592d567cb78fffb2501fa6499.tar.gz
freebsd-ports-graphics-4278c54db78aa12592d567cb78fffb2501fa6499.tar.zst
freebsd-ports-graphics-4278c54db78aa12592d567cb78fffb2501fa6499.zip
Oops, forgot to add this patch file before committing ports/mail/mailagent/Makefile Rev 1.39.
This patch fixes an infinite loop with the filter on AMD64. Submitted by: Yoshiaki Kasahara <kasahara@nc.kyushu-u.ac.jp> PR: 94585
Diffstat (limited to 'mail')
-rw-r--r--mail/mailagent/files/patch-agent::filter::logfile.c15
1 files changed, 15 insertions, 0 deletions
diff --git a/mail/mailagent/files/patch-agent::filter::logfile.c b/mail/mailagent/files/patch-agent::filter::logfile.c
new file mode 100644
index 00000000000..60a0bcbc130
--- /dev/null
+++ b/mail/mailagent/files/patch-agent::filter::logfile.c
@@ -0,0 +1,15 @@
+--- agent/filter/logfile.c.orig Fri Mar 17 12:59:44 2006
++++ agent/filter/logfile.c Fri Mar 17 13:02:25 2006
+@@ -47,6 +47,12 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+
++#ifdef I_STRING
++#include <string.h>
++#else
++#include <strings.h>
++#endif
++
+ #ifdef I_TIME
+ # include <time.h>
+ #endif