aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-27 17:07:20 +0800
committermiwi <miwi@FreeBSD.org>2014-02-27 17:07:20 +0800
commit4a62bd0a88ed97429f086f7791cfb751195fdfba (patch)
tree8c0c9e9bb32b4eec14e2a1a68fd606bc3dedaad5 /mail
parent882c81c1ffc07d3deec6fbcfa9cc9f4e0224a702 (diff)
downloadfreebsd-ports-graphics-4a62bd0a88ed97429f086f7791cfb751195fdfba.tar.gz
freebsd-ports-graphics-4a62bd0a88ed97429f086f7791cfb751195fdfba.tar.zst
freebsd-ports-graphics-4a62bd0a88ed97429f086f7791cfb751195fdfba.zip
- Stage support
- Update MASTER_SITES and WWW: line PR: 187050
Diffstat (limited to 'mail')
-rw-r--r--mail/asmail/Makefile47
-rw-r--r--mail/asmail/pkg-descr2
-rw-r--r--mail/asmail/pkg-plist6
3 files changed, 31 insertions, 24 deletions
diff --git a/mail/asmail/Makefile b/mail/asmail/Makefile
index 69297611ffc..a36d52eacc9 100644
--- a/mail/asmail/Makefile
+++ b/mail/asmail/Makefile
@@ -3,16 +3,14 @@
PORTNAME= asmail
PORTVERSION= 2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail afterstep
-MASTER_SITES= http://www.tigr.net/afterstep/download/asmail/
+MASTER_SITES= AFTERSTEP/apps/asmail/ \
+ http://tigr.net/afterstep/download/asmail/
MAINTAINER= ports@FreeBSD.org
COMMENT= Biff-type program, designed to match AfterStep
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-07
-
USE_XORG= xpm
USE_OPENSSL= yes
GNU_CONFIGURE= yes
@@ -21,27 +19,34 @@ CONFIGURE_ARGS= --enable-shaping \
--with-xpm-includes=${LOCALBASE}/include \
--with-xpm-library=${LOCALBASE}/lib
-MAN1= asmail.1x
-MAN5= asmailrc.5x
+LDFLAGS+= -pthread -lssl -lcrypto
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS} -lssl -lcrypto
+OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|machine/soundcard|sys/soundcard|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|@CFLAGS@ -D|@CFLAGS@ @CPPFLAGS@ -D|g ; \
- s|-lpthread -lrt|@LDFLAGS@|g' ${WRKSRC}/autoconf/Makefile.defines.in
@${REINPLACE_CMD} -e \
- 's|/usr/local|${PREFIX}|g' ${WRKSRC}/asmailrc.sample
+ 's|-lpthread|-pthread|g ; \
+ s|machine/soundcard|sys/soundcard|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/STRIP/s|^|#| ; \
+ s| \($$(AFTER_.*DIR)\)| $$(DESTDIR)\1| ; \
+ s|\.\([0-9]\)x|.\1|' \
+ ${WRKSRC}/autoconf/Makefile.common.in
+ @${REINPLACE_CMD} -e \
+ 's|@CFLAGS@ -D|@CFLAGS@ @CPPFLAGS@ -D|g ; \
+ s|-lpthread -lrt|@LDFLAGS@|g' \
+ ${WRKSRC}/autoconf/Makefile.defines.in
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/asmailrc.sample
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/asmailrc.sample ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} README \
+ ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} asmailrc.sample \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/mail/asmail/pkg-descr b/mail/asmail/pkg-descr
index 9382f7db0c5..f8dc5100f8a 100644
--- a/mail/asmail/pkg-descr
+++ b/mail/asmail/pkg-descr
@@ -3,4 +3,4 @@ look & feel. It indicates the status of your mailbox.
It can be put in the Wharf, execute a program on incoming mail,
execute a program upon mouseclick, show animations and more...
-WWW: http://www.tigr.net/afterstep/
+WWW: http://tigr.net/afterstep/
diff --git a/mail/asmail/pkg-plist b/mail/asmail/pkg-plist
index 75d69b56dc3..0c6d076a774 100644
--- a/mail/asmail/pkg-plist
+++ b/mail/asmail/pkg-plist
@@ -1,4 +1,6 @@
bin/asmail
+man/man1/asmail.1.gz
+man/man5/asmailrc.5.gz
%%DATADIR%%/pixmaps/e-no.xpm
%%DATADIR%%/pixmaps/e0.xpm
%%DATADIR%%/pixmaps/e1.xpm
@@ -65,8 +67,8 @@ bin/asmail
%%DATADIR%%/sounds/clink.au
%%DATADIR%%/sounds/drip.au
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/asmailrc.sample
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asmailrc.sample
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/sounds