aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2013-12-08 01:14:12 +0800
committerashish <ashish@FreeBSD.org>2013-12-08 01:14:12 +0800
commit4aa4f3bfa437db42602456344479b78bbecb6fdf (patch)
treed6a952e27131ea63bed6b5f3c1561a2b08ad4f44 /mail
parent7cd9495ae829481ad1b22c1b4533c7b000672fe4 (diff)
downloadfreebsd-ports-graphics-4aa4f3bfa437db42602456344479b78bbecb6fdf.tar.gz
freebsd-ports-graphics-4aa4f3bfa437db42602456344479b78bbecb6fdf.tar.zst
freebsd-ports-graphics-4aa4f3bfa437db42602456344479b78bbecb6fdf.zip
- Update to 5.4.1p1
- Update LICENSE information - Add OPTIONS for SQLITE, MYSQL, PGSQL, and LDAP - Add STAGE support - Add a note to UPDATING about change in configuration Changes: http://article.gmane.org/gmane.mail.opensmtpd.general/1146
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd/Makefile54
-rw-r--r--mail/opensmtpd/distinfo4
-rw-r--r--mail/opensmtpd/files/patch-bootstrap7
-rw-r--r--mail/opensmtpd/files/patch-mk_smtpd_Makefile.in (renamed from mail/opensmtpd/files/patch-smtpd_Makefile.am)10
-rw-r--r--mail/opensmtpd/pkg-descr2
-rw-r--r--mail/opensmtpd/pkg-plist26
6 files changed, 68 insertions, 35 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index 1617f6f5891..aae41ea4f2e 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= opensmtpd
-PORTVERSION= 5.3.3
+PORTVERSION= 5.4.1
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
@@ -13,34 +13,65 @@ MAINTAINER= ashish@FreeBSD.org
COMMENT= OpenSMTPD is a free MTA
LICENSE= ISCL
-LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent
-OPTIONS_DEFINE= PAM
+OPTIONS_DEFINE= PAM SQLITE MYSQL PGSQL LDAP
OPTIONS_DEFAULT= PAM
USE_AUTOTOOLS= autoconf:env automake:env libtool:env
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/
+CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/ \
+ --with-mailwrapper
USE_RC_SUBR= smtpd
SUB_FILES= pkg-install pkg-deinstall pkg-message
CONFLICTS_INSTALL= postfix-[0-9]* sendmail-[0-9]* opensmtpd-devel-[0-9]*
-MAN8= makemap.8 newaliases.8 smtpctl.8 smtpd.8
-MAN5= smtpd.conf.5 aliases.5 forward.5
-
USERS= _smtpd _smtpq _smtpf
GROUPS= _smtpd
-NO_STAGE= yes
.include <bsd.port.options.mk>
USE_OPENSSL= yes
+.if ${PORT_OPTIONS:MMYSQL}
+USE_MYSQL= yes
+CFLAGS+= -I${LOCALBASE}/include/mysql
+LDFLAGS+= -L${LOCALBASE}/lib/mysql
+CONFIGURE_ARGS+= --with-experimental-mysql
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+USE_SQLITE= 3
+CONFIGURE_ARGS+= --with-experimental-sqlite
+PLIST_SUB+= SQLITE=""
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.else
+PLIST_SUB+= SQLITE="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --with-experimental-postgres
+PLIST_SUB+= PGSQL=""
+.else
+PLIST_SUB+= PGSQL="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+CONFIGURE_ARGS+= --with-experimental-ldap
+PLIST_SUB+= LDAP=""
+.else
+PLIST_SUB+= LDAP="@comment "
+.endif
+
.if ${PORT_OPTIONS:MPAM}
CONFIGURE_ARGS+= --with-pam
.endif
@@ -50,13 +81,6 @@ CONFIGURE_ARGS+= --with-pam
WITH_OPENSSL_PORT= yes
.endif
-pre-configure:
- @cd ${WRKSRC} && ./bootstrap
-
-post-install:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
-
post-deinstall:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
diff --git a/mail/opensmtpd/distinfo b/mail/opensmtpd/distinfo
index 37f262ec131..49f2a1c481a 100644
--- a/mail/opensmtpd/distinfo
+++ b/mail/opensmtpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opensmtpd-5.3.3p1.tar.gz) = 34f0e208e6fdde5c5c25bb11f468436c4d6148a8b640c32117869cad140b823c
-SIZE (opensmtpd-5.3.3p1.tar.gz) = 343733
+SHA256 (opensmtpd-5.4.1p1.tar.gz) = 7debbf7e55ff3687617ae2c3b38e1cf30574b96f56b869e597c0e98478e5b5d9
+SIZE (opensmtpd-5.4.1p1.tar.gz) = 871745
diff --git a/mail/opensmtpd/files/patch-bootstrap b/mail/opensmtpd/files/patch-bootstrap
deleted file mode 100644
index 6ad5a2ffbca..00000000000
--- a/mail/opensmtpd/files/patch-bootstrap
+++ /dev/null
@@ -1,7 +0,0 @@
---- bootstrap.orig 2013-06-04 08:13:28.000000000 +0000
-+++ bootstrap 2013-07-23 20:06:15.000000000 +0000
-@@ -38,3 +38,3 @@
- amvers="no"
--for v in 13 12 11 10 9 8 7 6 5; do
-+for v in 14 13 12 11 10 9 8 7 6 5; do
- if automake-1.${v} --version >/dev/null 2>&1; then
diff --git a/mail/opensmtpd/files/patch-smtpd_Makefile.am b/mail/opensmtpd/files/patch-mk_smtpd_Makefile.in
index 7db3013e179..9fa435ac5df 100644
--- a/mail/opensmtpd/files/patch-smtpd_Makefile.am
+++ b/mail/opensmtpd/files/patch-mk_smtpd_Makefile.in
@@ -1,9 +1,9 @@
$FreeBSD$
---- smtpd/Makefile.am.orig
-+++ smtpd/Makefile.am
-@@ -162,11 +162,7 @@
+--- mk/smtpd/Makefile.in.orig
++++ mk/smtpd/Makefile.in
+@@ -1906,11 +1906,7 @@
$(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)5
$(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)8
@@ -14,5 +14,5 @@ $FreeBSD$
- fi
+ $(INSTALL) -m 644 smtpd.conf.out $(DESTDIR)$(sysconfdir)/smtpd.conf.sample
- ln -f $(DESTDIR)$(sbindir)/smtpctl$(EXEEXT) \
- $(DESTDIR)$(bindir)/mailq$(EXEEXT);
+ $(INSTALL) -m 644 aliases.5.out $(DESTDIR)$(mandir)/$(mansubdir)5/aliases.5
+ $(INSTALL) -m 644 forward.5.out $(DESTDIR)$(mandir)/$(mansubdir)5/forward.5
diff --git a/mail/opensmtpd/pkg-descr b/mail/opensmtpd/pkg-descr
index f5bcb42c0cb..e5cefc4f46e 100644
--- a/mail/opensmtpd/pkg-descr
+++ b/mail/opensmtpd/pkg-descr
@@ -3,4 +3,4 @@ defined by RFC 5321, with some additional standard extensions. It
allows ordinary machines to exchange e-mails with other systems
speaking the SMTP protocol.
-WWW: http://www.OpenSMTPD.org/
+WWW: http://www.OpenSMTPD.org/
diff --git a/mail/opensmtpd/pkg-plist b/mail/opensmtpd/pkg-plist
index abd7a14e4b3..e1b368da7cc 100644
--- a/mail/opensmtpd/pkg-plist
+++ b/mail/opensmtpd/pkg-plist
@@ -1,10 +1,26 @@
-bin/mailq
-bin/newaliases
-bin/smtpscript
etc/mail/smtpd.conf.sample
-libexec/mail.local
+libexec/opensmtpd/mail.local
libexec/opensmtpd/makemap
-sbin/makemap
+libexec/opensmtpd/queue-null
+libexec/opensmtpd/queue-ram
+libexec/opensmtpd/queue-stub
+libexec/opensmtpd/table-stub
+libexec/opensmtpd/table-passwd
+%%MYSQL%%libexec/opensmtpd/table-mysql
+%%SQLITE%%libexec/opensmtpd/table-sqlite
+%%LDAP%%libexec/opensmtpd/table-ldap
+%%PGSQL%%libexec/opensmtpd/table-postgres
+libexec/opensmtpd/scheduler-ram
+libexec/opensmtpd/scheduler-stub
+man/man8/makemap.8.gz
+man/man8/newaliases.8.gz
+man/man8/sendmail.8.gz
+man/man8/smtpctl.8.gz
+man/man8/smtpd.8.gz
+man/man5/forward.5.gz
+man/man5/aliases.5.gz
+man/man5/table.5.gz
+man/man5/smtpd.conf.5.gz
sbin/smtpctl
sbin/smtpd
@dirrm libexec/opensmtpd