aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-03 18:06:09 +0800
committerknu <knu@FreeBSD.org>2001-09-03 18:06:09 +0800
commit52d55125457c5b7f2147cf82d7fbffdd970395fa (patch)
treedf9f66d279e8390af047127052da3fd36a1877b1 /mail
parent8c1a03601325668bd75560eb01693e345018f178 (diff)
downloadfreebsd-ports-graphics-52d55125457c5b7f2147cf82d7fbffdd970395fa.tar.gz
freebsd-ports-graphics-52d55125457c5b7f2147cf82d7fbffdd970395fa.tar.zst
freebsd-ports-graphics-52d55125457c5b7f2147cf82d7fbffdd970395fa.zip
Add emh-emacs20 and emh-xemacs21-mule, MIME extension of mh-e.el.
PR: ports/26511 Submitted by: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile2
-rw-r--r--mail/emh-emacs20/Makefile33
-rw-r--r--mail/emh-emacs20/distinfo1
-rw-r--r--mail/emh-emacs20/pkg-comment1
-rw-r--r--mail/emh-emacs20/pkg-descr1
-rw-r--r--mail/emh-emacs20/pkg-plist11
-rw-r--r--mail/emh-xemacs21-mule/Makefile17
-rw-r--r--mail/emh/Makefile33
-rw-r--r--mail/emh/distinfo1
-rw-r--r--mail/emh/pkg-comment1
-rw-r--r--mail/emh/pkg-descr1
-rw-r--r--mail/emh/pkg-plist11
12 files changed, 113 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ff0abc75661..2248609d45a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -28,6 +28,8 @@
SUBDIR += drac
SUBDIR += elm
SUBDIR += elm+ME
+ SUBDIR += emh-emacs20
+ SUBDIR += emh-xemacs21-mule
SUBDIR += emil
SUBDIR += evolution
SUBDIR += exim
diff --git a/mail/emh-emacs20/Makefile b/mail/emh-emacs20/Makefile
new file mode 100644
index 00000000000..80a8775b3d6
--- /dev/null
+++ b/mail/emh-emacs20/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: emh
+# Date Created: 12 Mar 2001
+# Whom: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emh
+PORTVERSION= 1.10.1
+CATEGORIES= mail elisp
+MASTER_SITES= ftp://ftp.m17n.org/pub/mule/semi/emh/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= yoichi@eken.phys.nagoya-u.ac.jp
+
+BUILD_DEPENDS+= ${LOCALBASE}/share/semi/${MIMEUI_COOKIE}:${PORTSDIR}/editors/${MIMEUI_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/share/semi/${MIMEUI_COOKIE}:${PORTSDIR}/editors/${MIMEUI_PORT_NAME}
+
+MIMEUI_PRODUCT?= semi
+MIMEUI_VERSION?= 1.13.7
+MIMEUI_PORT_NAME?= ${MIMEUI_PRODUCT}-${EMACS_PORT_NAME}-current
+MIMEUI_COOKIE= ${MIMEUI_PRODUCT}-${EMACS_PORT_NAME}-${MIMEUI_VERSION}.FreeBSD-packages
+
+EMACS_PORT_NAME?= emacs20
+
+ALL_TARGET?= elc
+EMH_LISPDIR?= share/emacs/site-lisp/semi
+XEMACS_ONLY?= "@comment "
+
+PLIST_SUB= XEMACS_ONLY=${XEMACS_ONLY} \
+ EMH_LISPDIR=${EMH_LISPDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/emh-emacs20/distinfo b/mail/emh-emacs20/distinfo
new file mode 100644
index 00000000000..3bce96d3ad8
--- /dev/null
+++ b/mail/emh-emacs20/distinfo
@@ -0,0 +1 @@
+MD5 (emh-1.10.1.tar.gz) = c99c6b51bed0bab66a621b21accce089
diff --git a/mail/emh-emacs20/pkg-comment b/mail/emh-emacs20/pkg-comment
new file mode 100644
index 00000000000..397605f847b
--- /dev/null
+++ b/mail/emh-emacs20/pkg-comment
@@ -0,0 +1 @@
+MIME extension of mh-e.el
diff --git a/mail/emh-emacs20/pkg-descr b/mail/emh-emacs20/pkg-descr
new file mode 100644
index 00000000000..dece215e01e
--- /dev/null
+++ b/mail/emh-emacs20/pkg-descr
@@ -0,0 +1 @@
+EMH is a extender for mh-e to provide MIME feature using SEMI.
diff --git a/mail/emh-emacs20/pkg-plist b/mail/emh-emacs20/pkg-plist
new file mode 100644
index 00000000000..f05746ffeb7
--- /dev/null
+++ b/mail/emh-emacs20/pkg-plist
@@ -0,0 +1,11 @@
+%%EMH_LISPDIR%%/emh.el
+%%EMH_LISPDIR%%/emh.elc
+%%EMH_LISPDIR%%/emh-comp.el
+%%EMH_LISPDIR%%/emh-comp.elc
+%%EMH_LISPDIR%%/emh-face.el
+%%EMH_LISPDIR%%/emh-face.elc
+%%EMH_LISPDIR%%/emh-setup.el
+%%EMH_LISPDIR%%/emh-setup.elc
+%%XEMACS_ONLY%%%%EMH_LISPDIR%%/custom-load.el
+%%XEMACS_ONLY%%%%EMH_LISPDIR%%/custom-load.elc
+%%XEMACS_ONLY%%@dirrm %%EMH_LISPDIR%%
diff --git a/mail/emh-xemacs21-mule/Makefile b/mail/emh-xemacs21-mule/Makefile
new file mode 100644
index 00000000000..18bc853850c
--- /dev/null
+++ b/mail/emh-xemacs21-mule/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: emh-xemacs21-mule
+# Date Created: 12 Mar 2001
+# Whom: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../emh-emacs20
+
+EMACS_PORT_NAME= xemacs21-mule
+
+ALL_TARGET= package
+INSTALL_TARGET= install-package
+EMH_LISPDIR= lib/xemacs/site-packages/lisp/emh
+XEMACS_ONLY= ""
+
+.include <${MASTERDIR}/Makefile>
diff --git a/mail/emh/Makefile b/mail/emh/Makefile
new file mode 100644
index 00000000000..80a8775b3d6
--- /dev/null
+++ b/mail/emh/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: emh
+# Date Created: 12 Mar 2001
+# Whom: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emh
+PORTVERSION= 1.10.1
+CATEGORIES= mail elisp
+MASTER_SITES= ftp://ftp.m17n.org/pub/mule/semi/emh/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= yoichi@eken.phys.nagoya-u.ac.jp
+
+BUILD_DEPENDS+= ${LOCALBASE}/share/semi/${MIMEUI_COOKIE}:${PORTSDIR}/editors/${MIMEUI_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/share/semi/${MIMEUI_COOKIE}:${PORTSDIR}/editors/${MIMEUI_PORT_NAME}
+
+MIMEUI_PRODUCT?= semi
+MIMEUI_VERSION?= 1.13.7
+MIMEUI_PORT_NAME?= ${MIMEUI_PRODUCT}-${EMACS_PORT_NAME}-current
+MIMEUI_COOKIE= ${MIMEUI_PRODUCT}-${EMACS_PORT_NAME}-${MIMEUI_VERSION}.FreeBSD-packages
+
+EMACS_PORT_NAME?= emacs20
+
+ALL_TARGET?= elc
+EMH_LISPDIR?= share/emacs/site-lisp/semi
+XEMACS_ONLY?= "@comment "
+
+PLIST_SUB= XEMACS_ONLY=${XEMACS_ONLY} \
+ EMH_LISPDIR=${EMH_LISPDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/emh/distinfo b/mail/emh/distinfo
new file mode 100644
index 00000000000..3bce96d3ad8
--- /dev/null
+++ b/mail/emh/distinfo
@@ -0,0 +1 @@
+MD5 (emh-1.10.1.tar.gz) = c99c6b51bed0bab66a621b21accce089
diff --git a/mail/emh/pkg-comment b/mail/emh/pkg-comment
new file mode 100644
index 00000000000..397605f847b
--- /dev/null
+++ b/mail/emh/pkg-comment
@@ -0,0 +1 @@
+MIME extension of mh-e.el
diff --git a/mail/emh/pkg-descr b/mail/emh/pkg-descr
new file mode 100644
index 00000000000..dece215e01e
--- /dev/null
+++ b/mail/emh/pkg-descr
@@ -0,0 +1 @@
+EMH is a extender for mh-e to provide MIME feature using SEMI.
diff --git a/mail/emh/pkg-plist b/mail/emh/pkg-plist
new file mode 100644
index 00000000000..f05746ffeb7
--- /dev/null
+++ b/mail/emh/pkg-plist
@@ -0,0 +1,11 @@
+%%EMH_LISPDIR%%/emh.el
+%%EMH_LISPDIR%%/emh.elc
+%%EMH_LISPDIR%%/emh-comp.el
+%%EMH_LISPDIR%%/emh-comp.elc
+%%EMH_LISPDIR%%/emh-face.el
+%%EMH_LISPDIR%%/emh-face.elc
+%%EMH_LISPDIR%%/emh-setup.el
+%%EMH_LISPDIR%%/emh-setup.elc
+%%XEMACS_ONLY%%%%EMH_LISPDIR%%/custom-load.el
+%%XEMACS_ONLY%%%%EMH_LISPDIR%%/custom-load.elc
+%%XEMACS_ONLY%%@dirrm %%EMH_LISPDIR%%