aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2010-01-22 14:47:02 +0800
committerclsung <clsung@FreeBSD.org>2010-01-22 14:47:02 +0800
commit5302e808d50094ff9504c7efb491819730d2fb60 (patch)
tree877c39c803f42f0c151e7b23a77c2d60da860a0a /mail
parentd56f4a6c686d3307f271b801bbe9833ed9e44d3b (diff)
downloadfreebsd-ports-graphics-5302e808d50094ff9504c7efb491819730d2fb60.tar.gz
freebsd-ports-graphics-5302e808d50094ff9504c7efb491819730d2fb60.tar.zst
freebsd-ports-graphics-5302e808d50094ff9504c7efb491819730d2fb60.zip
Net::POP3::SSLWrapper is simple POP3S wrapper for Net::POP3.
You can easy to support POP3S, with very small code change. PR: ports/141694 Submitted by: johnpupu <johnpupu_AT_gmail dot com>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Net-POP3-SSLWrapper/Makefile25
-rw-r--r--mail/p5-Net-POP3-SSLWrapper/distinfo3
-rw-r--r--mail/p5-Net-POP3-SSLWrapper/pkg-descr5
-rw-r--r--mail/p5-Net-POP3-SSLWrapper/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 76db0a9c70f..e38ea309a71 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -423,6 +423,7 @@
SUBDIR += p5-Net-IMAP-Simple
SUBDIR += p5-Net-IMAP-Simple-SSL
SUBDIR += p5-Net-ManageSieve
+ SUBDIR += p5-Net-POP3-SSLWrapper
SUBDIR += p5-Net-QMTP
SUBDIR += p5-Net-SMTP-SSL
SUBDIR += p5-Net-SMTP-Server
diff --git a/mail/p5-Net-POP3-SSLWrapper/Makefile b/mail/p5-Net-POP3-SSLWrapper/Makefile
new file mode 100644
index 00000000000..cb0ffe58664
--- /dev/null
+++ b/mail/p5-Net-POP3-SSLWrapper/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-POP3-SSLWrapper
+# Date created: 16 December 2009
+# Whom: johnpupu <johnpupu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-POP3-SSLWrapper
+PORTVERSION= 0.02
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= johnpupu@gmail.com
+COMMENT= Perl extension for simple POP3S wrapper for Net::POP3
+
+RUN_DEPENDS= p5-IO-Socket-SSL>0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-ExtUtils-MakeMaker>0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::POP3::SSLWrapper.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Net-POP3-SSLWrapper/distinfo b/mail/p5-Net-POP3-SSLWrapper/distinfo
new file mode 100644
index 00000000000..6a1a5f879c5
--- /dev/null
+++ b/mail/p5-Net-POP3-SSLWrapper/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-POP3-SSLWrapper-0.02.tar.gz) = 1ef50e46ac902290be782004dc306f10
+SHA256 (Net-POP3-SSLWrapper-0.02.tar.gz) = 7ba38d76072a6dfbcf7ec7c4056cbad4cc5adf9c5449a477116c57cf6c2c57ad
+SIZE (Net-POP3-SSLWrapper-0.02.tar.gz) = 34630
diff --git a/mail/p5-Net-POP3-SSLWrapper/pkg-descr b/mail/p5-Net-POP3-SSLWrapper/pkg-descr
new file mode 100644
index 00000000000..f7692b66a4c
--- /dev/null
+++ b/mail/p5-Net-POP3-SSLWrapper/pkg-descr
@@ -0,0 +1,5 @@
+Net::POP3::SSLWrapper is simple POP3S wrapper for Net::POP3.
+
+You can easy to support POP3S, with very small code change.
+
+WWW: http://search.cpan.org/dist/Net-POP3-SSLWrapper/
diff --git a/mail/p5-Net-POP3-SSLWrapper/pkg-plist b/mail/p5-Net-POP3-SSLWrapper/pkg-plist
new file mode 100644
index 00000000000..51dd4ded48a
--- /dev/null
+++ b/mail/p5-Net-POP3-SSLWrapper/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/POP3/SSLWrapper.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/POP3/SSLWrapper/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/POP3/SSLWrapper
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/POP3
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/POP3
+@dirrmtry %%SITE_PERL%%/Net