aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2003-12-13 08:42:15 +0800
committersergei <sergei@FreeBSD.org>2003-12-13 08:42:15 +0800
commit568a04ccb4ba8397cbc239d8149706b968554982 (patch)
tree3eaa6127a46de28010c1660fb8837dea5033b994 /mail
parent72bb762770dd74931ad4d63d2e02a43bd01837db (diff)
downloadfreebsd-ports-graphics-568a04ccb4ba8397cbc239d8149706b968554982.tar.gz
freebsd-ports-graphics-568a04ccb4ba8397cbc239d8149706b968554982.tar.zst
freebsd-ports-graphics-568a04ccb4ba8397cbc239d8149706b968554982.zip
Add p5-Email-Filter 1.0, library for creating easy email filters.
This is another module produced by the "Perl Email Project", a reaction against the complexity and increasing bugginess of the "Mail::*" modules. It replaces Mail::Audit, and allows you to write programs describing how your mail should be filtered. WWW: http://search.cpan.org/dist/Email-Filter PR: 59617 Submitted by: Lars Thegler <lars@thegler.dk>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Email-Filter/Makefile31
-rw-r--r--mail/p5-Email-Filter/distinfo1
-rw-r--r--mail/p5-Email-Filter/pkg-descr6
-rw-r--r--mail/p5-Email-Filter/pkg-plist6
5 files changed, 45 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index a7a9e479347..8f9667c243c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -193,6 +193,7 @@
SUBDIR += nullmailer
SUBDIR += offlineimap
SUBDIR += openwebmail
+ SUBDIR += p5-Email-Filter
SUBDIR += p5-Email-Find
SUBDIR += p5-Email-Folder
SUBDIR += p5-Email-FolderType
diff --git a/mail/p5-Email-Filter/Makefile b/mail/p5-Email-Filter/Makefile
new file mode 100644
index 00000000000..93af6b6ecb3
--- /dev/null
+++ b/mail/p5-Email-Filter/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Email-Filter
+# Date created: 2003-08-31
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-Filter
+PORTVERSION= 1.0
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Library for creating easy email filters
+
+BUILD_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/Email/LocalDelivery.pm:${PORTSDIR}/mail/p5-Email-LocalDelivery \
+ ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
+ ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::Filter.3
+
+test: build
+ cd ${WRKSRC} ; make test
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Filter/distinfo b/mail/p5-Email-Filter/distinfo
new file mode 100644
index 00000000000..f047f0c7716
--- /dev/null
+++ b/mail/p5-Email-Filter/distinfo
@@ -0,0 +1 @@
+MD5 (Email-Filter-1.0.tar.gz) = 857a522c2c43991f59c65de9c8c05d40
diff --git a/mail/p5-Email-Filter/pkg-descr b/mail/p5-Email-Filter/pkg-descr
new file mode 100644
index 00000000000..057d13b99e8
--- /dev/null
+++ b/mail/p5-Email-Filter/pkg-descr
@@ -0,0 +1,6 @@
+This is another module produced by the "Perl Email Project", a reaction
+against the complexity and increasing bugginess of the "Mail::*"
+modules. It replaces Mail::Audit, and allows you to write programs
+describing how your mail should be filtered.
+
+WWW: http://search.cpan.org/dist/Email-Filter
diff --git a/mail/p5-Email-Filter/pkg-plist b/mail/p5-Email-Filter/pkg-plist
new file mode 100644
index 00000000000..e307b2f2cde
--- /dev/null
+++ b/mail/p5-Email-Filter/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Email/Filter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Filter/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Filter
+@unexec rmdir %D/%%SITE_PERL%%/Email 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email 2>/dev/null || true